Home of the Squeezebox™ & Transporter® network music players.
Page 102 of 105 FirstFirst ... 25292100101102103104 ... LastLast
Results 1,011 to 1,020 of 1043
  1. #1011
    Babelfish's Best Boy mherger's Avatar
    Join Date
    Apr 2005
    Location
    Switzerland
    Posts
    20,351

    Announce: Music & Artist Informationplugin

    > MAI made scan terminate in failure when failing to connect to last.fm

    Oops... I thought I had fixed this. I did, but I forgot to release it...
    will do shortly.

    --

    Michael

  2. #1012
    Senior Member
    Join Date
    Apr 2005
    Location
    UK/London
    Posts
    1,971
    Can we have a mechanism to prevent checking remote sites for a particular album review (or for a particular set)?
    I guess I could do it by putting in a blank review file in each album folder but better would be to be able to (perhaps by a set of regex) exclude certain albums.

    I suggest this only because I have a number of albums that I know will never be reviewed because they are my own radio show recordings.
    It probably does no harm for the lookup to fail - but being able to avoid them completely might be kinder to the remote sites that host the genuine reviews.

    Imagine I have a set of recordings of a radio show called "Interesting Radio Programme" and I store them like albums - with the album title of
    Interesting Radio Programme - 1973/12/25
    Interesting Radio Programme - 1974/01/01
    Interesting Radio Programme - 1974/01/08

    Then I could prevent reviews by having a regex that looks for "^Interesting Radio Programme - "
    If I had a different radio show called "Different Show" where I used the same scheme ... then I could have one regex that matched them both ...
    " - [1-2][0-9][0-9][0-9]/[0-1][0-9]/[0-3][0-9]$"
    with little chance that it would match others ... and with little consequence if it did.
    Paul Webster
    http://dabdig.blogspot.com
    Author Radio France (FIP etc) plugin

  3. #1013
    Babelfish's Best Boy mherger's Avatar
    Join Date
    Apr 2005
    Location
    Switzerland
    Posts
    20,351

    Announce: Music & Artist Informationplugin

    > Can we have a mechanism to prevent checking remote sites for a
    > particular album review (or for a particular set)?


    It certainly could be done. But I don't want to add yet another option
    to the already rather busy settings page. In particular an option which
    would require quite a bit of knowledge to even use (regex).

    > I guess I could do it by putting in a blank review file in each album
    > folder but better would be to be able to (perhaps by a set of regex)
    > exclude certain albums.


    I'd much prefer this "solution" :-D.

    > I suggest this only because I have a number of albums that I know will
    > never be reviewed because they are my own radio show recordings.


    Do they change often? Putting an empty file in those places should be
    perfectly feasible, right?

    > It probably does no harm for the lookup to fail - but being able to
    > avoid them completely might be kinder to the remote sites that host the
    > genuine reviews.


    Review lookup isn't a high volume task.

    > Imagine I have a set of recordings of a radio show called "Interesting
    > Radio Programme" and I store them like albums - with the album title of
    > Interesting Radio Programme - 1973/12/25


    Do you also store an artist? If not, no review would be looked up anyway.

    --

    Michael

  4. #1014
    Senior Member
    Join Date
    Oct 2008
    Location
    The Hague, Netherlands
    Posts
    138

    update NL translation

    Hi Michael,
    I have updated the NL strings as not all were translated in the latest version.
    Could you please add it to the next version?
    thx!
    Attached Files Attached Files
    Living: EtherRegen -> Ultrarendu -> Benchmark DAC2 HGC -> Benchmark AHB2 -> ATC SCM19 v2 & Sennheiser HD650
    Kitchen: SB Touch -> Audio Pro Addon T10 gen2
    Kids rooms: SB Booms
    Bedroom: SB Boom & SB Radio
    Controls: iPeng, Material Skin & LMS via internet
    Server: Windows 10 Pro with LMS 7.9.2
    Spare: 2 SB Touch, 1 SB3, 2 SB Radio

  5. #1015
    Babelfish's Best Boy mherger's Avatar
    Join Date
    Apr 2005
    Location
    Switzerland
    Posts
    20,351

    Announce: Music & Artist Informationplugin

    Hi Blackfiction

    I finally wanted to merge your strings updates. But all I'm seeing is
    three strings which are identical with the English
    (Websites/Credits/Videos). Is this correct? There's no need to add them
    if they're identical anyway. They would be displayed correctly already,
    wouldn't they?

    --

    Michael

  6. #1016
    Junior Member
    Join Date
    Jul 2011
    Posts
    14

    After latest LMS update this plugin appears to cause a fault with LMS

    Hi,

    I've been using this great plugin for ages and never had any probs. I updated to the latest LMS the day before.
    Today when browsing through "album artists" using orange for android the LMS server terminated. I restarted LMS and every time I browsed it terminated. I cleared and rescanned the library but still the same issue.
    I then removed the plugin and did a clear and rescan and browsing "album artist" is fine. But now without all my artist artwork and info and lots of other great things this plugin does.

    LMS log entry followed by Windows log entry:

    [20-01-15 15:30:36.6350] Plugins::MusicArtistInfo::Common::__ANON__ (119) Failed to call https://www.last.fm/music/CLAIRE%20M...ODNEY/+images: 404 NOT FOUND


    Log Name: Application
    Source: Application Error
    Date: 15/01/2020 15:30:37
    Event ID: 1000
    Task Category: (100)
    Level: Error
    Keywords: Classic
    User: N/A
    Computer: Audio-Server
    Description:
    Faulting application name: SqueezeSvr.exe, version: 45394.0.0.0, time stamp: 0x4e209f7a
    Faulting module name: EV.dll, version: 0.0.0.0, time stamp: 0x4e551770
    Exception code: 0x40000015
    Fault offset: 0x00001488
    Faulting process ID: 0x33dc
    Faulting application start time: 0x01d5cbb8987fe28d
    Faulting application path: C:\PROGRA~2\SQUEEZ~1\server\SqueezeSvr.exe
    Faulting module path: C:\WINDOWS\TEMP\pdk-SYSTEM-13276\7f177c338672436e01c4f0bdbcf94491\EV.dll
    Report ID: 0e6d3969-75fa-441d-a959-5468cb6daa23
    Faulting package full name:
    Faulting package-relative application ID:
    Event Xml:
    <Event xmlns="http://schemas.microsoft.com/win/2004/08/events/event">
    <System>
    <Provider Name="Application Error" />
    <EventID Qualifiers="0">1000</EventID>
    <Level>2</Level>
    <Task>100</Task>
    <Keywords>0x80000000000000</Keywords>
    <TimeCreated SystemTime="2020-01-15T15:30:37.220606100Z" />
    <EventRecordID>10308</EventRecordID>
    <Channel>Application</Channel>
    <Computer>Audio-Server</Computer>
    <Security />
    </System>
    <EventData>
    <Data>SqueezeSvr.exe</Data>
    <Data>45394.0.0.0</Data>
    <Data>4e209f7a</Data>
    <Data>EV.dll</Data>
    <Data>0.0.0.0</Data>
    <Data>4e551770</Data>
    <Data>40000015</Data>
    <Data>00001488</Data>
    <Data>33dc</Data>
    <Data>01d5cbb8987fe28d</Data>
    <Data>C:\PROGRA~2\SQUEEZ~1\server\SqueezeSvr.exe </Data>
    <Data>C:\WINDOWS\TEMP\pdk-SYSTEM-13276\7f177c338672436e01c4f0bdbcf94491\EV.dll</Data>
    <Data>0e6d3969-75fa-441d-a959-5468cb6daa23</Data>
    <Data>
    </Data>
    <Data>
    </Data>
    </EventData>
    </Event>
    Faulting application name: SqueezeSvr.exe, version: 45394.0.0.0, time stamp: 0x4e209f7a
    Log Name: System
    Source: Service Control Manager
    Date: 15/01/2020 15:30:38
    Event ID: 7034
    Task Category: None
    Level: Error
    Keywords: Classic
    User: N/A
    Computer: Audio-Server
    Description:
    The Logitech Media Server service terminated unexpectedly. It has done this 1 time(s).
    Event Xml:
    <Event xmlns="http://schemas.microsoft.com/win/2004/08/events/event">
    <System>
    <Provider Name="Service Control Manager" Guid="{555908d1-a6d7-4695-8e1e-26931d2012f4}" EventSourceName="Service Control Manager" />
    <EventID Qualifiers="49152">7034</EventID>
    <Version>0</Version>
    <Level>2</Level>
    <Task>0</Task>
    <Opcode>0</Opcode>
    <Keywords>0x8080000000000000</Keywords>
    <TimeCreated SystemTime="2020-01-15T15:30:38.708800900Z" />
    <EventRecordID>12204</EventRecordID>
    <Correlation />
    <Execution ProcessID="752" ThreadID="7040" />
    <Channel>System</Channel>
    <Computer>Audio-Server</Computer>
    <Security />
    </System>
    <EventData>
    <Data Name="param1">Logitech Media Server</Data>
    <Data Name="param2">1</Data>
    <Binary>730071007500650065007A00650073007600630000 00</Binary>
    </EventData>
    </Event>

  7. #1017
    Babelfish's Best Boy mherger's Avatar
    Join Date
    Apr 2005
    Location
    Switzerland
    Posts
    20,351

    Announce: Music & Artist Informationplugin

    > I've been using this great plugin for ages and never had any probs. I
    > updated to the latest LMS the day before.


    7.9.2?

    > Today when browsing through "album artists" using orange for android the
    > LMS server terminated. I restarted LMS and every time I browsed it
    > terminated. I cleared and rescanned the library but still the same
    > issue.


    What if you used the web UI?

    > I then removed the plugin and did a clear and rescan and browsing "album
    > artist" is fine. But now without all my artist artwork and info and lots
    > of other great things this plugin does.


    You can turn off display of the artwork in the artist list and continue
    to use the other features.

    > LMS log entry followed by Windows log entry:
    >
    > [20-01-15 15:30:36.6350] Plugins::MusicArtistInfo::Common::__ANON__
    > (119) Failed to call
    > https://www.last.fm/music/CLAIRE%20M...ODNEY/+images:
    > 404 NOT FOUND


    This should not crash LMS. Is it always this one picture? What if you
    stored an artist.jpg for this artist in your folder?


    --

    Michael

  8. #1018
    Junior Member
    Join Date
    Jul 2011
    Posts
    14
    Many thanks for your quick reply.

    I will give your suggestions a go and report back

  9. #1019
    Junior Member
    Join Date
    Jul 2011
    Posts
    14
    Hi,

    The same thing happens in Webui.

    Also Ive found a quick way to crash the LMS server, just go to artist information>pictures. This does not produce an entry in the LMS server log but you get the same windows app log fault with module EV.DLL
    I also did a rescan and downloaded all the artist artwork into a defined folder. The scan worked fine but made no difference.

    As a last resort I installed an early version of 7.9.2 (v7.9.2, 1527493162, Mon May 28 10:08:13 WEDT 2018) and all works ok again, all pictures accessed via "artist information>pictures" download without error.

    So I reinstalled version v7.9.2, 1578996832, Tue Jan 14 12:09:46 WEST 2020 and "artist information>pictures" cause a crash again with the fault caused by module EV.DLL

    Is there anyway I can access previous builds of LMS, that way I can narrow down when this started to happen? May 2018 seems a long time ago.

    The crash only occurs if the picture is not cached locally and needs to go online to retrieve it. I think the "image Not found error" in the LMS server log is not the issue, I think LMS crashes when it finds an image to download.

  10. #1020
    Senior Member
    Join Date
    Jan 2010
    Location
    Hertfordshire
    Posts
    3,391
    Quote Originally Posted by ajs6000 View Post
    Hi,

    The same thing happens in Webui.

    Also Ive found a quick way to crash the LMS server, just go to artist information>pictures. This does not produce an entry in the LMS server log but you get the same windows app log fault with module EV.DLL
    I also did a rescan and downloaded all the artist artwork into a defined folder. The scan worked fine but made no difference.

    As a last resort I installed an early version of 7.9.2 (v7.9.2, 1527493162, Mon May 28 10:08:13 WEDT 2018) and all works ok again, all pictures accessed via "artist information>pictures" download without error.

    So I reinstalled version v7.9.2, 1578996832, Tue Jan 14 12:09:46 WEST 2020 and "artist information>pictures" cause a crash again with the fault caused by module EV.DLL

    Is there anyway I can access previous builds of LMS, that way I can narrow down when this started to happen? May 2018 seems a long time ago.

    The crash only occurs if the picture is not cached locally and needs to go online to retrieve it. I think the "image Not found error" in the LMS server log is not the issue, I think LMS crashes when it finds an image to download.
    I tried adding the MAI plugin on my Windows 10 machine with virtually no music on it and LMS stopped responding. I wasn't even trying to access artist pictures. I clicked on Album Artists and it seemed to crash. Something odd is happening on Windows as it works fine on a Pi.

    Sent from my Pixel 3a using Tapatalk

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •