Home of the Squeezebox™ & Transporter® network music players.
Page 1 of 2 12 LastLast
Results 1 to 10 of 16
  1. #1
    Senior Member
    Join Date
    May 2005
    Location
    UK
    Posts
    711

    Assign playlist to preset button on Boom (or Radio)

    Hi,

    Can anyone tell me how to assign a playlist to a preset button on the Boom or Radio? I tried starting the playlist and then holding the preset button, but that just assigned the currently playing track to it.

    I want to define a playlist that plays a few tracks then switches to a live radio stream, and have this available from a button on the devices.

    Thanks

    Andy

  2. #2
    Senior Member kidstypike's Avatar
    Join Date
    Feb 2007
    Location
    Brindle
    Posts
    3,256
    Quote Originally Posted by adhawkins View Post
    Hi,

    Can anyone tell me how to assign a playlist to a preset button on the Boom or Radio? I tried starting the playlist and then holding the preset button, but that just assigned the currently playing track to it.

    I want to define a playlist that plays a few tracks then switches to a live radio stream, and have this available from a button on the devices.

    Thanks

    Andy
    With the playlist name highlighted, press and hold a preset button.
    Server - LMS 7.9.2 Pi4B 4GB/pCP 6.0.0-b6 18K library, playlists & LMS cache on SSD (ntfs)
    Study - Pi3B+/pCP 5.0.0/pi screen/HiFiBerry DAC+/jivelite,
    Lounge - Pi2/pCP 5.0.0 > HiFiBerry DIGI+ > AudioEngine DAC1 > AVI DM5
    Dining Room - Squeezebox Boom
    Garage - Pi3B/Pi screen/HiFiBerry DAC+/pCP 5.0.0 > Edifier R980T

    Spares - 2xTouch, 1xSB3, 1xRadio, 6xRPi

  3. #3
    Senior Member
    Join Date
    May 2005
    Location
    UK
    Posts
    711

    Assign playlist to preset button on Boom(or Radio)

    Hi,

    In article <kidstypike.60bx1z (AT) no-mx (DOT) forums.slimdevices.com>,
    kidstypike<kidstypike.60bx1z (AT) no-mx (DOT) forums.slimdevices.com> wrote:
    > With the playlist name highlighted, press and hold a preset button.


    So I do this while browsing My Music -> Playlists?

    Thanks, I'll give it a go.

    Cheers

    Andy


  4. #4
    Senior Member kidstypike's Avatar
    Join Date
    Feb 2007
    Location
    Brindle
    Posts
    3,256
    Quote Originally Posted by adhawkins View Post
    Hi,

    In article <kidstypike.60bx1z (AT) no-mx (DOT) forums.slimdevices.com>,
    kidstypike<kidstypike.60bx1z (AT) no-mx (DOT) forums.slimdevices.com> wrote:
    > With the playlist name highlighted, press and hold a preset button.


    So I do this while browsing My Music -> Playlists?

    Thanks, I'll give it a go.

    Cheers

    Andy
    Yes.
    Server - LMS 7.9.2 Pi4B 4GB/pCP 6.0.0-b6 18K library, playlists & LMS cache on SSD (ntfs)
    Study - Pi3B+/pCP 5.0.0/pi screen/HiFiBerry DAC+/jivelite,
    Lounge - Pi2/pCP 5.0.0 > HiFiBerry DIGI+ > AudioEngine DAC1 > AVI DM5
    Dining Room - Squeezebox Boom
    Garage - Pi3B/Pi screen/HiFiBerry DAC+/pCP 5.0.0 > Edifier R980T

    Spares - 2xTouch, 1xSB3, 1xRadio, 6xRPi

  5. #5
    Senior Member
    Join Date
    May 2005
    Location
    UK
    Posts
    711

    Assign playlist to preset button on Boom(or Radio)

    Hi,

    In article <kidstypike.60bx1z (AT) no-mx (DOT) forums.slimdevices.com>,
    kidstypike<kidstypike.60bx1z (AT) no-mx (DOT) forums.slimdevices.com> wrote:
    > With the playlist name highlighted, press and hold a preset button.


    Sadly, this didn't work. I now have an empty preset.

    I also tried going into the playlist and holding the button, same effect. It
    only seems to save the preset of whatever is playing (and when I do this for
    a playlist, all it saves is the current track).

    Can I edit the config file to do this somehow?

    Andy


  6. #6
    Senior Member
    Join Date
    May 2005
    Location
    UK
    Posts
    711
    Quote Originally Posted by adhawkins View Post
    Can I edit the config file to do this somehow?
    Hmm, thought I'd look in server.prefs to see how these are stored. Low and behold, there is an entry there:

    - URL: file:///var/spool/music/tagged/playlists/Bedtime.m3u
    text: Bedtime
    type: playlist

    However, the 'Bedtime.m3u' file has gone, it certainly used to be there!

    I'll recreate it and see if the preset then starts to work.

    Andy

  7. #7
    Senior Member
    Join Date
    May 2005
    Location
    UK
    Posts
    711
    Hmm, I seem to have some odd permissions issue, the server can't create files in the playlist directory. It's mounted via NFS, and as far as I can tell the permissions are right. Can't do it from the shell either though, so don't think it's an issue specific to Squeezebox server.

    Will check when I get home if the preset has 'stuck'. Odd that the server could display the appropriate playlist in its menus (and play it) but the file had never been written to disk...

    Andy

  8. #8
    Senior Member kidstypike's Avatar
    Join Date
    Feb 2007
    Location
    Brindle
    Posts
    3,256
    I'm away on holiday atm, so not near any LMS/Squeezeboxes.
    Can't help with any permissions problems, but just a thought - try making the playlist a favourite, then browse to it through "Favorites" on your Boom, (don't start it playing) and press and hold a preset button.
    Server - LMS 7.9.2 Pi4B 4GB/pCP 6.0.0-b6 18K library, playlists & LMS cache on SSD (ntfs)
    Study - Pi3B+/pCP 5.0.0/pi screen/HiFiBerry DAC+/jivelite,
    Lounge - Pi2/pCP 5.0.0 > HiFiBerry DIGI+ > AudioEngine DAC1 > AVI DM5
    Dining Room - Squeezebox Boom
    Garage - Pi3B/Pi screen/HiFiBerry DAC+/pCP 5.0.0 > Edifier R980T

    Spares - 2xTouch, 1xSB3, 1xRadio, 6xRPi

  9. #9
    Senior Member
    Join Date
    May 2005
    Location
    UK
    Posts
    711
    Thanks again. It may well be that the preset button has actually worked, but pressing it failed to do anything because the playlist file hadn't actually been written to disk (and it's referenced in the preset part of the server.prefs file).

    Permissions issues I should be able to sort out. I'm comfortable with most things linux, so should be able to work out why it isn't working!

    Andy

  10. #10
    Senior Member aubuti's Avatar
    Join Date
    Oct 2005
    Posts
    8,825
    Quote Originally Posted by adhawkins View Post
    Odd that the server could display the appropriate playlist in its menus (and play it) but the file had never been written to disk...
    I have had similar experiences when I forgot to give the LMS user ('squeezeboxserver' or its predecessors) write permission in the playlist directory. A playlist would appear to be created, until I restarted LMS and then it would be gone. I *think* that LMS may be holding the playlist in RAM until it is restarted.

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •