Home of the Squeezebox™ & Transporter® network music players.
Page 2 of 2 FirstFirst 12
Results 11 to 13 of 13
  1. #11
    Senior Member
    Join Date
    May 2008
    United States
    Quote Originally Posted by JerryS View Post
    Don't want to rain on your happiness but I used powerline adapters for a couple of years with a duet and although the ethernet connection worked fine and much more reliably than wireless, the adapters only seemed to last for a few months before dying. After the second failure I gave up and spent several hours crawling about under the floorboards laying a cable!

    Hope you don't have this problem, maybe I was unlucky with manufacturer or batches.


    another datapoint. I've used ethernet over powerline for years with no issues. Set it up and have never had to do anything since....
    Home: VBA 4TB (2.5)>LMS 7.9.2>Transporter, Touch, Boom, Radio (all ethernet)
    Cottage: VBA 3TB (2.4)>LMS 7.9.1>Touch>Benchmark DAC I, Boom, Radio w/Battery (ethernet, Radio WIFI)
    Office: Win10(64)>LMS 7.9.2>Squeezelite
    The Wild (no internet): PiCorePlayer 4.0 on rPi 3B+, hifiberry Dac+Pro, 4TB USB (LMS & Squeezelite)
    Controllers: iPhone6 & iPadAir2 (iPeng), CONTROLLER, or SqueezePlay 7.8 on Win10(64) laptop
    Files: ripping: dbpa > FLAC; post-rip: mp3tag, PerfectTunes; Streaming: Spotify

  2. #12
    Junior Member
    Join Date
    Aug 2009
    Just in case anyone arrives here via google, the duet receiver can quite easily be set to use ethernet. There's a short blog post that describes the process here. Basically,

    1. Push the big button on the front of the Duet receiver and hold it down until it flashes red.
    2. Shut off the Duet controller. DO NOT SKIP THIS STEP.
    3. Turn on Duet controller (and select the Duet receiver, if necessary).
    4. The controller will now give you the option of ethernet or wireless connectivity. Select ethernet, and wait a minute while the system runs its DHCP queries.

    At step 4 I had to 'Switch player' on my duet controller, away from the duet receiver I was trying to set to ethernet, to one of my other squeezeboxes, and then back again. When I switched back I was offered the option to use ethernet. I chose the option and after some seconds the flashing red light on the front of the receiver turned blue. The controller showed the IP address that the receiver has been assigned by my router.

  3. #13
    Senior Member w3wilkes's Avatar
    Join Date
    Jan 2009
    Utah, USA
    This write-up has 1 missing step. Plug the receiver into the ethernet cable before you do the reset of the receiver (the part where you hold the front button until you get the fast red blink).

    You can then verify that the receiver is on ethernet by going to the Settings in the webGui, on the Information tab the receiver will show a % signal strength if on wifi. If not on wifi there will be no signal strength.
    Main system - Rock Solid with LMS 7.9.1 Official on WHS 2011 - 2 Duets and Squeeseslave
    Cabin system - Rock solid with LMS 7.9.1 Official on Win10 Pro - 1 RPi 3 Model B/Hifiberry DAC+ Pro/PiCorePlayer and Squeezeslave
    Headphones and car - Android phone/Bluetooth w/full library on MicroSD card - PowerAmp music player app (similar to Material Skin)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts