Home of the Squeezebox™ & Transporter® network music players.
Page 91 of 439 FirstFirst ... 41818990919293101141191 ... LastLast
Results 901 to 910 of 4381
  1. #901
    Senior Member sbp's Avatar
    Join Date
    Apr 2010
    Location
    Denmark
    Posts
    1,179
    Quote Originally Posted by BNAL View Post
    It looks nice and tight a specially with the HIFIBerry DAC. I have all the parts to build a nice 5V linear PS and can supply power directly to the DAC's 5v input and not use the microUSB.

    Also, the new wife dongle is working like a champ.
    Good to hear that you got it sorted. I have been trying to see if I could disable the power sawing from your Pi-Wi wifi adaptor without any luck.

    As always I'm very interested in hearing about your impression of the player, are you satisfied with the sound quality from your HiFiBerry DAC?

    Steen
    piCorePlayer a small player for the Raspberry Pi in RAM.
    Homepage: https://www.picoreplayer.org

    Please donate if you like piCorePlayer

  2. #902
    Junior Member
    Join Date
    May 2013
    Posts
    7

    Set ESSID Too Few Arguments

    Hi

    I got back to sorting out the USB config issue and i connected up to HDMI viewer so I could see whats going on. It turns out its not a mounting issue, the config is correctly picked up however the wifi is the issue.

    When it detects wlan0 and tries to connect to my wifi I get an error:
    Error for wireless request "Set ESSID" (8B1A) :
    too few arguments.


    I can see its picked up the right ESSID from my newconfig.cfg file but never gets connected to the wifi.

    I am using WPA and the adapter is an edimax one and was working on a previous version of piCorePlayer on this RasPi so something to do with the config on version 12c

    Any thoughts?

    Cheers

    Gordon

  3. #903
    Senior Member sbp's Avatar
    Join Date
    Apr 2010
    Location
    Denmark
    Posts
    1,179
    Quote Originally Posted by gordonallan View Post
    Hi

    I got back to sorting out the USB config issue and i connected up to HDMI viewer so I could see whats going on. It turns out its not a mounting issue, the config is correctly picked up however the wifi is the issue.

    When it detects wlan0 and tries to connect to my wifi I get an error:
    Error for wireless request "Set ESSID" (8B1A) :
    too few arguments.


    I can see its picked up the right ESSID from my newconfig.cfg file but never gets connected to the wifi.

    I am using WPA and the adapter is an edimax one and was working on a previous version of piCorePlayer on this RasPi so something to do with the config on version 12c

    Any thoughts?

    Cheers

    Gordon
    Hi Gordon

    I have seen this error also, but then the problem was caused by using some special characters in the SSID name or password.

    Could you please post the content of your newconfig.cfg file?
    Do a:
    cat /mnt/sda1/newconfig.cfg

    cheers
    Steen
    piCorePlayer a small player for the Raspberry Pi in RAM.
    Homepage: https://www.picoreplayer.org

    Please donate if you like piCorePlayer

  4. #904
    Junior Member
    Join Date
    May 2013
    Posts
    7
    Quote Originally Posted by sbp View Post
    Hi Gordon

    I have seen this error also, but then the problem was caused by using some special characters in the SSID name or password.

    Could you please post the content of your newconfig.cfg file?
    Do a:
    cat /mnt/sda1/newconfig.cfg

    cheers
    Steen
    Code:
    cat newconfig.cfg 
    NAME="piCorePlayer"
    OUTPUT="sysdefault:CARD=ALSA"
    ALSA_PARAMS="80:::0"
    BUFFER_SIZE=""
    CODEC=""
    PRIORITY=""
    MAX_RATE=""
    UPSAMPLE=""
    MAC_ADDRESS=""
    SERVER_IP=""
    LOGLEVEL=""
    LOGFILE=""
    DSDOUT=""
    VISULIZER=""
    OTHER=""
    AUDIO=Analog
    HOST=piCorePlayer
    NRPACKS="8"
    PIVERS="piCorePlayer 1.11"
    SSID="StClements52"
    PASSWORD="Blacader50"
    ENCRYPTION="WPA"
    OVERCLOCK="NONE"
    Cheers

    Gordon

  5. #905
    Junior Member
    Join Date
    May 2013
    Posts
    7

    Needs Unix Encoded Config File

    Quote Originally Posted by gordonallan View Post
    Code:
    cat newconfig.cfg 
    NAME="piCorePlayer"
    OUTPUT="sysdefault:CARD=ALSA"
    ALSA_PARAMS="80:::0"
    BUFFER_SIZE=""
    CODEC=""
    PRIORITY=""
    MAX_RATE=""
    UPSAMPLE=""
    MAC_ADDRESS=""
    SERVER_IP=""
    LOGLEVEL=""
    LOGFILE=""
    DSDOUT=""
    VISULIZER=""
    OTHER=""
    AUDIO=Analog
    HOST=piCorePlayer
    NRPACKS="8"
    PIVERS="piCorePlayer 1.11"
    SSID="StClements52"
    PASSWORD="Blacader50"
    ENCRYPTION="WPA"
    OVERCLOCK="NONE"
    Cheers

    Gordon
    I found the issue, the file needs to have unix line breaks. Changed that and it connects correctly.

    One other comment is that if I then remove the usb drive, on reboot it reverts to the default config. Should it not save the newconfig.cfg file as config.cfg in the picore image so i can remove the USB?

  6. #906
    Senior Member sbp's Avatar
    Join Date
    Apr 2010
    Location
    Denmark
    Posts
    1,179
    Quote Originally Posted by gordonallan View Post
    I found the issue, the file needs to have unix line breaks. Changed that and it connects correctly.

    One other comment is that if I then remove the usb drive, on reboot it reverts to the default config. Should it not save the newconfig.cfg file as config.cfg in the picore image so i can remove the USB?
    Yes I believe it should - I will look into that.

    As you know piCorePlayer is running in RAM, so if you change anything you will need to manually save it. Usually that is a good thing because then you are not able to break your system (just pull the power - and you will have the same system as last time).

    There is an option to save your new settings from the web GUI (main page)
    You can also save it manually using SHH access.
    sudo filetool.sh -b

    Please report back.

    Steen
    piCorePlayer a small player for the Raspberry Pi in RAM.
    Homepage: https://www.picoreplayer.org

    Please donate if you like piCorePlayer

  7. #907
    Senior Member sbp's Avatar
    Join Date
    Apr 2010
    Location
    Denmark
    Posts
    1,179
    Quote Originally Posted by gordonallan View Post
    I found the issue, the file needs to have unix line breaks. Changed that and it connects correctly.
    OK I didn't know that.
    So maybe I should find a way, so that it reads the variable from the file and writes them to the config.cfg file instead of simply copying the file?

    Steen
    piCorePlayer a small player for the Raspberry Pi in RAM.
    Homepage: https://www.picoreplayer.org

    Please donate if you like piCorePlayer

  8. #908
    Junior Member
    Join Date
    May 2013
    Posts
    7
    Quote Originally Posted by sbp View Post
    OK I didn't know that.
    So maybe I should find a way, so that it reads the variable from the file and writes them to the config.cfg file instead of simply copying the file?

    Steen
    Or you could just dos2unix the file before reading it.

    I still think it should get new config file, replace config.cfg and the run file tool so that the USB doesn't need to stay attached... I am using the USB option to set the basic wifi options to get them on the network then just using the web tool to configure.

    I still think your proposed change to put newconfig.cfg on the fat part of the sd card is best then I could keep a collection of config files for each device and then after each new sd card image write I can just drag the right config file on.

    Best of all would be if the image could auto update without need to rewrite disk image.

    I now have 10 of these running in my house and they are great, just a bit of a fiddle for the ones in inaccessible places (like the loft) when they need upgraded.

  9. #909
    Senior Member sbp's Avatar
    Join Date
    Apr 2010
    Location
    Denmark
    Posts
    1,179
    Quote Originally Posted by gordonallan View Post
    Or you could just dos2unix the file before reading it.

    I still think it should get new config file, replace config.cfg and the run file tool so that the USB doesn't need to stay attached... I am using the USB option to set the basic wifi options to get them on the network then just using the web tool to configure.
    Thanks.
    That is exactly they way I wanted it to work. So I will have to look into where the bug is.

    I still think the best way is to use the USB approach, maybe we can figure out how we can make it acceptable for you.

    Steen
    piCorePlayer a small player for the Raspberry Pi in RAM.
    Homepage: https://www.picoreplayer.org

    Please donate if you like piCorePlayer

  10. #910
    Senior Member sbp's Avatar
    Join Date
    Apr 2010
    Location
    Denmark
    Posts
    1,179
    Quote Originally Posted by gordonallan View Post
    Or you could just dos2unix the file before reading it.
    Thank you for the suggestion, what would be a correct syntax for the use of dos2unix before copying the file to picoreplayer?

    steen
    piCorePlayer a small player for the Raspberry Pi in RAM.
    Homepage: https://www.picoreplayer.org

    Please donate if you like piCorePlayer

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •