Home of the Squeezebox™ & Transporter® network music players.
Results 1 to 5 of 5

Hybrid View

  1. #1
    Junior Member
    Join Date
    Dec 2012
    Posts
    2

    Time format on Squeezebox Boom

    I had the time format configured as I wanted on my Squeezebox Boom for several years. Unfortunately, my NAS (ReadyNAS Pro Business,where the Logitech Media Server runs) became infected with a trojan, and in the process of removing the trojan, I unnecessarily cleared all settings in Logitech Media Server. So, now I'm trying to restore my Squeezebox Boom to the settings it had before the trojan.

    The question is about the time format that the Boom displays in three different states:
    a. When the Boom is off.
    b. When the Boom is on but the streaming is stopped.
    c. When the Boom is streaming.

    My requirements are to display time as follows:
    a. Current time (11:11 AM)
    b. Current time (11:11 AM)
    c. Alternate between the information about what's streaming and the current time (11:11 AM)

    I want to be able to see the current time from across the room, so I do not want the date to display on the Boom's screen at all. I just want the current time and that's it.

    I've spent several hours now trying to configure this, and the only scenario I was able to achieve just the current time display is in case (a), which is when the Boom is off. I can control this settings in Player > Squeezebox Boom > Basic settings > Screensaver when off. The value I assign to this setting is ironically "Date and Time"; however, only the current time is displayed when I turn the Boom off, and the digits are large - they fill the entire Boom's screen, which is what I want.

    However, if I assign the same value to the "Screensaver when stopped" setting on the same configuration page, I see both the date and the time. The format for the display of the date is controlled by the value assigned to the "Long Date Format" setting configured on the "Interface" tab in Logitech Media Server settings.

    So, even though I assign the same exact value (Date and Time) to both "Screensaver when ..." settings in Player > Squeezebox Boom > Basic settings, the clock format in scenarios (a) and (b) are different. Could someone explain this behavior and possibly help me configure scenario (b) the way I need - current time (11:11 AM)?

    P.S. I'm hoping to address Scenario (c) with the SaverSwitcher plugin, but again, I need to be able to switch to the Clock (as a screensaver) displaying only the current time (11:11 AM) and not the time and the date. So, I'm hoping once I resolve the issue I'm having in scenario (b), I can address scenario (c).

    Thank you very much!
    Last edited by sirozha1; 2012-12-09 at 08:26.

  2. #2
    Senior Member
    Join Date
    Apr 2008
    Location
    Paris, France
    Posts
    2,209
    I don't esp. want to deconfigure one of my players to check how this works, but did you look into "Player > Squeezebox Boom > Date and Time" ?
    3 SB 3 • Libratone Loop, Zipp Mini • iPeng (iPhone + iPad) • LMS 7.9 (linux) with plugins: CD Player, WaveInput, Triode's BBC iPlayer by bpa • IRBlaster by Gwendesign (Felix) • Server Power Control by Gordon Harris • Smart Mix, Music Walk With Me, What Was That Tune? by Michael Herger • PowerSave by Jason Holtzapple • Song Info, Song Lyrics by Erland Isaksson • AirPlay Bridge by philippe_44 • WeatherTime by Martin Rehfeld • Auto Dim Display, SaverSwitcher, ContextMenu by Peter Watkins.

  3. #3
    Senior Member
    Join Date
    Feb 2006
    Location
    Washington, DC
    Posts
    894
    You need to adjust the font size. You're seeing just the time when it's off because you have the Boom set to use a larger font when it's off. So to see only the time when the player is idle you'll need to bump up the font size. The problem you're going to run into is that you'll likely want the smaller font size for most other things you do with the Boom on. It would be optimal if you could configure the font-size on a per-screensaver basis but I'm not aware of any plugins or any other good approach for doing this.

    I will say this, though: I find it kind of helpful to have the display look different when the player is off vs. when it's on but idle. Lets me know at a glance whether or not it's on.
    1x SB1, 3x SB1g, 1x SB2, 1x SB3, 2x Booms

  4. #4
    Junior Member
    Join Date
    Dec 2012
    Posts
    2
    Quote Originally Posted by azinck3 View Post
    You need to adjust the font size. You're seeing just the time when it's off because you have the Boom set to use a larger font when it's off. So to see only the time when the player is idle you'll need to bump up the font size. The problem you're going to run into is that you'll likely want the smaller font size for most other things you do with the Boom on. It would be optimal if you could configure the font-size on a per-screensaver basis but I'm not aware of any plugins or any other good approach for doing this.

    I will say this, though: I find it kind of helpful to have the display look different when the player is off vs. when it's on but idle. Lets me know at a glance whether or not it's on.
    Thank you!

    Changing font under Player > Squeezebox Boom > Display to "full_n" fixed the issue. Now only the time is being displayed. There's another option on the same page - "Standby Font". That option affects the font when the Boom is turned off. It was already set to "full_n" and that was the reason why I did not see the date when I would turn off the Boom.

  5. #5
    Junior Member
    Join Date
    Oct 2008
    Posts
    6
    Quote Originally Posted by sirozha1 View Post
    Thank you!

    Changing font under Player > Squeezebox Boom > Display to "full_n" fixed the issue. Now only the time is being displayed. There's another option on the same page - "Standby Font". That option affects the font when the Boom is turned off. It was already set to "full_n" and that was the reason why I did not see the date when I would turn off the Boom.

    Thanks for this post!

    I recently migrated my LMS server from Windows to Raspberry Pi, and the time format got messed up when powered off.
    I had to keep the unit powered on to see the the time in full, without the long date.
    Using "full_n" in all modes fixed it.

    (I know this is a 7 year old post and you probably sold this equipment on eBay YEARS ago! Ha ha.
    Squeezebox 2's make nice clocks around my house!).

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •