Home of the Squeezebox™ & Transporter® network music players.
Page 189 of 194 FirstFirst ... 89139179187188189190191 ... LastLast
Results 1,881 to 1,890 of 1934
  1. #1881
    Babelfish's Best Boy mherger's Avatar
    Join Date
    Apr 2005
    Location
    Switzerland
    Posts
    20,666

    Qobuz.com streaming plugin

    > This seems to be a problem with the handling of works on an album: in
    > this particular case only one work is defined, and the missing tracks
    > don't belong to any particular work. The plugin tries to group tracks
    > into works. And as those lack a work, they get lost on the way.

    This should be fixed in the upcoming v2.4.14.

  2. #1882
    Junior Member brann's Avatar
    Join Date
    May 2020
    Location
    Paris, France
    Posts
    21

    Qobuz.com streaming plugin

    Quote Originally Posted by mherger View Post
    > This seems to be a problem with the handling of works on an album: in
    > this particular case only one work is defined, and the missing tracks
    > don't belong to any particular work. The plugin tries to group tracks
    > into works. And as those lack a work, they get lost on the way.

    This should be fixed in the upcoming v2.4.14.

    Thanks a lot Michael, it works!
    Last edited by brann; 2021-12-02 at 04:41.
    LMS/Material + Qobuz Studio + Raspberry Pi's (3/4) + Audio cards (IQaudio DAC Pro + Hifiberry DAC2HD/DAC+ ADC) + Naim 200DR / ATC SCM11 / Cabasse Galion 4 / EVE SC207 / Pro-Ject RPM5 Carbon using Waveinput or not. My main motto for music is "no speaker systems if not closed"

  3. #1883
    Junior Member ls-74's Avatar
    Join Date
    Dec 2021
    Location
    Italy
    Posts
    6

    Connection timed out

    Hi!

    I just installed LMS on my QNAP NAS to use it streaming TIDAL/Qobuz. Unfortunately I can't make Qobuz working (TIDAL integration works!), I constantly get timeout error messages like those:

    [21-12-16 12:29:25.0669] Plugins::Qobuz::API::_get (698)
    [21-12-16 12:29:40.0693] Plugins::Qobuz::API::__ANON__ (734) Error: Connect timed out:
    [21-12-16 12:29:40.0696] Plugins::Qobuz::API::__ANON__ (76) Failed to get token

    Connectivity to qobuz.com is fine, I can ping the domain from my NAS..

    I tried to disable/re-enable the plug-in and I also restarted LMS several times with no benefit.. :-(

    So I need some expert help now..

    Thanks in advance!

  4. #1884
    Babelfish's Best Boy mherger's Avatar
    Join Date
    Apr 2005
    Location
    Switzerland
    Posts
    20,666

    Qobuz.com streaming plugin

    > [21-12-16 12:29:25.0669] Plugins::Qobuz::API::_get (698)
    > [21-12-16 12:29:40.0693] Plugins::Qobuz::API::__ANON__ (734) Error:
    > Connect timed out:


    What IO::Socket::SSL version is reported in Settings/Information? What
    LMS version?

  5. #1885
    Junior Member ls-74's Avatar
    Join Date
    Dec 2021
    Location
    Italy
    Posts
    6
    Quote Originally Posted by mherger View Post
    > [21-12-16 12:29:25.0669] Plugins::Qobuz::API::_get (698)
    > [21-12-16 12:29:40.0693] Plugins::Qobuz::API::__ANON__ (734) Error:
    > Connect timed out:


    What IO::Socket::SSL version is reported in Settings/Information? What
    LMS version?
    IO::Socket::SSL: 2.060
    Version: 8.2.1 - 1639114554 @ Fri 10 Dec 2021 08:17:26 AM CET

    Cheers!

  6. #1886
    Babelfish's Best Boy mherger's Avatar
    Join Date
    Apr 2005
    Location
    Switzerland
    Posts
    20,666

    Qobuz.com streaming plugin

    > IO::Socket::SSL: 2.060
    > Version: 8.2.1 - 1639114554 @ Fri 10 Dec 2021 08:17:26 AM CET


    Hmm... that should be good enough. Are you running LMS in Docker? Did
    you try restarting LMS (not the NAS)?

  7. #1887
    Junior Member ls-74's Avatar
    Join Date
    Dec 2021
    Location
    Italy
    Posts
    6
    Quote Originally Posted by mherger View Post
    > IO::Socket::SSL: 2.060
    > Version: 8.2.1 - 1639114554 @ Fri 10 Dec 2021 08:17:26 AM CET


    Hmm... that should be good enough. Are you running LMS in Docker? Did
    you try restarting LMS (not the NAS)?
    No, no docker.. I'm using this "native" package https://www.qnapclub.eu/en/qpkg/545#, that has also an active thread in this forum https://forums.slimdevices.com/showt...pport-!/page91 I will post a request also on the latter, but GUI, TIDAL and other functions work, I've just issues with Qobuz.

    This is the log entry after an LMS restart:
    Code:
    [21-12-16 17:47:36.8133] main::init (390) Starting Logitech Media Server (v8.2.1, 1639114554, Fri 10 Dec 2021 08:17:26 AM CET) perl 5.030001 - x86_64-linux-thread-multi
    [21-12-16 17:47:37.7308] Plugins::Qobuz::API::_get (698) http://www.qobuz.com/api.json/0.2/us...anufacturer_id
    [21-12-16 17:47:37.8434] Plugins::Qobuz::Plugin::postinitPlugin (178) Successfully registered BrowseArtist handler for Qobuz
    [21-12-16 17:47:52.9573] Plugins::Qobuz::API::__ANON__ (734) Error: Connect timed out: 
    [21-12-16 17:47:52.9576] Plugins::Qobuz::API::__ANON__ (76) Failed to get token
    [21-12-16 17:51:37.0103] Plugins::Qobuz::API::_get (698) http://www.qobuz.com/api.json/0.2/us...anufacturer_id
    [21-12-16 17:51:52.0128] Plugins::Qobuz::API::__ANON__ (734) Error: Connect timed out: 
    [21-12-16 17:51:52.0131] Plugins::Qobuz::API::__ANON__ (76) Failed to get token
    Thanks a lot!

  8. #1888
    Junior Member ls-74's Avatar
    Join Date
    Dec 2021
    Location
    Italy
    Posts
    6
    Quote Originally Posted by ls-74 View Post
    No, no docker.. I'm using this "native" package https://www.qnapclub.eu/en/qpkg/545#, that has also an active thread in this forum https://forums.slimdevices.com/showt...pport-!/page91 I will post a request also on the latter, but GUI, TIDAL and other functions work, I've just issues with Qobuz.

    This is the log entry after an LMS restart:
    Code:
    [21-12-16 17:47:36.8133] main::init (390) Starting Logitech Media Server (v8.2.1, 1639114554, Fri 10 Dec 2021 08:17:26 AM CET) perl 5.030001 - x86_64-linux-thread-multi
    [21-12-16 17:47:37.7308] Plugins::Qobuz::API::_get (698) http://www.qobuz.com/api.json/0.2/us...anufacturer_id
    [21-12-16 17:47:37.8434] Plugins::Qobuz::Plugin::postinitPlugin (178) Successfully registered BrowseArtist handler for Qobuz
    [21-12-16 17:47:52.9573] Plugins::Qobuz::API::__ANON__ (734) Error: Connect timed out: 
    [21-12-16 17:47:52.9576] Plugins::Qobuz::API::__ANON__ (76) Failed to get token
    [21-12-16 17:51:37.0103] Plugins::Qobuz::API::_get (698) http://www.qobuz.com/api.json/0.2/us...anufacturer_id
    [21-12-16 17:51:52.0128] Plugins::Qobuz::API::__ANON__ (734) Error: Connect timed out: 
    [21-12-16 17:51:52.0131] Plugins::Qobuz::API::__ANON__ (76) Failed to get token
    Thanks a lot!
    I did further experiments:

    Pinging and tracerouting qobuz.com works fine *BUT* if I try to run a wget to the token URL I get connection time-outs (independent of the account I use)! If I run the same wget on my Raspbery Pi endpoint or on my Mac I get a correct response from the server!
    I have no firewall or IP restrictions set, can it be that request is rejected by the Qobuz server due to a wrong user-agent or something else that is different when running on a NAS? Is there something I can do to support debugging? Can it be something related to the perl version or some other lib?!
    During the weekend I'll try to run LMS from a docker on the NAS and report..

    Cheers!

    PS. Also the Spotty plug-in works flawlessly..
    Last edited by ls-74; 2021-12-17 at 14:13.

  9. #1889
    Senior Member DomieMic65's Avatar
    Join Date
    Jul 2019
    Location
    Athens Greece
    Posts
    192
    Hi there!
    May be this is answered before: Is there a way to search labels within the plug-in?
    I see that "play . qobuz . com" gives this option!
    Thank you for your great effort!!!! Happy Holidays!!!!
    Michael
    Main system: Synology DS115j/RPi4B4GB(LMS)/RPi3B+[LnrPS](S.lite)/RME ADI-2 DAC fs/Densen DM20&30/Spendor SP2/3E
    Head-Fi: Sennheiser HD600 & HD25Alum/Audeze Sine.
    Aditional HW: Allo DigiOne, iFi iDefender, iPurifier, iPower

  10. #1890
    Senior Member
    Join Date
    Jan 2007
    Location
    Next to my neighbours :-)
    Posts
    210
    Label search: Michael Herger who takes care of the plugin has written here before that the API that is used does not support that (and other stuff). A few years ago the API was documented on the Qobuz website but they have removed all documentation. "We" can count ourselves lucky that Qobuz left the webservice in place. It could have been closed too and leave us empty handed with a plug that would not work anymore.

    Sadly Qobuz is not forthcoming to give developers like Michael again access to the API or newer version of that API.

    So I keep fingers crossed that Qobuz does not close the webservice as-is.

    Qobuz seems to be a bit off these days anyway.....normally they make new releases visible on friday but a few times I've seen albums return that were already in their catalog long before. Today it was particularly strange with a lot of albums with very old release dates and several already in their catalog.
    does the all-black SB sound better than the white SB?

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •