Home of the Squeezebox™ & Transporter® network music players.
Page 340 of 345 FirstFirst ... 240290330338339340341342 ... LastLast
Results 3,391 to 3,400 of 3447
  1. #3391
    Hi,

    thanks for your answer.

    As far as LMS is concerned this is a .wav file, then all the transcoding defined for WAV take place. In this case it seems to me is converted to FLAC 44.1/16.
    Hi that is exactly what I do not understand. The File is a DXD file
    http://dsd-guide.com/faq/what-dxd-it-dsd

    Could it be possible that LMS does not recognize it. At least it shows the correct bitrate.

    I have one question to the resampler. I have a device that is limited to 96Khz. So I thought this would be the correct way to call squeezelite

    Code:
     ./squeezelite -m 00:22:4d:b7:7d:b5 -n DanteKa01 -r 44100-96000 -R -u vME:::28 -d decode=debug -o stereo1
    However when I play a 192Khz track it is not resampled. It shows that rates match - the funny thing it's playing something (which should not work according to the description of the device)
    Anyhow even if the device could play the 192Khz why does it not resample when i define the maximum rate?

    Code:
    audioserver:~/programs$ ./squeezelite -m 00:22:4d:b7:7d:b5 -n DanteKa01 -r 44100-96000 -R -u vME:::28 -d decode=debug -o stereo1
    [21:17:53.153631] decode_init:153 init decode
    [21:17:53.153746] register_dsd:908 using dsd to decode dsf,dff
    [21:17:53.153873] load_faad:611 loaded libfaad.so.2
    [21:17:53.153888] register_faad:641 using faad to decode aac
    [21:17:53.154100] load_vorbis:305 loaded libvorbisfile.so.3
    [21:17:53.154115] register_vorbis:334 using vorbis to decode ogg
    [21:17:53.154240] load_flac:266 loaded libFLAC.so.8
    [21:17:53.154262] register_flac:294 using flac to decode flc
    [21:17:53.154270] register_pcm:433 using pcm to decode aif,pcm
    [21:17:53.154348] load_mad:385 loaded libmad.so.0
    [21:17:53.154368] register_mad:414 using mad to decode mp3
    [21:17:53.154376] decode_init:187 include codecs:  exclude codecs:
    [21:17:53.154595] load_soxr:269 loaded libsoxr.so.0
    [21:17:53.154614] resample_init:362 resampling sync recipe: 0x36, flags: 0x00, scale: 0.89, precision: 28.0, passband_end: 0.00000, stopband_begin: 0.00000, phase_response: -1.0
    [21:17:53.156319] decode_flush:229 decode flush
    [21:17:53.156476] decode_flush:229 decode flush
    [21:18:19.493696] decode_flush:229 decode flush
    [21:18:19.508167] codec_open:257 codec open: 'f'
    [21:18:19.682304] write_cb:116 setting track_start
    [21:18:19.682335] resample_newstream:232 disable resampling - rates match
    [21:18:19.682340] process_newstream:124 processing: inactive
    Thanks S

  2. #3392
    Senior Member
    Join Date
    Dec 2009
    Location
    Albinea (RE) Italy
    Posts
    657
    Quote Originally Posted by s25a View Post
    Hi,

    thanks for your answer.



    Hi that is exactly what I do not understand. The File is a DXD file
    http://dsd-guide.com/faq/what-dxd-it-dsd

    Could it be possible that LMS does not recognize it. At least it shows the correct bitrate.
    I don't know what DXD is, but if you don't change the file type table and add some other specific settings/code, LMS is handling .wav as WAV, if you need transcoding you have to explicity add it (don't know how to transcode dxd to pcm, btw).

    Quote Originally Posted by s25a View Post

    I have one question to the resampler. I have a device that is limited to 96Khz. So I thought this would be the correct way to call squeezelite

    Code:
     ./squeezelite -m 00:22:4d:b7:7d:b5 -n DanteKa01 -r 44100-96000 -R -u vME:::28 -d decode=debug -o stereo1
    However when I play a 192Khz track it is not resampled. It shows that rates match - the funny thing it's playing something (which should not work according to the description of the device)
    Anyhow even if the device could play the 192Khz why does it not resample when i define the maximum rate?

    Code:
    audioserver:~/programs$ ./squeezelite -m 00:22:4d:b7:7d:b5 -n DanteKa01 -r 44100-96000 -R -u vME:::28 -d decode=debug -o stereo1
    [21:17:53.153631] decode_init:153 init decode
    [21:17:53.153746] register_dsd:908 using dsd to decode dsf,dff
    [21:17:53.153873] load_faad:611 loaded libfaad.so.2
    [21:17:53.153888] register_faad:641 using faad to decode aac
    [21:17:53.154100] load_vorbis:305 loaded libvorbisfile.so.3
    [21:17:53.154115] register_vorbis:334 using vorbis to decode ogg
    [21:17:53.154240] load_flac:266 loaded libFLAC.so.8
    [21:17:53.154262] register_flac:294 using flac to decode flc
    [21:17:53.154270] register_pcm:433 using pcm to decode aif,pcm
    [21:17:53.154348] load_mad:385 loaded libmad.so.0
    [21:17:53.154368] register_mad:414 using mad to decode mp3
    [21:17:53.154376] decode_init:187 include codecs:  exclude codecs:
    [21:17:53.154595] load_soxr:269 loaded libsoxr.so.0
    [21:17:53.154614] resample_init:362 resampling sync recipe: 0x36, flags: 0x00, scale: 0.89, precision: 28.0, passband_end: 0.00000, stopband_begin: 0.00000, phase_response: -1.0
    [21:17:53.156319] decode_flush:229 decode flush
    [21:17:53.156476] decode_flush:229 decode flush
    [21:18:19.493696] decode_flush:229 decode flush
    [21:18:19.508167] codec_open:257 codec open: 'f'
    [21:18:19.682304] write_cb:116 setting track_start
    [21:18:19.682335] resample_newstream:232 disable resampling - rates match
    [21:18:19.682340] process_newstream:124 processing: inactive
    Thanks S
    Sure is 192KHz? "resample_newstream:232 disable resampling - rates match" state is not, maybe you are downsampling server side, try tyo add -x to the command line to avoid it, if you like more, but I would advise you to live the server doing that.

    You could also look for "TRANSCODE" commands in convert.conf to see what transcoding is applyed by LMS when sample rate is greater than the one supported by the player.
    Last edited by marcoc1712; 2018-07-10 at 03:06.
    __________________________________________________ ______________________
    Author of C-3PO plugin, Squeezelite-R2, Falcon Web interface - See www.marcoc1712.it

  3. #3393
    Hi,

    thanks a lot for all the information. It's getting clearer bit by bit :-)

    Sure is 192KHz? "resample_newstream:232 disable resampling - rates match" state is not, maybe you are downsampling server side, try tyo add -x to the command line to avoid it, if you like more, but I would advise you to live the server doing that.

    You could also look for "TRANSCODE" commands in convert.conf to see what transcoding is applyed by LMS when sample rate is greater than the one supported by the player
    Yes it's definitely 192Khz. So as far as I understood. Squeezelite hands over to LMS that it's not capable to play and LMS than resamples right?
    I wanted to test your -x Parameter but this is not available - only X (Capitol Letter which is "Use linear volume adjustments instead of in terms of dB")

    I compiled with these options
    Code:
    sudo make OPTS="-DDSD -DRESAMPLE -DVISEXPORT"
    Maybe there's something missing.

    In regards to DXD - anyone here who have more information? There is some High Res Material available (also for testing at NativeDSD). If someone interested.

    Thanks S

  4. #3394
    Senior Member
    Join Date
    Dec 2009
    Location
    Albinea (RE) Italy
    Posts
    657
    Quote Originally Posted by s25a View Post
    Hi,

    thanks a lot for all the information. It's getting clearer bit by bit :-)



    Yes it's definitely 192Khz. So as far as I understood. Squeezelite hands over to LMS that it's not capable to play and LMS than resamples right?
    I wanted to test your -x Parameter but this is not available - only X (Capitol Letter which is "Use linear volume adjustments instead of in terms of dB")

    I compiled with these options
    Code:
    sudo make OPTS="-DDSD -DRESAMPLE -DVISEXPORT"
    Maybe there's something missing.

    In regards to DXD - anyone here who have more information? There is some High Res Material available (also for testing at NativeDSD). If someone interested.

    Thanks S
    Indeed, looks like the new version from Ralphy lack the

    -x Disable downsampling requests to LMS

    option. Don't know why he decided that way, both Daphile and my R2 version supports it.
    __________________________________________________ ______________________
    Author of C-3PO plugin, Squeezelite-R2, Falcon Web interface - See www.marcoc1712.it

  5. #3395
    Senior Member ralphy's Avatar
    Join Date
    Jan 2006
    Location
    Canada
    Posts
    1,952
    Quote Originally Posted by marcoc1712 View Post
    Indeed, looks like the new version from Ralphy lack the

    -x Disable downsampling requests to LMS

    option. Don't know why he decided that way, both Daphile and my R2 version supports it.
    I never removed the -x option. It was never part of Triode's original squeezelite source.

    You might be able to use the -Z option to achieve the same result.

    -Z <rate> Report rate to server in helo as the maximum sample rate we can support
    Last edited by ralphy; 2018-07-12 at 04:55.
    Ralphy

    1-Touch, 5-Classics, 3-Booms, 1-UE Radio
    Squeezebox client builds donations always appreciated.

  6. #3396
    Senior Member
    Join Date
    Dec 2009
    Location
    Albinea (RE) Italy
    Posts
    657
    Quote Originally Posted by ralphy View Post
    I never removed the -x option. It was never part of Triode's original squeezelite source.

    You might be able to use the -Z option to achieve the same result.

    -Z <rate> Report rate to server in helo as the maximum sample rate we can support
    I was thinking you added -x at some point, togheter with -W, sure is my fault, sorry for that.

    -Z is new to me, what's the difference with -r ?
    __________________________________________________ ______________________
    Author of C-3PO plugin, Squeezelite-R2, Falcon Web interface - See www.marcoc1712.it

  7. #3397
    Senior Member ralphy's Avatar
    Join Date
    Jan 2006
    Location
    Canada
    Posts
    1,952
    Quote Originally Posted by marcoc1712 View Post
    I was thinking you added -x at some point, togheter with -W, sure is my fault, sorry for that.

    -Z is new to me, what's the difference with -r ?
    You can tell lms that the player supports a higher sample rate that it actually does and then have squeezelite resample with the filters and setup you want.
    Ralphy

    1-Touch, 5-Classics, 3-Booms, 1-UE Radio
    Squeezebox client builds donations always appreciated.

  8. #3398

    SL 1.9 + LMS 7.9.0 - No native DSD. :(

    Title says it all. I'm using Squeezelite 1.9 with LMS 7.9.1 (not 7.9.0) and while I can get DoP working, I am not getting native DSD. Is there a funky combination of plugins or SL flags I need to set?

    Thank you!

    Erik

  9. #3399
    Quote Originally Posted by totoroBounced View Post
    Title says it all. I'm using Squeezelite 1.9 with LMS 7.9.1 (not 7.9.0) and while I can get DoP working, I am not getting native DSD. Is there a funky combination of plugins or SL flags I need to set?

    Thank you!

    Erik
    Start squeezeilte:

    Code:
     ./squeezelite -d decode=debug -R -u vME:::28 -D :u32be -o "YOUR Sound Card CARD"
    If it does not start the DSD decoder might be not included (option D in the command line) - You could compile it by yourself.
    (Described here just a few thread before)


    @Ralphy, Marco: I am still struggling with some WAV Files. Attached is a Test File (Just some noise). Could you try if you can play this?
    My DAC is capable of these high rates however even with resampler activated - it does not start. The output is always:

    Code:
    [18:44:55.871253] decode_flush:229 decode flush
    [18:44:55.880255] codec_open:257 codec open: 'f'
    [18:44:55.931540] decode_flush:229 decode flush
    I can play the file with the Same DAC under Windows in Foobar. It shows the correct rate on the display. In this case 768Khz PCM

    I also wonder if someone got DXD Files to work. I am not sure but I fear the decoder for this is not implemented
    https://dsd-guide.com/faq/what-dxd-it-dsd

    Have someone try this before. I could also provide test files if necessary (Very big file but I can sent ONEDRIVE or Dropbox link)

    Thanks S
    L1kR2kPCM768k24bit.zip

  10. #3400
    Senior Member
    Join Date
    Dec 2009
    Location
    Albinea (RE) Italy
    Posts
    657
    Quote Originally Posted by s25a View Post
    Start squeezeilte:

    Code:
     ./squeezelite -d decode=debug -R -u vME:::28 -D :u32be -o "YOUR Sound Card CARD"
    If it does not start the DSD decoder might be not included (option D in the command line) - You could compile it by yourself.
    (Described here just a few thread before)


    @Ralphy, Marco: I am still struggling with some WAV Files. Attached is a Test File (Just some noise). Could you try if you can play this?
    My DAC is capable of these high rates however even with resampler activated - it does not start. The output is always:

    Code:
    [18:44:55.871253] decode_flush:229 decode flush
    [18:44:55.880255] codec_open:257 codec open: 'f'
    [18:44:55.931540] decode_flush:229 decode flush
    I can play the file with the Same DAC under Windows in Foobar. It shows the correct rate on the display. In this case 768Khz PCM

    I also wonder if someone got DXD Files to work. I am not sure but I fear the decoder for this is not implemented
    https://dsd-guide.com/faq/what-dxd-it-dsd

    Have someone try this before. I could also provide test files if necessary (Very big file but I can sent ONEDRIVE or Dropbox link)

    Thanks S
    L1kR2kPCM768k24bit.zip
    Is squeezelite supporting 768Khz PCM? If I well remembre no.
    __________________________________________________ ______________________
    Author of C-3PO plugin, Squeezelite-R2, Falcon Web interface - See www.marcoc1712.it

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •