Home of the Squeezebox™ & Transporter® network music players.
Page 366 of 367 FirstFirst ... 266316356364365366367 LastLast
Results 3,651 to 3,660 of 3661
  1. #3651
    Senior Member ralphy's Avatar
    Join Date
    Jan 2006
    Location
    Canada
    Posts
    2,599
    Quote Originally Posted by Arthur View Post
    Log file
    Thank you. Same error.

    Code:
    [21:41:22.157] process:521 strm
    [21:41:22.157] process_strm:274 strm command t
    [21:41:22.157] sendSTAT:189 STAT: STMt
    [21:41:23.158] sendSTAT:189 STAT: STMt
    [21:41:25.085] stream_thread:324 error reading: Unknown error
    [21:41:25.085] sendDSCO:208 DSCO: 2
    [21:41:25.085] sendSTAT:189 STAT: STMt
    [21:41:27.086] sendSTAT:189 STAT: STMt
    Not sure what's causing this, but the device opens successfully afterward.
    Code:
    [21:37:21.591] sendSTAT:189 STAT: STMf
    [21:37:21.607] pa_monitor:283 output on
    [21:37:21.607] pa_monitor:304 end monitor thread
    [21:37:21.607] _pa_open:395 error opening device 9 - USB DAC ASIO [ASIO] : Unanticipated host error
    [21:37:21.607] pa_monitor:275 start monitor thread
    Ralphy

    1-Touch, 5-Classics, 3-Booms, 1-UE Radio
    Squeezebox client builds donations always appreciated.

  2. #3652
    Junior Member
    Join Date
    May 2020
    Posts
    8
    Thank you so much ralphy mcoste and Arthur! We really appreciation your work in trying to narrow down the issue and solve it.

    I recently played a 40 minute podcast MP3 with -b 10000:10000 buffer. It stopped at the 28 minute mark (100% thread usage - 30 second pause) then kept playing. and it happened 10 minutes later - same thing about 2 minutes from the end of the file.

    Is there something I could contribute to assist in identifying the issue?

  3. #3653
    Senior Member
    Join Date
    Jan 2010
    Location
    Hertfordshire
    Posts
    5,144
    Quote Originally Posted by Jophnal View Post
    Thank you so much ralphy mcoste and Arthur! We really appreciation your work in trying to narrow down the issue and solve it.

    I recently played a 40 minute podcast MP3 with -b 10000:10000 buffer. It stopped at the 28 minute mark (100% thread usage - 30 second pause) then kept playing. and it happened 10 minutes later - same thing about 2 minutes from the end of the file.

    Is there something I could contribute to assist in identifying the issue?
    For podcast issues maybe the "Reliable" plugin would help. I think it should be available in third party plugins.

    Sent from my Pixel 3a using Tapatalk

  4. #3654
    Senior Member
    Join Date
    Jan 2011
    Location
    Staffordshire. UK
    Posts
    3,636
    2012 Mac-mini running High Sierra

    I have managed (after a few trials and tribulations) to install Squeezelite-x86_64-1.9.7r1278.dmg

    Thanks Ralphy

    It works but I have this message in the logs

    Code:
    sudo nano /var/log
    [09:07:08.328223] stream_sock:543 unable to open SSL socket -1 (1)
    [09:10:21.631165] stream_sock:543 unable to open SSL socket -1 (1)
    Does this mean that I have to perform the dreaded SSL update (Which might also enable LMS to run correctly) ?

    Also I would like to add the "-C 10" parameter. Should this be in form of a separate line, viz

    Code:
    <string>-C 10</string>
    and does it matter where in the list It is placed ?

    Code:
    <?xml version="1.0" encoding="UTF-8"?>
    <!DOCTYPE plist PUBLIC "-//Apple Computer//DTD PLIST 1.0//EN" "http://www.apple.com/DTDs/PropertyList-1.0.dtd">
    <plist version="1.0">
    <dict>
            <key>EnvironmentVariables</key>
            <dict>
                    <key>StandardErrorPath</key>
                    <string>/dev/null</string>
                    <key>StandardOutPath</key>
                    <string>/dev/null</string>
            </dict>
            <key>KeepAlive</key>
            <true/>
            <key>Label</key>
            <string>squeezelite</string>
            <key>OnDemand</key>
            <false/>
            <key>ProgramArguments</key>
            <array>
                    <string>/Applications/Squeezelite.app/Contents/MacOS/Squeezelite</string>
                    <string>-o</string>
                    <string>iFi (by AMR) HD USB Audio Output</string>
                    <string>-a</string>
                    <string>100</string>
                    <string>-f</string>
                    <string>/var/log/Squeezelite.log</string>
                    <string>-N</string>
                    <string>/var/log/Squeezelite.name</string>
            </array>
            <key>RunAtLoad</key>
            <true/>
    </dict>
    </plist>

    Many thanks for any help

    ronnie

  5. #3655
    Senior Member ralphy's Avatar
    Join Date
    Jan 2006
    Location
    Canada
    Posts
    2,599
    Quote Originally Posted by Man in a van View Post
    Code:
    sudo nano /var/log
    [09:07:08.328223] stream_sock:543 unable to open SSL socket -1 (1)
    [09:10:21.631165] stream_sock:543 unable to open SSL socket -1 (1)
    Does this mean that I have to perform the dreaded SSL update (Which might also enable LMS to run correctly) ?
    No, the SSL libraries are compiled into squeezelite. The message can be ignored. Squeezelite tries to connect using SSL first and if that fails it tries connecting again without SSL.
    It's related to a recent squeezelite SSL issue.

    Quote Originally Posted by Man in a van View Post
    Also I would like to add the "-C 10" parameter. Should this be in form of a separate line, viz

    Code:
    <string>-C 10</string>
    and does it matter where in the list It is placed ?

    Code:
    <?xml version="1.0" encoding="UTF-8"?>
    <!DOCTYPE plist PUBLIC "-//Apple Computer//DTD PLIST 1.0//EN" "http://www.apple.com/DTDs/PropertyList-1.0.dtd">
    <plist version="1.0">
    <dict>
            <key>EnvironmentVariables</key>
            <dict>
                    <key>StandardErrorPath</key>
                    <string>/dev/null</string>
                    <key>StandardOutPath</key>
                    <string>/dev/null</string>
            </dict>
            <key>KeepAlive</key>
            <true/>
            <key>Label</key>
            <string>squeezelite</string>
            <key>OnDemand</key>
            <false/>
            <key>ProgramArguments</key>
            <array>
                    <string>/Applications/Squeezelite.app/Contents/MacOS/Squeezelite</string>
                    <string>-o</string>
                    <string>iFi (by AMR) HD USB Audio Output</string>
                    <string>-a</string>
                    <string>100</string>
                    <string>-f</string>
                    <string>/var/log/Squeezelite.log</string>
                    <string>-N</string>
                    <string>/var/log/Squeezelite.name</string>
            </array>
            <key>RunAtLoad</key>
            <true/>
    </dict>
    </plist>

    Many thanks for any help

    ronnie
    It needs to be after the <string>/Applications/Squeezelite.app/Contents/MacOS/Squeezelite</string> tag and not in between other multiple line option strings.

    You need to put each part in a separate tag.

    Code:
    <string>-C</string>
    <string>10</string>
    Last edited by ralphy; 2020-10-20 at 05:47.
    Ralphy

    1-Touch, 5-Classics, 3-Booms, 1-UE Radio
    Squeezebox client builds donations always appreciated.

  6. #3656
    Senior Member
    Join Date
    Jan 2011
    Location
    Staffordshire. UK
    Posts
    3,636
    Thanks Ralphy

  7. #3657
    stream_sock:543 unable to open SSL socket -1 (5)

    If it can't open a stream it will put squeezelite into an complete unresponsive state

    version: squeezelite-1.9.7-1278-win64.zip

    Arthur
    Last edited by Arthur; 2020-10-22 at 11:26.

  8. #3658
    Senior Member ralphy's Avatar
    Join Date
    Jan 2006
    Location
    Canada
    Posts
    2,599
    Quote Originally Posted by Arthur View Post
    stream_sock:543 unable to open SSL socket -1 (5)

    If it can't open a stream it will put squeezelite into an complete unresponsive state

    version: squeezelite-1.9.7-1278-win64.zip

    Arthur
    As before, a full squeezelite log running -d all=debug and the URL of the stream, please.

    Does the next line in the log say Trying non-SSL connection?

    The (5) SSL_ERROR_SYSCALL could be caused by antivirus, or the host using a very old version of SSL or the server doesn't support SSL.
    Last edited by ralphy; 2020-10-24 at 05:47.
    Ralphy

    1-Touch, 5-Classics, 3-Booms, 1-UE Radio
    Squeezebox client builds donations always appreciated.

  9. #3659
    As requested
    Attached Files Attached Files

  10. #3660
    Senior Member ralphy's Avatar
    Join Date
    Jan 2006
    Location
    Canada
    Posts
    2,599
    Quote Originally Posted by Arthur View Post
    As requested
    The log indicates that you played 10 streams in less that 4 minutes and only 4 of those exhibit the failed reading/writing to socket: Unknown error issue in windows 10 that's been discussed previously in this thread.

    Quote Originally Posted by ralphy View Post
    and the URL of the stream, please.
    What are the URLs for all the failed streams?

    I've been unable to reproduce the problem, so if you can provide them, it could be helpful. Thanks.
    Ralphy

    1-Touch, 5-Classics, 3-Booms, 1-UE Radio
    Squeezebox client builds donations always appreciated.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •