Home of the Squeezebox™ & Transporter® network music players.
Page 82 of 83 FirstFirst ... 327280818283 LastLast
Results 811 to 820 of 829
  1. #811
    Senior Member
    Join Date
    Apr 2008
    Posts
    424
    I'm afraid it's still stopping. When it stops, the track timer continues to advance...there's just no audio, till I skip to the next track.

  2. #812
    Senior Member wt0's Avatar
    Join Date
    Jul 2008
    Posts
    688
    Quote Originally Posted by jstraw View Post
    I'm afraid it's still stopping. When it stops, the track timer continues to advance...there's just no audio, till I skip to the next track.
    Have you looked at the debug page in SB Player? Does it show any errors?
    --------------
    Squeezebox apps for webOS, Android and Windows Phone, http://www.angrygoatapps.com

  3. #813
    Senior Member
    Join Date
    Apr 2008
    Posts
    424
    Quote Originally Posted by wt0 View Post
    Have you looked at the debug page in SB Player? Does it show any errors?
    There are messages. I don't know if they indicate errors, per se. I there a way to export the logs?

  4. #814
    Senior Member wt0's Avatar
    Join Date
    Jul 2008
    Posts
    688
    Quote Originally Posted by jstraw View Post
    There are messages. I don't know if they indicate errors, per se. I there a way to export the logs?
    No, there's no export function.

    Just screenshot the page when the audio stops.
    Last edited by wt0; 2019-10-19 at 14:46.
    --------------
    Squeezebox apps for webOS, Android and Windows Phone, http://www.angrygoatapps.com

  5. #815
    Senior Member
    Join Date
    Apr 2008
    Posts
    424
    Auostart playback
    New track
    Data stream ended
    Decoder ready
    Streaming from (host/port)
    Data Stream Starting
    Got response headers
    Autostart playback
    Data stream ended
    New track

    (this is through several tracks without audio failing)

  6. #816
    Senior Member wt0's Avatar
    Join Date
    Jul 2008
    Posts
    688
    Quote Originally Posted by jstraw View Post
    Auostart playback
    New track
    Data stream ended
    Decoder ready
    Streaming from (host/port)
    Data Stream Starting
    Got response headers
    Autostart playback
    Data stream ended
    New track

    (this is through several tracks without audio failing)
    That looks normal.

    At the top, what happens to the in/out buffers when the audio stops.
    --------------
    Squeezebox apps for webOS, Android and Windows Phone, http://www.angrygoatapps.com

  7. #817
    Senior Member
    Join Date
    Apr 2008
    Posts
    424
    Name:  XPS-2019-10-19-0104.jpg
Views: 99
Size:  52.6 KB

    Output buffer underrun?

  8. #818
    Senior Member wt0's Avatar
    Join Date
    Jul 2008
    Posts
    688
    Quote Originally Posted by jstraw View Post
    Name:  XPS-2019-10-19-0104.jpg
Views: 99
Size:  52.6 KB

    Output buffer underrun?
    Ok, it only happens with mp3's, not flac's and it happens not long after the device goes to sleep. SB Player uses it's own decoder for FLAC and the system's decoder for MP3. My guess is that Android 10 has gotten more aggressive with it's power saving and is shutting down the decoder when it sleeps. This would explain why the output buffer is empty while the input buffer still has data.

    I'll check in the Android docs to see if this behavior can be programmatically disabled, but there's a good chance it cannot be. Google has a history of breaking things in updates.

    Since the MP3 patents have expired, I can legally use a 3rd party decoder now, so that may be the route I'll have to go.

    BTW, this will probably happen with OGG and AAC too, since those use the same system decoder. It doesn't affect Squeeze Player since it uses it's own native code decoder.
    --------------
    Squeezebox apps for webOS, Android and Windows Phone, http://www.angrygoatapps.com

  9. #819
    Senior Member
    Join Date
    Apr 2008
    Posts
    424
    Quote Originally Posted by wt0 View Post
    Ok, it only happens with mp3's, not flac's and it happens not long after the device goes to sleep. SB Player uses it's own decoder for FLAC and the system's decoder for MP3. My guess is that Android 10 has gotten more aggressive with it's power saving and is shutting down the decoder when it sleeps. This would explain why the output buffer is empty while the input buffer still has data.

    I'll check in the Android docs to see if this behavior can be programmatically disabled, but there's a good chance it cannot be. Google has a history of breaking things in updates.

    Since the MP3 patents have expired, I can legally use a 3rd party decoder now, so that may be the route I'll have to go.

    BTW, this will probably happen with OGG and AAC too, since those use the same system decoder. It doesn't affect Squeeze Player since it uses it's own native code decoder.
    Thank you for giving this your attention.

  10. #820
    Senior Member
    Join Date
    Aug 2005
    Posts
    125
    Thanks for adding Random Mix and New Music support to Android Auto.
    Question: is album art suppose to be shown in Android Auto? It never worked for me; it looks system is trying to display something, and fails.
    Because of that, the Now Playing and New Music screens looks like attached.
    Also, on many occasions, the Now Playing screen lacks the "back" arrow, without which it's impossible to go back to the menu ( as can be seen on the screenshot). It is usually solved by switching from other app and back.
    Sent from my SM-G965F using Tapatalk
    Last edited by ymilner; 2019-10-23 at 04:29.

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •