Home of the Squeezebox™ & Transporter® network music players.
Page 2 of 19 FirstFirst 123412 ... LastLast
Results 11 to 20 of 181
  1. #11
    Senior Member
    Join Date
    Dec 2011
    Posts
    132
    Many thanks for this - I've been looking for a Squeezeplay that will handle my hi-res files.

    By the way it happily plays 192 flacs from LMS 7.7

  2. #12
    Senior Member ralphy's Avatar
    Join Date
    Jan 2006
    Location
    Canada
    Posts
    2,833
    Quote Originally Posted by steve-g View Post
    Many thanks for this - I've been looking for a Squeezeplay that will handle my hi-res files.

    By the way it happily plays 192 flacs from LMS 7.7
    Yes, flacs work in 7.7, pcm was fixed in 7.8.

    and you're welcome
    Ralphy

    1-Touch, 5-Classics, 3-Booms, 2-UE Radio
    Squeezebox client builds donations always appreciated.

  3. #13
    Senior Member
    Join Date
    Apr 2005
    Location
    Milan, Italy
    Posts
    652
    Would it correctly playback FLAC multichannel files?

  4. #14
    I'm having problems with this. I have a WinXP PC with Squeezeplay, ASIO4ALL and M2Tech USB converter. I usually leave the PC running 24/7, but I shut down Squeezeplay since when I leave it on, it sometimes crashes and freezes Windows.
    I set the variables USEPADEVICE and USEPAHOSTAPI to the values showed by Squeezeslave. After a PC reboot everything worked fine. Then, if I shut down Squeezeplay and start it, say, next day again, eveything still looks fine (Squeezeplay activates the ASIO driver etc, connects to LMS) but there is no sound. I have to reboot the PC and then all is OK again. Any ideas?
    Cheers

  5. #15

    WASAPI with HRT Streamer II

    Hi,

    I'm trying to get this version of Squeezeplay to work via WASAPI with the HRT Streamer II on Windows 7 64 bit. Squeezeslave -L yields the following:

    * 2: (Windows DirectSound) Primary Sound Driver (119/239)
    3: (Windows DirectSound) Speakers (2- Music Streamer II) (119/239)
    4: (Windows DirectSound) Speakers (Realtek High Definition Audio) (119/239)
    5: (Windows WASAPI) Speakers (2- Music Streamer II) (3/10)
    6: (Windows WASAPI) Speakers (Realtek High Definition Audio) (3/10)
    8: (Windows WDM-KS) Speakers (Realtek HD Audio output) (10/40)
    11: (Windows WDM-KS) Speakers (Music Streamer II) (10/85)

    I've set the following environment variables:

    USEPADEVICE - Speakers (2- Music Streamer II)
    USEPAHOSTAPI - Windows WASAPI
    USEPAMAXSAMPLERATE - 96000

    However, Squeezeplay simply hangs with these settings. Changing USEPAHOSTAPI to Windows Directsound works fine though, but the sample rate is fixed by the Windows device.

    Any ideas?

  6. #16
    Senior Member ralphy's Avatar
    Join Date
    Jan 2006
    Location
    Canada
    Posts
    2,833
    Quote Originally Posted by nunovi View Post
    Hi,

    I'm trying to get this version of Squeezeplay to work via WASAPI with the HRT Streamer II on Windows 7 64 bit. Squeezeslave -L yields the following:

    * 2: (Windows DirectSound) Primary Sound Driver (119/239)
    3: (Windows DirectSound) Speakers (2- Music Streamer II) (119/239)
    4: (Windows DirectSound) Speakers (Realtek High Definition Audio) (119/239)
    5: (Windows WASAPI) Speakers (2- Music Streamer II) (3/10)
    6: (Windows WASAPI) Speakers (Realtek High Definition Audio) (3/10)
    8: (Windows WDM-KS) Speakers (Realtek HD Audio output) (10/40)
    11: (Windows WDM-KS) Speakers (Music Streamer II) (10/85)

    I've set the following environment variables:

    USEPADEVICE - Speakers (2- Music Streamer II)
    USEPAHOSTAPI - Windows WASAPI
    USEPAMAXSAMPLERATE - 96000

    However, Squeezeplay simply hangs with these settings. Changing USEPAHOSTAPI to Windows Directsound works fine though, but the sample rate is fixed by the Windows device.

    Any ideas?
    I'd suggest trying WDM-KS instead.

    USEPADEVICE - Speakers (Music Streamer II)
    USEPAHOSTAPI - Windows WDM-KS
    USEPAMAXSAMPLERATE - 96000

    WASAPI is using shared mode which means you need to set the sample rate to match the source you're trying to play.
    Ralphy

    1-Touch, 5-Classics, 3-Booms, 2-UE Radio
    Squeezebox client builds donations always appreciated.

  7. #17
    Senior Member
    Join Date
    Apr 2005
    Location
    Milan, Italy
    Posts
    652
    Quote Originally Posted by gorman View Post
    Would it correctly playback FLAC multichannel files?
    Bump on this question.

  8. #18
    Senior Member
    Join Date
    Dec 2011
    Posts
    699
    Quote Originally Posted by nunovi View Post
    Hi,

    I'm trying to get this version of Squeezeplay to work via WASAPI with the HRT Streamer II on Windows 7 64 bit. Squeezeslave -L yields the following:

    * 2: (Windows DirectSound) Primary Sound Driver (119/239)
    3: (Windows DirectSound) Speakers (2- Music Streamer II) (119/239)
    4: (Windows DirectSound) Speakers (Realtek High Definition Audio) (119/239)
    5: (Windows WASAPI) Speakers (2- Music Streamer II) (3/10)
    6: (Windows WASAPI) Speakers (Realtek High Definition Audio) (3/10)
    8: (Windows WDM-KS) Speakers (Realtek HD Audio output) (10/40)
    11: (Windows WDM-KS) Speakers (Music Streamer II) (10/85)

    I've set the following environment variables:

    USEPADEVICE - Speakers (2- Music Streamer II)
    USEPAHOSTAPI - Windows WASAPI
    USEPAMAXSAMPLERATE - 96000

    However, Squeezeplay simply hangs with these settings. Changing USEPAHOSTAPI to Windows Directsound works fine though, but the sample rate is fixed by the Windows device.

    Any ideas?
    I had the same issue, got round it by not specifying a USEPAHOSTAPI ie deleting that variable and setting my wasapi device to be the default, worked ok, although had latency issues playing 192/24, 96 was ok.

  9. #19
    Senior Member ralphy's Avatar
    Join Date
    Jan 2006
    Location
    Canada
    Posts
    2,833
    Quote Originally Posted by gorman View Post
    Bump on this question.
    No.
    Ralphy

    1-Touch, 5-Classics, 3-Booms, 2-UE Radio
    Squeezebox client builds donations always appreciated.

  10. #20
    Senior Member
    Join Date
    Apr 2005
    Location
    Milan, Italy
    Posts
    652
    Quote Originally Posted by ralphy View Post
    No.
    Would this be something "fixable" somehow?

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •