Home of the Squeezebox™ & Transporter® network music players.
Page 14 of 15 FirstFirst ... 412131415 LastLast
Results 131 to 140 of 143
  1. #131
    Quote Originally Posted by mherger View Post
    >
    Well, there obviously is no such folder in your system, is there? You'd
    have to set it in the "source specific settings" or similar.

    --

    Michael
    No there isn't. I figured that out by using "search function". The big Q is if this really would work outside a Touch context? I tried and made a "media" folder with a *.jpg file in it and put it in a whole lot of different locations associated to the squeezeplay install but not any of the locations I tried seemed to work. To my knowledge there is only two locations where Squeezeplay places it's "stuff" during an install 1: in the "program" folder and 2: in the "settings" folder. They naturally is to be found in a bit different locations depending if one install on a Mac or in Windows. (have no clue regarding Linux)
    And further I then tried change in the named "source specific setting"; e.g. I changed from "/media" to a couple of different names like "/squeezeplay", "/jive", "userpath/squeezeplay" but then when I go back in the Squeezeplay menu to "image viewer>browse media it's exactly the same error message whatever I write down in "source specific settings" (i.e "cannot open folder: /media") which is a bit odd isn't?... :-/ i.e squeezeplay seemingly doesn't "buy" the change from "/media" to whatever else I set there.

    There's something I completely miss here and I for sure isn't knowledgeable enough to figure this out by myself. First and foremost is this "browsing in a local folder" function working on a Touch?
    If yes, can one change the "media" folder to some other folder on the same Touch and it still would work? Then if this actually IS working what would be the equivalent folder one could use on a OSX/WIN install?? I hope maybe Ralphy could have the answers if this is suppose to work or not? And if it is, EXACTLY what should one write down in the "source specific settings"?
    From the info I managed to gather; this function is suppose to work on a Touch from either a inserted SD card OR a USB HDD plugged into the Touch so I figure could it be that there must be a "line" that needs to be changed somewhere in one of those many "lua" files that I understand has everything to do with how the Squeezeplay behaves?

  2. #132
    Babelfish's Best Boy mherger's Avatar
    Join Date
    Apr 2005
    Location
    Switzerland
    Posts
    20,435

    [ANNOUNCE] SqueezePlay for Mac OSX

    > No there isn't. I figured that out by using "search function". The big Q
    > is if this really would work outside a Touch context? I tried and made a
    > "media" folder with a *.jpg file in it and put it in a whole lot of
    > different locations associated to the squeezeplay install but not any of


    The path says /media - which is not available on a Mac. You don't have
    to create a random folder, but point the Image Viewer applet at a folder
    on your system.

    > And further I then tried change in the named "source specific setting";
    > e.g. I changed from "/media" to a couple of different names like
    > "/squeezeplay", "/jive", "userpath/squeezeplay" but then when I go back


    That's the way to go. But don't put anything random in there. Most
    likely it needs to be something below /Users/[your username]/...

    --

    Michael

  3. #133
    Quote Originally Posted by mherger View Post
    >
    That's the way to go. But don't put anything random in there. Most
    likely it needs to be something below /Users/[your username]/...

    Michael
    Not sure if you read all I wrote? Difficult "fault trace" over messages so maybe misunderstandings. Those folders in my example are not "random", they exist but Squeezeplay will seemingly not buy it.
    As I said I'm not very "computersavvy". My feeling is that Squeezeplay doesn't "understand" e.g "/media" or whatever one put in in that context? if I go "/user/*myusername* (and that sure is a folder that exists!) I still get error message "cannot open folder : /MEDIA" ...!!
    One would more expect that I would get message "cannot open folder : /user/*myusername* ...uhh,no?!? But sure, I might very well be missing something!

    It seems like Squeezeplay install on a Mac doesn't at all "understand" the context : /-whatever-foldername-one-put-here/myusername- ?!? And my Windows install behaves the same way. If you know this should work outside a Touch context please give me a more clear example of how and what I should put in the "source specific settings" menu. I'm not a programmer but I sure can put 1+1 together ... ;-) :-) hopefully we can solve this together. Can it have somthing to do with not using the correct symbols, e.g / instead of \ , a missing : and the like? Also it would be helpful and maybe timesaving if someone could confirm that this "app" works on a HW Touch. But please note that it should be the "reading from a local folder" option. The URL option works fine on both Mac and Windows.

  4. #134
    Babelfish's Best Boy mherger's Avatar
    Join Date
    Apr 2005
    Location
    Switzerland
    Posts
    20,435

    [ANNOUNCE] SqueezePlay for Mac OSX

    > One would more expect that I would get message "cannot open folder :
    > /user/*myusername* ...uhh,no?!? But sure, I might very well be missing
    > something!


    Are you on Mac or Linux? On Mac this would be uppercase plural "Users",
    not "user".

    Just gave it a try. There indeed seems to be a problem with the browse
    item. But given a correct path, "start slideshow" should work. Can you
    confirm?

    --

    Michael

  5. #135
    Quote Originally Posted by mherger View Post
    > But given a correct path, "start slideshow" should work. Can you
    confirm?

    Michael
    I'm now on a mac (but occasionly a windows install also). Not very "at home" on a Mac that's for sure.

    So you mean you have put a couple of *jpg's in a FOLDER and the "start slideshow" option reads the images you've put there?

    Wait I'll try.

  6. #136
    Quote Originally Posted by doggod View Post
    I'm now on a mac (but occasionly a windows install also). Not very "at home" on a Mac that's for sure.

    So you mean you have put a couple of *jpg's in a FOLDER and the "start slideshow" option reads the images you've put there?

    Wait I'll try.

    Ok, I can confirm here as well. Not sure what OS X you've but I'm on Sierra and I actually tried and change the "upper/lower" case in /User/Myusername and that didn't matter, both way works here! Can also confirm the "start slideshow" option works in Windows.

    So this is a step forward. So what could be wrong with the "browse" option? So maybe that doesn't work on a Touch neither then?

    Do you have the same behaviour in the "browse" option that whatever location you put there's still the "Cannot open folder : /MEDIA error message?
    Last edited by doggod; 2020-03-20 at 09:10.

  7. #137
    Senior Member ralphy's Avatar
    Join Date
    Jan 2006
    Location
    Canada
    Posts
    2,517
    Quote Originally Posted by doggod View Post
    Ok, I can confirm here as well. Not sure what OS X you've but I'm on Sierra and I actually tried and change the "upper/lower" case in /User/Myusername and that didn't matter, both way works here! Can also confirm the "start slideshow" option works in Windows.

    So this is a step forward. So what could be wrong with the "browse" option? So maybe that doesn't work on a Touch neither then?

    Do you have the same behaviour in the "browse" option that whatever location you put there's still the "Cannot open folder : /MEDIA error message?
    The browse option is hard coded to /media on the touch and therefore all my squeezeplay builds as well.

    Let me see if I can change it to check the Image Viewer Settings to see if there's an alternate folder defined first.
    Ralphy

    1-Touch, 5-Classics, 3-Booms, 1-UE Radio
    Squeezebox client builds donations always appreciated.

  8. #138
    Senior Member ralphy's Avatar
    Join Date
    Jan 2006
    Location
    Canada
    Posts
    2,517
    Attached is an updated ImageViewer applet to try.

    Extract the file in /Users/$USER/Library/Preferences/SqueezePlay/userpath/applets after which you should have files in

    /Users/$USER/Library/Preferences/SqueezePlay/userpath/applets/ImageViewer/

    ImageSource.lua
    ImageSourceCard.lua
    ImageSourceFlickr.lua
    ImageSourceHttp.lua
    ImageSourceLocalStorage.lua
    ImageSourceServer.lua
    ImageSourceUSB.lua
    ImageViewerApplet.lua
    ImageViewerMeta.lua
    strings.txt

    Then restart SqueezePlay.

    Navigate to Settings->Image Viewer->Image Viewer Settings->Sources->Enable Local storage media

    Navigate back one level and change the /media path in Source specific settings to the folder where your images are stored on the Mac then click done.

    There are still a couple other hard coded instances of /media in the applet that might need modification before I include the an update Image Viewer applet in the installer.
    Attached Files Attached Files
    Ralphy

    1-Touch, 5-Classics, 3-Booms, 1-UE Radio
    Squeezebox client builds donations always appreciated.

  9. #139
    Quote Originally Posted by ralphy View Post
    Attached is an updated ImageViewer applet to try.

    Extract the file in /Users/$USER/Library/Preferences/SqueezePlay/userpath/applets after which you should have files in

    /Users/$USER/Library/Preferences/SqueezePlay/userpath/applets/ImageViewer/

    ImageSource.lua
    ImageSourceCard.lua
    ImageSourceFlickr.lua
    ImageSourceHttp.lua
    ImageSourceLocalStorage.lua
    ImageSourceServer.lua
    ImageSourceUSB.lua
    ImageViewerApplet.lua
    ImageViewerMeta.lua
    strings.txt

    Then restart SqueezePlay.

    Navigate to Settings->Image Viewer->Image Viewer Settings->Sources->Enable Local storage media

    Navigate back one level and change the /media path in Source specific settings to the folder where your images are stored on the Mac then click done.

    There are still a couple other hard coded instances of /media in the applet that might need modification before I include the an update Image Viewer applet in the installer.
    Hi Ralphy,
    Thanks for such quick and nice solution. Can confirm it works fine both for OS X and Windows.

    Have another Q for ya which I hope there's an answer for? I posted on the Squeezeplay for windows thread way back in July -19 (#173) here > :

    https://forums.slimdevices.com/showt...l=1#post945123

    but no one seemingly has any ideas. What do you think, possible? (I mean the "power button" in the upper left corner on the first "menu")
    Last edited by doggod; 2020-03-23 at 13:29.

  10. #140
    Junior Member
    Join Date
    Aug 2009
    Posts
    19

    Resize SqueezePlay window

    I'm sure this is obvious but I can't figure it out. How do I resize the SqueezePlay app window? When I drag the bottom left corner it doesn't work, the window doesn't change.

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •