Home of the Squeezebox™ & Transporter® network music players.
Results 1 to 1 of 1
  1. #1
    Junior Member
    Join Date
    Apr 2012

    Playlist duplication issues (entire list, not individual entries)

    I posted in General, and decided that probably wasn't the right place for it. Sorry for the dup.

    I'm assuming this is related to problems I've identified here.

    short version.
    I have LMS running on Windows 7, with the music and playlist files on a QNAP (network attached storage).
    The music directory is mapped as X:
    The Playlist directory is mapped as Z:

    This worked for months, until the last upgrade in which LMS could no longer see anything on the mapped drives, though of course everything was there.

    I was able to fix that by using \\computername\flac and \\computername\music\playlist respectively for music and playlists. After a single good run, that no longer worked and I had to use \\ip.address\flac and \\ip.address\music\playlist. Music is working, though I don't like using it this way as in some bizarre situation the ip address might change.

    However, the playlists are killing me. All of the playlist names are doubled up All the others are where I would expect them to be. I backed up the directory and rescanned, all dissappeared as expected. When I put them back they were doubled up again.

    I went to create a dummy to see where it's writing it, and I can't find the new dummy playlist. It's not out in \\ip.address\music\playlist, though all the others are, but singled. It's like it's reading from there and then copying it someplace else, but then reading both locations.

    later that day.....

    I logged directly into the machine with LMS running as opposed to going through the web interface. I found that the drives were disconnected which is why I couldn't use them.

    HOWEVER, now all my playlists are in triplicate.

    Another test was to move my actual playlist directory. LMS didn't delete the existing entries when I rescanned, so it's storing it elsewhere which is probably what's causing my problem.

    edit: Fixed. Drive mapping issue was because drives were disconnected and needed refreshed. Then I did a clear and reload and it worked fine.
    Last edited by noxiousdog; 2012-04-04 at 20:23.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts