Home of the Squeezebox™ & Transporter® network music players.
Results 1 to 6 of 6
  1. #1

    Can't locate perl514.dll

    I am running the latest nighly build 7.7.2/r33882 (have also tried other 7.7.2 builds) on Vista Ultimate 32 bit.

    Since changing the user privelidges of my main admin account to standard user and enabling UAC I have been having a problem with squeezebox during startup of the standard user account.

    I now get an error for squeezetray.exe - "Error: Can't locate perl514.dll. Make sure ActivePerl bin directory is in your Path" only during startup of the standard user account.

    perl514.dll is in my Local Temp directory for the session.

    e.g. C:\Users\Home\AppData\Local\Temp\pdk-Home-2544

    When I run LMS as administrator everything works fine.

    My current PATH is

    %SystemRoot%\system32;%SystemRoot%;%SystemRoot%\Sy stem32\Wbem;c:\Program Files\Microsoft SQL Server\90\Tools\binn\;C:\Program Files\QuickTime\QTSystem\;%SYSTEMROOT%\System32\Wi ndowsPowerShell\v1.0\

    I am relectant to change the path in case this is a symptom of another issue.

    Do you think this is an installer issue, or UAC privelidges, or should I just change the PATH?

    Last edited by entrecour; 2012-03-11 at 02:16. Reason: typo

  2. #2
    Senior Member gharris999's Avatar
    Join Date
    Apr 2005
    Santa Fe, NM
    You could try changing the "Start In" value in the shortcut that launches squeezetray.exe. Have it start in C:\Users\Home\AppData\Local\Temp\pdk-Home-2544. The EXE ought to find the dll then.

  3. #3
    Thanks for the suugestion.

    A new psk directory is created every login session as far as I can see so I tried the parent directory C:\Users\Home\AppData\Local\Temp\ instead. That didn't fix the problem but I did notice that the double quotes (") around the path weren't saved.

    I assume others are using Standard User accounts also so I am puzzled why I have this problem. I may try another uninstall / install and see if that fixes it.

  4. #4

    This seems to be a Admin rights / UAC issue

    I reinstalled...

    Logitech Media Server Version: 7.7.2 - r33883 @ Sat Mar 10 02:14:16 PST 2012
    Operating system: Windows Vista - EN - cp1252
    Platform Architecture: 586
    Perl Version: 5.14.1 - MSWin32-x86-multi-thread
    Database Version: DBD::SQLite 1.34_01 (sqlite

    ... but I still have same issue. When I am running as admin all works ok, but as standard user account I get the perl error and tray app does not start. I can start LMS by right clicking on the short cut and running as administrator. I checked the compatability / priviledge settings for the .exe and the service is run as admin, squeezetray.exe is not.

    Changing squeezetray.exe to run as admin does not work either. The only way I can get it to start is to right click the shortcut and run as admin.

    I have also tried using the Microsoft Application Compatability Manager to RunAsAdmin and RunAsInvoker for all the squeezebox exe's but that doesn't help either.

    I did some more digging on this site and found that this was a known issue but supposedly fixed for W7 at least






    Does anyone know what compatability settings should be set in the app comptability manager for LMS?

    Logitech, have you reported the required settings to Microsoft? I can find 3-4 Logitech apps in the database (e.g quickcam) but not LMS or Squeezeserver.

  5. #5
    Senior Member
    Join Date
    Sep 2007
    Your issues isnt related to the things you are linking to.

    Your issue is swapping your user privileges after installing apps. It doesnt seem such a bad thing at first but I have found it causes ALL KINDS OF BAD.
    Most apps are piss poor at uninstalling. You really need to go hunting and remove everything. You might find left overs in the registry, VirtualStore, application data and so on.

    So your problem is that you have your app(s) stuck in limbo. Settings which unfortunately aren't being deleted on uninstall are confusing the app.
    The uninstaller itself is probably confused because it installed the files with one set of credentials and then at uninstall just assumed it would be equal but all the file paths between the 2 are totally different.

    Either go hunting or scrap the entire Windows login and create a new one. All apps that have crossed over from before to after the credential changes have a fairly high chance of some kind of issue. It is never written in writing by app developers or Microsoft but be certain to never change your user rights like this after installing apps, you will be left in the unsupported user camp.
    Last edited by bits; 2012-03-13 at 05:23.

  6. #6
    There are several posts on this forum relating to issues caused by Microsoft changing security / privelidge handling affecting LMS and W7. Vista has always been difficult wrt Admin / UAC so I am just wondering if there are some remaining issues related to Vista and LMS.

    I have only had issues with one application in 60 after changing the old admin account to standard user. This was fixed after a full reinstall of the app.

    I tried again today with7.7.2 this time uninstalling using Revo Uninstaller Pro, all relevant program files and data directories were deleted, and nothing leftover in the registry. I cleared out all temp files, restarted, and then reinstalled the latest nighlty.

    Same result - on admin acct startup works fine, squeezetray.exe starts, no error messages.

    As standard user however I have the perl error and squeezetray.exe does not start without right click run as admin.

    Anyone else recently installed a 7.7.2 build on an upto date (fully patched) Vista OS?

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts