Home of the Squeezebox™ & Transporter® network music players.
Results 1 to 2 of 2
  1. #1
    Roger Mitchell
    Guest

    Moodlogic playlists disappeared

    I haven't cut anything from the start of the log only a large chunk in the
    middle referring to Itunes. What you see is what you get. I think I'll try a
    nightly next although I cant see that is going to do much. If it does, I'll
    be amazed because I have been running with 5.3.1 ever since it was released
    and everything has been OK up to about a week ago - I'm completely baffled!.
    As I said, all the mixes work on squeezebox - all the little "m"'s do what
    they are supposed to, it's just that there are no Moodlogic playlists shown
    in slimserver - weird. Don't know what to do next, any ideas.... Anyone?

    Best regards
    Roger, Newbury, UK



    -----Original Message-----
    From: discuss-bounces (AT) lists (DOT) slimdevices.com
    [mailto:discuss-bounces (AT) lists (DOT) slimdevices.com] On Behalf Of kdf
    Sent: 23 October 2004 19:42
    To: Slim Devices Discussion
    Subject: [slim] Moodlogic playlists disappeared

    what seems to be missing is any messages about the playlists at all, which
    should be the first thing you see before it starts with songs. Did you
    delete those from the debug? messages like "no autoplaylists found" or
    "adding 23 items" should be present. I use the latest cvs myself and it
    seems to be working just fine for me. I had also expected prehaps that the
    debug would have reported that there was an error with the moodlogic
    database. I'm really not sure how you can be devoid of any playlist
    messages whatsoever. sorry, I know that's not much help.
    -kdf
    Quoting Roger Mitchell <rog.mitchell (AT) bigfoot (DOT) com>:

    > Hi kdf (and everyone else, of course!)
    >
    > Sorry about the time it has taken me to respond to your suggestion -
    > couldn't get on my PC yesterday because "she who must be obeyed" was
    > busy booking a holiday for next year (yes, all day)!) Anyway, I have
    > cut and pasted the log below although I have chopped out a load of
    > references to Itunes stuff. I hope this will tell you what is

    happening.....
    >
    > 2004-10-23 13:38:20.2908 using moodlogic: 1
    > 2004-10-23 13:38:56.8500 using moodlogic: 1
    > 2004-10-23 13:38:56.8503 using moodlogic: 1
    > 2004-10-23 13:38:56.8504 startScan: start export
    > 2004-10-23 13:38:56.8505 using moodlogic: 1
    > 2004-10-23 13:38:57.1250 Exporting song 19708: 2004-10-23
    > 13:39:18.6024 Exporting song 23380:
    > file:///C:/Documents%20and%20Settings/Roger/My%20Documents/My%20Music/
    > iTunes
    > /iTunes%20Music/Zappacosta/Dirty%20Dancing%20-%20Original%20Soundtrack
    > /09%20
    > Overload.mp3
    > 2004-10-23 13:39:18.6130 Exporting song 23381:
    > file:///C:/Documents%20and%20Settings/Roger/My%20Documents/My%20Music/
    > iTunes
    > /iTunes%20Music/Ziggy%20Marley/The%20Best%20Reggae%20Album%20In%20The%
    > 20Worl
    > d%20-%20CD2/19%20Tomorrow%20People.mp3
    > 2004-10-23 13:39:18.6213 MoodLogic: done Scanning
    > 2004-10-23 13:39:24.8218 exportFunction: finished export (3429
    > records, 0
    > playlists)
    > getpeername() on closed socket GEN4 at /PerlApp/IO/Socket.pm line 206.
    > 2004-10-23 13:39:24.8407 using moodlogic: 1
    > 2004-10-23 13:39:28.9743 using moodlogic: 1
    > 2004-10-23 13:39:29.2098 using moodlogic: 1
    > 2004-10-23 13:39:29.2562 using moodlogic: 1
    > 2004-10-23 13:39:29.2565 using moodlogic: 1
    > 2004-10-23 13:39:29.2567 using moodlogic: 1
    > 2004-10-23 13:39:29.8417 using moodlogic: 1
    > 2004-10-23 13:39:34.8428 using moodlogic: 1
    > 2004-10-23 13:39:39.8448 using moodlogic: 1
    > 2004-10-23 13:39:56.2045 using moodlogic: 1
    > 2004-10-23 13:40:01.2087 using moodlogic: 1
    >
    >
    >
    >
    >
    > -----Original Message-----
    > From: discuss-bounces (AT) lists (DOT) slimdevices.com
    > [mailto:discuss-bounces (AT) lists (DOT) slimdevices.com] On Behalf Of kdf
    > Sent: 21 October 2004 22:42
    > To: Slim Devices Discussion
    > Subject: [slim] Moodlogic playlists disappeared
    >
    > try debugging with the following:
    >
    > stop the server
    > click start->run
    > type: "c:\program files\slimserver\server\slim.exe" --d_moodlogic
    > --logfile c:\moodlogic.log then click ok.
    >
    > open the server web ui, go into server settings to make sure you have
    > "use moodlogic' selected. an audiodir setting is not required.
    >
    > click on wipe cache in server settings -> performance
    >
    > when teh scan is complete, you can open the log in wordpad and see
    > what it says about the moodlogic playlists.
    >
    > -kdf
    >
    > Quoting Roger Mitchell <rog.mitchell (AT) bigfoot (DOT) com>:
    >
    > > Sorry kdf, didn't make it too clear did I. I'm running 5.3.1 (the
    > > official released version) on an XP Pro SP2 system. I remember the
    > > problem with the empty playlists but that was a while ago as you say.
    > > I have no Moodlogic playlists at all, only Itunes playlists show up
    > > and they work fine! Using squeezebox, I can do all the various mixes
    > > etc., but I have none of the pre-defined playlists that I used to
    > > have

    > under "Saved Playlists".
    > > Everything else works a treat, it's only the fact the playlists have
    > > gone missing! I have wiped the cache at least 5 times and even
    > > re-installed slimserver, but it just doesn't want to pick up the
    > > playlists. Other playlists are OK. Any ideas?
    > >
    > > Regards
    > > Roger, Newbury, UK
    > >
    > >
    > >
    > > -----Original Message-----
    > > From: discuss-bounces (AT) lists (DOT) slimdevices.com
    > > [mailto:discuss-bounces (AT) lists (DOT) slimdevices.com] On Behalf Of kdf
    > > Sent: 21 October 2004 17:39
    > > To: Slim Devices Discussion
    > > Subject: [slim] Moodlogic playlists disappeared
    > >
    > > This was a known issue with 5.3.0 and is fixed for 5.3.1. Since you
    > > haven't stated the version you are running or on what OS, I'll just
    > > suggest that you upgrade, or gointo server settings, performance and
    > > click wipe cache and let the server rescan.
    > >
    > > -kdf
    > >
    > > Quoting Roger Mitchell <rog.mitchell (AT) bigfoot (DOT) com>:
    > >
    > > > Hi all! If anyone has any ideas I would be happy to try anything!
    > > > My moodlogic playlists have disappeared from slimserver! Itunes
    > > > playlists are still there but no matter what I seem to do,
    > > > Moodlogic playlists just won't appear. They always used to work Ok
    > > > and as far as I know the only change to my PC is the installation
    > > > of Norton Internet Security 2005 a couple of days ago. In honesty,
    > > > I cant really associate the 2 items together because I am not sure
    > > > when the playlists disappeared. I have tried a re-install of
    > > > slimserver, disabling and enabling moodlogic support and I think
    > > > played with just about everything! Moodlogic works fine as a
    > > > standalone program and the

    > > mixes still work on my squeezebox (the little "m").
    > > >

    > >
    > >
    > >
    > >

  2. #2
    NOT a Slim Devices Employee kdf's Avatar
    Join Date
    Apr 2005
    Posts
    9,493

    Moodlogic playlists disappeared

    Quoting Roger Mitchell <rog.mitchell (AT) bigfoot (DOT) com>:

    > I haven't cut anything from the start of the log only a large chunk in the
    > middle referring to Itunes. What you see is what you get. I think I'll try a
    > nightly next although I cant see that is going to do much. If it does, I'll
    > be amazed because I have been running with 5.3.1 ever since it was released
    > and everything has been OK up to about a week ago - I'm completely baffled!.
    > As I said, all the mixes work on squeezebox - all the little "m"'s do what
    > they are supposed to, it's just that there are no Moodlogic playlists shown
    > in slimserver - weird. Don't know what to do next, any ideas.... Anyone?


    things to try:
    server settings, performance, wipe cache (which I believe you've done)
    run Moodlogic and let it possibly fix the database if something has gone wrong.
    download Test_Moodlogic_com.exe from here:
    http://www.slimdevices.com/downloads/moodlogic/

    running that will test the COM interface ande report any errors. however, I
    would have expected slimserver to have reported at least one error were any of
    the above to be useful. instead, your log looks as if it doesnt' even attempt
    to look for playlists for some reason.

    -kdf

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •