Home of the Squeezebox™ & Transporter® network music players.
Results 1 to 3 of 3
  1. #1
    Junior Member
    Join Date
    Dec 2011

    Unhappy Boom unresponsive, no display - cannot reset

    Problem with a Squeezebox Boom. Not sure what triggered this, but possibly a failed firmware upgrade.

    Right now when powered on the display does not light at all. The individual buttons (1, 2, Back, Play etc) are all illuminated, but nothing happens when they are pressed.

    I have tried the two reset procedures described in the Wiki - that is to power on while pressing the 1 (one) on the remote (and also pressing the 1 button on the unit). And also tried same but with the + (plus) key on remote and unit. Regret no response to any of these.

    Other devices (Radio and Squeezebox Classic) running fine. Squeezebox Server at version 7.5.2, hosted on a QNAP 509 Turbo.

    Anything else I can try to revive the Boom? Feels rather Bricked otherwise.


  2. #2
    Senior Member toby10's Avatar
    Join Date
    Jul 2007
    USA (home of the bottomless credit card)
    I'd try..
    - unplugging it for an hour
    - pressing and HOLDING the left arrow on the Boom itself for about 20 seconds in hopes it might enter Setup
    - Brightness button
    - checking the PSU

  3. #3
    Senior Member Soulkeeper's Avatar
    Join Date
    Dec 2009
    And if it turns out to be totally bricked, don't toss it in the garbage right away. People will probably be interested in buying it for parts, like the speaker drivers (unless they're torn around the edges) and the display (unless that's what's defect).

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts