Home of the Squeezebox™ & Transporter® network music players.
Results 1 to 1 of 1
  1. #1
    Senior Member JadeMonkee's Avatar
    Join Date
    Oct 2008
    Location
    Somerset, UK
    Posts
    217

    Moved to Windows install from NAS, SC can't see local music directory

    Hi Guys,
    I've been wanting to improve the performance of SC by moving it from my ReadyNAS Duo to my Windows PC for a little while now, and I spent all day yesterday doing so.
    And it all worked last night, and I was happy.

    Only, this morning, my library was empty. I ripped a CD, and rescanned before I went to bed, but it seemed to be working fine.

    Here's what I did yesterday.

    I installed SC Version: 7.5.6 - r32834 @ Wed Jul 27 02:04:27 PDT 2011 on my Windows machine, and copied my music over to a local disk (D:\Albums).
    EDIT: I only chose 7.5.5 because I didn't want to be a 7.6 guinea pig, but if an upgrade means a solution/workaround fir this problem, I'm open to it.

    I actually keep a USB backup (NTFS formatted) of my music, so copied it over from there, rather than my NAS, because it's faster.

    Anyway, this morning, after I realised the library was now empty, I opened the control panel and found the library was referencing my old NAS install directory (now deleted).

    I noticed last night that I couldn't see my local music directory (D:\Albums) while selecting it from the web interface -- even though it appeared in the Control Panel.

    I thought nothing of that last night, so I just specified it in the Control Panel.

    But now, with the web interface still not being able to see my library (even though the Control Panel still can) I believe it's a permissions issue, probably related to copying the music over from my USB drive (which had copied them over from my NAS using the Microsoft SyncToy).

    I can get a scan running from the Control Panel, after selecting the local music directory, but I fear I will run into the same problems tomorrow (and I want my SB Boom to wake me up for work!).

    Also, I had the server running at startup (not login). Would this make any difference? I assumed that I provide my Windows username and password in the fields provided. The lack of help files/documentation on the Control Panel is woeful. I miss the SlimDevices days.

    Your help is appreciated. Thank you in advance.

    EDIT 2: I just had a thought... is it possible that the library disappeared because i triggered a rescan from within the web interface, cf the Control Panel?
    I shall investigate...

    EDIT 3: Nope... rescan from web interface worked fine. Hmmm... I wonder if the library disappearing may have been a once off thing?
    Last edited by JadeMonkee; 2011-08-14 at 02:19. Reason: Additional info

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •