Home of the Squeezebox™ & Transporter® network music players.
Results 1 to 8 of 8
  1. #1

    7.6 - How do i start WITHOUT control panel appearing???

    Just did a fresh install of windows 7-64 bit and SBS 7.6 (without any problems)...

    Server is set not to start automatically - starts via batch script i run when starting PC.

    Question: when SBS starts the control panel pops up an i have to press 'OK' on it to make it disappear... Is there a way i can start SBS without the controlpanel appearing???

  2. #2
    Senior Member JJZolx's Avatar
    Join Date
    Apr 2005
    Location
    Colorado
    Posts
    11,536
    Are you sure your batch file runs the correct program?

  3. #3
    Babelfish's Best Boy mherger's Avatar
    Join Date
    Apr 2005
    Location
    Switzerland
    Posts
    20,417

    7.6 - How do i start WITHOUTcontrol panel appearing???

    > Server is set not to start automatically - starts via batch script i
    > run when starting PC.
    >
    > Question: when SBS starts the control panel pops up an i have to press
    > 'OK' on it to make it disappear... Is there a way i can start SBS
    > without the controlpanel appearing???


    Make sure your batch script does start the server, and not the control
    panel. Why don't you configure the server to run as a service instead of
    by using a batch script?

    --

    Michael

  4. #4
    Quote Originally Posted by mherger View Post
    >Make sure your batch script does start the server, and not the control panel. Why don't you configure the server to run as a service instead of by using a batch script?

    --

    Michael
    How do i start the server without going through squeezetray????

    Server is not set to run as service, because the drives containing the music needs to be mounted first...

  5. #5
    Senior Member JJZolx's Avatar
    Join Date
    Apr 2005
    Location
    Colorado
    Posts
    11,536
    You run squeezesvr.exe

  6. #6
    Quote Originally Posted by JJZolx View Post
    You run squeezesvr.exe
    That seems to work - thx! - but i get some errors:

    [11-08-11 14:54:18.8027] Slim::bootstrap::tryModuleLoad (289) Warning: Module [Slim::Plugin::Orange::Plugin] failed to load:
    Can't locate URI/Split.pm in @INC (@INC contains: R:\Squeezeserver\Cache\InstalledPlugins C:\Program Files (x86)\Squeezebox\server\CPAN\arch\5.10\MSWin32-x86-multi-thread C:\Program Files (x86)\Squeezebox\server\CPAN\arch\5.10\MSWin32-x86-multi-thread\auto C:\Program Files (x86)\Squeezebox\server\CPAN\arch\5.10.0\MSWin32-x86-multi-thread C:\Program Files (x86)\Squeezebox\server\CPAN\arch\5.10.0\MSWin32-x86-multi-thread\auto C:\Program Files (x86)\Squeezebox\server\CPAN\arch\5.10\MSWin32-x86-multi-thread C:\Program Files (x86)\Squeezebox\server\CPAN\arch\5.10\MSWin32-x86-multi-thread\auto C:\Program Files (x86)\Squeezebox\server\CPAN\arch\MSWin32-x86-multi-thread C:\Program Files (x86)\Squeezebox\server\lib C:\Program Files (x86)\Squeezebox\server\CPAN C:/Program Files (x86)/Squeezebox/server C:/Program Files (x86)/Squeezebox/server C:\Users\tvserver\AppData\Local\Temp\pdk-tvserver-2004\ C:\Program Files (x86)\Squeezebox\server) at C:/Program Files (x86)/Squeezebox/server/Slim/Plugin/Orange/Plugin.pm line 8.
    BEGIN failed--compilation aborted at C:/Program Files (x86)/Squeezebox/server/Slim/Plugin/Orange/Plugin.pm line 8.
    Compilation failed in require at (eval 1425) line 2.
    BEGIN failed--compilation aborted at (eval 1425) line 2.

    [11-08-11 14:54:18.8033] Slim::Utils::PluginManager::load (288) Error: Couldn't load Slim::Plugin::Orange::Plugin


    Server runs fine, though - i can play my music on my radio/duet, and access the web interface... But the CMD box stays up - that's even worse than before; then i could just remove the control panel, now if i remove the cmd windows the server stops...

    *EDIT*
    Ok - removed a lot of useless plugins via web interface, so now i don't get the error anymore - but the cmd box stays (without cursor appearing) an when i close it i loose the server...
    Last edited by Hildebrandt; 2011-08-11 at 06:13.

  7. #7
    Babelfish's Best Boy mherger's Avatar
    Join Date
    Apr 2005
    Location
    Switzerland
    Posts
    20,417

    7.6 - How do i start WITHOUTcontrol panel appearing???

    > [11-08-11 14:54:18.8027] SLIM::BOOTSTRAP::TRYMODULELOAD (289) WARNING:
    > MODULE [SLIM::PLUGIN::ORANGE::PLUGIN] FAILED TO LOAD:
    > CAN'T LOCATE URI/SPLIT.PM IN @INC (@INC CONTAINS:


    If you're interested in using the Orange plugin you'd have to re-download
    the installer. There was a broken build which got published in the very
    first hours.

    If you're not interested in Orange, then just ignore it.

    --

    Michael

  8. #8
    Interesting thing - orange plugin wasn't activated, but the errors disappeared when i deactivated a lot of crap plugins.... (itunes etc)

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •