Home of the Squeezebox™ & Transporter® network music players.
Results 1 to 6 of 6
  1. #1
    Junior Member
    Join Date
    Jan 2011

    Squeezebox Radio/Volume Control Inoperative

    I just bought a used Squeezebox Radio from Amazon and when I first tried it the volume control did not work. I would turn the knob and the volume display would show but the knob would not adjust the volume, mute always works though. Sometimes if I spin the knob at different speeds it might adjust. I do have to mention that when I first powered up the radio that the software was updated and I heard that it has lots of issues. I also read somewhere that you could roll back the software, so I tried this and it has been working fine for about a week now and it's happening again. This time I said what the heck and updated the software back to the newest version and the volume control is working again. I seem to feel that is not a hardware issue as much as a software issue. The other issue I noticed is when you are scrolling to enter characters the order of the characters will change. I may have just entered the letter L and then I need to enter O and when I scroll to it it's not there or I have to chase it. I think this particular problem is related to the software version because the problem was there with the newest version, went away with the older version and is now back sometimes with the newer version. Has anybody ever had this particular problem with the volume control or should I just return the radio and get a new one? I noticed that these types of products all have their quirks and I could live with this if all it is is a quirk and not a hardware problem. I don't want to be without this radio now, this thing is amazing! It's like a modern day shortwave radio with even more, who would even want to listen to terrestrial radio after using this radio with all it's versatility!

  2. #2
    Senior Member toby10's Avatar
    Join Date
    Jul 2007
    USA (home of the bottomless credit card)
    I have not experienced either issue on my Radio. In which menu screen are you having trouble entering characters?

  3. #3
    Senior Member
    Join Date
    Oct 2009
    I've not experienced either of these issues either.

    Something you can try for the volume control issue... if the knob isn't changing the volume, try setting it through the web interface (i.e. log into MySqueezebox.com or your local SB server if you're using that) with your browser. Admittedly, the volume setting isn't quite as granular (10 or 11 steps, versus 100), but if you can change the volume setting through the web interface with no problem, then it could very well be a hardware issue.
    Squeezebox devices: Boom, Duet, and Radio
    DLNA devices: Sony Bravia TV, WMP11 on Win7
    LMS 7.7.2 running on a ReadyNAS Ultra 2 Plus

  4. #4
    Senior Member Mnyb's Avatar
    Join Date
    Feb 2006
    Vństerňs Sweden
    If you got the remote try with that ? otherwise return it and get a new one
    Main hifi: Touch + CIA PS +MeridianG68J MeridianHD621 MeridianG98DH 2 x MeridianDSP5200 MeridianDSP5200HC 2 xMeridianDSP3100 +Rel Stadium 3 sub.
    Bedroom/Office: Boom
    Kitchen: Touch + powered Fostex PM0.4
    Misc use: Radio (with battery)
    iPad1 with iPengHD & SqueezePad
    (spares Touch, SB3, reciever ,controller )
    server HP proliant micro server N36L with ClearOS Linux


  5. #5
    Senior Member
    Join Date
    Oct 2005
    To check whether the buttons work OK - use Settings/Advanced/Factory Test /Keypad

    All buttons must be tested and Vol & Knob rotated /pushed before it will return to menu.

  6. #6
    Senior Member
    Join Date
    Nov 2006

    This happened to me

    I just got one of the last Radios they're selling; the volume control knob seems to work immediately after setup, but stops working thereafter, and has no effect on volume.

    Ever figure this out?

    - Tim

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts