Home of the Squeezebox™ & Transporter® network music players.
Results 1 to 2 of 2
  1. #1
    Senior Member
    Join Date
    Apr 2005
    Posts
    8,410

    Hard time locking 44.1?

    Just an idea - as a work around to stop the DSP taking a while to stabilise
    when switching from MP3 to PCM, why not always stream as PCM and do server
    side decodes of MP3s?

    I for one would be happy with a configuration option to fix the Squeezebox
    SPDIF output to 44.1 and let the server do the rest.

    Must admit a quick look at lame seemed to suggest the need to two passes if
    you want it to resample and decode to PCM.

    Try adding the following to convert.conf and selecting it:

    mp3 wav * *
    [lame] --resample 44.1 --mp3input --silent $FILE$ - |
    [lame] --decode --mp3input --silient - -

    If all your mp3s are 44.1 sampled then the following would probably work:

    mp3 wav * *
    [lame] --mp3input --decode --silent $FILE$ -

    (my server [Pentium 200] is underpowered and can't sustain the double lame
    processes, but suggests this may work).

    Adrian

  2. #2
    Roy M. Silvernail
    Guest

    Hard time locking 44.1?

    On Mon, 2004-09-06 at 18:30, Triode wrote:
    > Just an idea - as a work around to stop the DSP taking a while to stabilise
    > when switching from MP3 to PCM, why not always stream as PCM and do server
    > side decodes of MP3s?
    >
    > I for one would be happy with a configuration option to fix the Squeezebox
    > SPDIF output to 44.1 and let the server do the rest.
    >
    > Must admit a quick look at lame seemed to suggest the need to two passes if
    > you want it to resample and decode to PCM.
    >
    > Try adding the following to convert.conf and selecting it:
    >
    > mp3 wav * *
    > [lame] --resample 44.1 --mp3input --silent $FILE$ - |
    > [lame] --decode --mp3input --silient - -
    >
    > If all your mp3s are 44.1 sampled then the following would probably work:
    >
    > mp3 wav * *
    > [lame] --mp3input --decode --silent $FILE$ -
    >
    > (my server [Pentium 200] is underpowered and can't sustain the double lame
    > processes, but suggests this may work).


    If you have sox available, this will get rid of the double-decode:

    [sox] -t .mp3 $FILE$ -t .wav -r 44100 -

    --
    Roy M. Silvernail is roy (AT) rant-central (DOT) com, and you're not
    "Progress, like reality, is not optional." - R. A. Hettinga
    SpamAssassin->procmail->/dev/null->bliss
    http://www.rant-central.com

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •