Home of the Squeezebox™ & Transporter® network music players.
Results 1 to 6 of 6
  1. #1

    squeezebox keeps randomly re-booting

    Hi

    I have been the happy owner of a squeezebox 3 for close to 5 years. No real problems up to recently. In the last week or so, the player has started to randomly re-boot itself while playing. It seems to completely power off and back on.

    Anyone else had similar experiences ? I dont think its a WIFI issue... I occasionally loose wifi (doesnt everyone) but that doesn't tend to re-boot the player (at least, not immediately).

    Any ideas ? Is there a way of logging what's going on so I can see if its a hardware issue ? I guess I could use this as an excuse to upgrade to a touch.... but what I dont want to do is get a new machine, only to find I get the same problems...

    Any guidance greatly appreciated !

  2. #2
    Senior Member
    Join Date
    Aug 2009
    Posts
    412
    Power supply on its last legs perhaps. Dodgy WiFi boards in the SB3 has caused a few problems here and there also, if you can live with a wired conection you could try removing the WiFi board.

  3. #3
    Senior Member toby10's Avatar
    Join Date
    Jul 2007
    Location
    USA (home of the bottomless credit card)
    Posts
    9,271
    It may just be a loose power connection. Check this by wiggling the power connection at the player, see if this causes a reboot.
    Could be a failing PSU as well.

    And, no, "losing WiFi" is not normal. What is the WiFi signal strength on your player? Possible interference near by? Router failing?

  4. #4
    Ive checked the power connections and all looks fine. I think I'll try a new power supply to start with.

    WIFI is running at >80%. When I say I loose wifi occasionally I mean every few weeks... probably a channel clash with a neighbor.. it aint a regular thing.

    CAT5 aint really an option. If a new PSU doesnt fix it, I might try a powerline connection. Anyone gone this route ?

    Cheers

  5. #5
    Senior Member
    Join Date
    May 2008
    Location
    United States, Florida
    Posts
    11,942
    Quote Originally Posted by DannyKudos View Post
    Ive checked the power connections and all looks fine. I think I'll try a new power supply to start with.

    WIFI is running at >80%. When I say I loose wifi occasionally I mean every few weeks... probably a channel clash with a neighbor.. it aint a regular thing.

    CAT5 aint really an option. If a new PSU doesnt fix it, I might try a powerline connection. Anyone gone this route ?

    Cheers
    lots of folks here report good outcomes with internet over powerline. But definitely check the interference with neighboring WiFI channels first. use netstumbler or vistumbler to see nearby networks and the channels they use.

  6. #6
    I have two Squeezeboxes which I believe are SB3s. One of these acts as a wired to wireless bridge between the wired LAN that has the NAS running Squeezebox Server on it and the wireless LAN with the other squeezeboxes.

    As noted in another post I am having some trouble with the wireless access point getting into a funny state, often triggered by using the squeezeboxes, particularly several squeezeboxes at once, synchronised.

    When the squeezebox acting as a bridge has lost contact with the wireless access point, cycling the power on the squeezebox can cause it to go into a kind of loop where it tries to associate with the wireless access point, fails, and then seems to reset itself (the Logitech logo reappears) then the whole thing repeats.

    There have been other odd occasions when this squeezebox has randomly reset though this is rare. As I have two of these I have tried swapping the squeezebox itself and the power supply independently and the one that resets is always the one acting as a bridge.

    I wonder if the random resets are actually due to firmware bugs with either a software exception mechanism or a hardware watchdog timer performing the reset.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •