Home of the Squeezebox™ & Transporter® network music players.
Page 1 of 2 12 LastLast
Results 1 to 10 of 17
  1. #1

    Dummy Questions from a new SB Touch Owner


    I have had my SB Touch a few days now and have been running it standalone with an external USB HDD playing FLAC files. So far I am very impressed.

    Would anyone be so kind as to answer some questions for me on the networking facilities of the Touch? I have read through the very brief manuals and many of the posts on this forum but I admit I am totally confused on this area of the Touch. I think that the problem lies with the fact that I do not understand the relationship between myqueezebox.com , The Touch and its internal server TinySC and the Squeezebox Server software.

    Here are some of the questions relating to functions on the Touch that I have been unable to work out :

    1. How do I move files from my computer to the Touch and also to the HDD attached to the touch? I cannot see the Touch on my computer when I look at network connections and have installed the SB Server software on my laptop (even though I am using TinySC with computer off when listening to music). Can an ddress be typed into an internet browser? I tried the address given by the Touch but I was still not asked for password or username. I have enabled sharing and SSH on the Touch.

    I found soundchecks blog with scripts to disable the analogue output. I would like to be able to access the files on the touch and to try disabling the analogue output as per the blog.

    2. The Patch Installer does not show any patches or any options to show non recommended patches. I want to fix the audio output at 100% as per a post on this forum for the fixed output patch.

    Many thanks, sorry for the dummy questions. I have tried to find out for myself but am not really getting anywhere.


  2. #2
    Senior Member
    Join Date
    Feb 2008
    Nij Beets, The Netherlands
    After enabling sharing, the Touch should be visible in your network. If not, try (e.g. in Explorer) to connect to \\Squeezeboxtouch\media-sdb1 (supposing you're under Windows).

    If you succeed in connecting, you can transfer music files via your network to the Touch USB disk, but it will be slow. What I do (and most people I think) is attach the USB drive to my computer and put the files I want on it.

    For SSH you need a telnet program (I use PuTTY on my PC) to 'enter' the Touch. Just enter the ip-address into the right field in PuTTY and enter the default password 1234 to enter the Touch. You have to look at the posts where the tweaks are described to see where (in which folder) you'll find the files you want to alter.


  3. #3
    Senior Member Phil Leigh's Avatar
    Join Date
    Apr 2005
    Cornwall, England
    If you want to see your HDD attached to the Touch, then don't install Soundcheck's first tweak as that turns off Samba Filesharing...
    You want to see the signal path BEFORE it gets onto a CD/vinyl...it ain't what you'd call minimal...
    Touch(wired/W7)+Teddy Pardo PSU - Audiolense 3.3/2.0+INGUZ DRC - MF M1 DAC - Linn 5103 - full Aktiv 5.1 system (6x LK140's, ESPEK/TRIKAN/KATAN/SEIZMIK 10.5), Pekin Tuner, Townsend Supertweeters,VdH Toslink,Kimber 8TC Speaker & Chord Signature Plus Interconnect cables
    Stax4070+SRM7/II phones
    Kitchen Boom, Outdoors: SB Radio, Harmony One remote for everything.

  4. #4

    Thanks for the replies. I shall have a look when I get home now I have been pointed in the right direction.

    Yes I am under windows XP, sorry forgot to mention that detail.

    I was only going to try switching off the analogue output (I just use the digital) out of Soundchecks tweaks as I did get the impression most of them would disable things that I need for using the internal server with external HDD.


  5. #5

    I have just downloaded PUTTY and put in the address as

    Then when it asks login as i enter squeezebox (as per what it says for the sharing account) then I enter the password 1234. The cursor doesn't move at thispoint but I assume that this is normal. Anyhow I get access denied as below:

    squeezebox@'s password:
    Access denied
    squeezebox@'s password:

    I have also tried in firefox internet explorer entering

    into the address bar but I get problem loading the page.

    I have double checked that SSH is enabled and sharing the device is enabled on the touch.

    I am probably being an idiot somewhere, but where am I going wrong?


  6. #6
    Further to my last message I have connected to mysqueezebox.com and can see the player connected. I have also changed some settings via the server settings (player tab).

    I have also been able to view third party patches and have installed the locked 100% volume patch I was after.

    I still though, cannot see the SB Touch from my laptop when looking at the network and I cannot SSH into the touch as posted above.


  7. #7
    Senior Member aubuti's Avatar
    Join Date
    Oct 2005
    Try logging in with the username root instead of squeezebox.

    When you are running standalone (that is, the Touch's built-in SbS server, also known as TinySC or TinySBS) you cannot access that server via your laptop's web browser. The Touch's built-in server has no support for web interface.

    Also note that at least some of the settings you changed via mysqueezebox.com may only apply to when you are using mysqueezebox.com, and not when you are using the built-in server (TinySBS).

    Considering your unfamiliarity with the system at this stage, I would strongly advise against doing any advanced tweaks to the Touch's operating system until you have a better handle on what you're doing in there.

  8. #8
    Senior Member iPhone's Avatar
    Join Date
    Oct 2007
    Two questions: Do you have SSH checked as On on the Touch? Did you go in under Root?
    Media Room:
    ModWright Platinum Signature Transporter, VTL TL-6.5 Signature Pre-Amp, Ayre MX-R Mono's, VeraStarr 6.4SE 6-channel Amp, Vandersteen Speakers: Quatro Wood Mains, VCC-5 Reference Center, four VSM-1 Signatures, Video: Runco RS 900 CineWide AutoScope 2.35:1, Vandersteen V2W Subwoofer

    Living Room:
    Transporter, ADCOM GTP-870HD, Cinepro 3K6SE III Gold, Vandersteen Model 3A Signature, Two 2Wq subs, VCC-2, Two VSM-1

    Office: Touch with Vandersteen VSM-1s
    Kitchen: Touch in-wall mount w/ Thiel Powerpoint 1.2s
    Bedroom: Squeezebox BOOM
    Bathroom: Squeezebox Radio
    Around the House: SliMP3, SB1, SB2, SB3
    Ford Thunderbird: SB Touch, USB drive
    Ford Expedition: SB Touch, USB drive

  9. #9
    Senior Member JJZolx's Avatar
    Join Date
    Apr 2005
    Quote Originally Posted by aubuti View Post
    Try logging in with the username root instead of squeezebox.
    Exactly. There are two sets of username/password for the Touch's networking facilities. The two different types of access must be enabled separately.

    1. SSH (Secure Shell, i.e. remote command-line access)

      • Enable SSH under
        Settings > Advanced > Remote Login > Enable SSH

      • Note that username is 'root' and the password is '1234'.

      • Use PuTTY for access to a terminal session.

      • Use WinSCP for copying files to the Touch's internal file system.

    2. Network share access to logs, and the hard drive

      • Enable network sharing under
        Settings > Advanced > USB & SD Storage > Sharing > Enable Sharing

      • For network share access the (default) username is 'Squeezebox' and the password is '1234'.

      • Access the logs and hard drive through Windows Explorer (not Internet Explorer or another web browser). You'll find the Touch under the workgroup named 'Workgroup'. Below that you should see the 'logs' share and some convoluted share name for the hard disk and/or SD card.

  10. #10
    Many thanks for all that info.

    Yes I was going to do alot more research before changing anything on the SB Touch but I just wanted to see that I could connect to it.

    Regarding the two options, I have enabled them and the problem is probably just the fact that I didn't enter root as the username. I shall have to try it tonight.

    I did find "workgroup" but it wouldn't let me open it, I can't remember the message I shall have another try tonight.

    Many thanks!

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts