Home of the Squeezebox™ & Transporter® network music players.
Page 1 of 2 12 LastLast
Results 1 to 10 of 17
  1. #1
    Junior Member
    Join Date
    Dec 2009
    Location
    Vriezenveen, Netherlands
    Posts
    12

    Workaround for too loud fallback alarm: change volume

    The fallback alarm is ringing the last week many times. This alarm is too loud.
    One option is to change the alarm.mp3 file, but another one is to change the volume setting:

    1. Log in to the radio using ssh
    2. Edit the AlarmSnoozeApplet file:
    vi /usr/share/jive/applets/AlarmSnooze/AlarmSnoozeApplet.lua
    3. search for volume (/volume)
    You will find this function:
    function soundFallbackAlarm(self)
    log:warn("soundFallbackAlarm()")
    self.localPlayer:volumeLocal(43)
    self.localPlayer:stop(true)
    self.alarmInProgress = 'rtc'
    self.localPlayerlayFileInLoop(self.alarmTone)
    end
    4. change the value of 43 to a lower one, e.g. 20:
    self.localPlayer:volumeLocal(20)
    5. save the file and you don't wake up with a heart-attack-alarm

    Hopefully you don't need the fallback alarm.

  2. #2
    Member
    Join Date
    Oct 2009
    Location
    Austria
    Posts
    88
    I'm posting to this very useful thread just to keep it up!

    best regards!
    simsboard
    so far only 1x Squeezebox Radio with selfmade batterykit
    changed from mysb.com to a local server
    http://www.lastfm.de/user/weanabazi

  3. #3
    Junior Member localhorst's Avatar
    Join Date
    Feb 2010
    Location
    Germany, HH
    Posts
    25

    Thumbs up

    Nice one - thanks gerko! I already had a few heard attacks because of this.
    This should be in future an editable option on the radio itself or on the server.

    *edit*
    Is it just me, or does anybody else have the feeling that the standard alarm comes way more often since the update to SBS 7.5.0?
    Before the update I nearly had the standard alarm never.
    Last edited by localhorst; 2010-04-20 at 01:56.

  4. #4
    Junior Member
    Join Date
    Dec 2005
    Posts
    22

    Thumbs up How to change fallback alarm.mp3

    Here is some useful information should you want to replace the Jingle-Jangle standard fallback alarm with your own MP3 (I've put together parts of what has been posted by others and what I found on the net, because I thought it would be useful to have this in this thread as well). One word of caution, be certain the file size of your replacement alarm.mp3 is roughly the same as the fallback alarm.mp3 (not megs in size) as you may use up all available memory in the Radio.

    To access the Squeezebox Radio via SSH:

    1. On the Radio, choose "Home > Settings > Advanced > Remote Login > Enable SSH". You should see a message telling you the root password and IP address. If you don't see the message, restart your Radio and try again.

    2. From your PC, use a program like WINSCP to SSH into the IP address of the Radio

    3. Enter "root" (without quotes) as the user and enter the password displayed on the Radio when you "enable ssh" (the default is "1234"(without quotes)).

    Once you are in via SSH, you can find the default alarm.mp3 at the location:

    /usr/share/jive/applets/AlarmSnooze/alarm.mp3

    Simply copy your alarm.mp3 to this location and replace the default. It is also a good idea to reduce the fallback alarm volume as indicated in this thread as I found it was playing even my "replacement" fallback alarm.mp3 at heart attack levels!!

    Worked like a charm for me, no more Jingle-Jangle!

    Good Luck!!!

    Jakearama.

  5. #5
    Junior Member localhorst's Avatar
    Join Date
    Feb 2010
    Location
    Germany, HH
    Posts
    25
    Quote Originally Posted by Jakearama View Post
    2. From your PC, use a program like WINSCP to SSH into the IP address of the Radio
    How did you get on the Radio with WinSCP? All i get is:
    Cannot initialize SFTP protocol. Is the host running a SFTP server?

  6. #6
    Junior Member
    Join Date
    Dec 2005
    Posts
    22

    Smile

    Quote Originally Posted by localhorst View Post
    How did you get on the Radio with WinSCP? All i get is:
    Just change the "File Protocol" type on the WinSCP login screen to "SCP" (see the attached jpeg).

    Ignore any error messages and away you go!

    Jakearama.

  7. #7
    Junior Member localhorst's Avatar
    Join Date
    Feb 2010
    Location
    Germany, HH
    Posts
    25
    Woo - that easy (slaps himself)! Thanks a million, Jakearama!

  8. #8
    Junior Member
    Join Date
    Dec 2005
    Posts
    22
    My pleasure!

    Jakearama.

  9. #9
    Senior Member erland's Avatar
    Join Date
    Dec 2005
    Location
    Sweden
    Posts
    11,046
    For anyone using 7.5, I've now added a patch for this that can be installed through the third party Patch Installer applet.

    1. Install the third party Patch Installer applet through Settings/Advanced/Applet Installer
    2. Install the "Low Volume Fallback Alarm" patch through Settings/Advanced/Patch Installer (you have to uncheck the "Recommended Patches Only" checkbox to be able to see it)

    The patch will change the volume to 20 instead of the default 43.
    The Patch Installer applet requires 7.5, so this procedure won't work for users using 7.4.* or earlier releases.
    Erland Isaksson (My homepage)
    Developer of many plugins/applets

  10. #10
    Junior Member
    Join Date
    Apr 2010
    Posts
    8
    Hi Erland, does your low volume for the fallback alarm applet work with 7.5.1 as I cannot find it, "Recommended Applets Only" is unchecked and I can see other applets including your own but no low volume fallback alarm.

    Regards Pete

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •