Home of the Squeezebox™ & Transporter® network music players.
Results 1 to 7 of 7
  1. #1
    Junior Member
    Join Date
    Mar 2010
    Posts
    17

    iTunes Update not working correctly under OSX

    Hi,

    I'm having trouble getting iTunesUpdate to work properly.

    Installation:
    I'm running on a new iMac under Snow Leopard. Squeezebox Server, iTunesUpdate, TrackStat, CustomScan and SugarCube (all installed via repository) and iTunes are all up to date. Developer tools and Glue (force install first, later updated successfully without errors) have been installed. No tweaks have been applied i.e. standard settings.

    What is working and what is not working:
    + In Squeezebox Server there is the new iTunesUpdate entry.
    - The iTunesUpdate info page does not show TrackStat ratings.
    + iTunes gets automatically started after half a track is played.
    + The play count in iTunes is updated.
    - The play count increases by 2 instead of 1.
    - When playing a playlist or album the play count increases only the first track, and this track will get a count of 2 added for each other track played.
    - No ratings are transferred to iTunes whatsoever.
    - Using the "Direct Update" option does not change this behavior except that iTunes will not start automatically.
    + No errors show up in the server log.

    I'd be glad for any help.
    Thanks,
    Thomas

  2. #2
    Senior Member
    Join Date
    Apr 2005
    Location
    London
    Posts
    647

    iTunes Update not working correctlyunder OSX

    Hi,
    First suggestion would be to change the plugin.iTunesUpdate logging setting to Debug to see what's really happening.

    James

    --------------------------------------------------------------------------
    NOTICE: If received in error, please destroy, and notify sender. Sender does not intend to waive confidentiality or privilege. Use of this email is prohibited when received in error. We may monitor and store emails to the extent permitted by applicable law.

  3. #3
    Junior Member
    Join Date
    Mar 2010
    Posts
    17

    iTunes Update not working correctly under OSX: Log file

    James, thanks for your response.
    This is what I found out:

    [10-03-24 01:33:19.7605] Plugins::iTunesUpdate::Settings::handler (71) directupdate:$VAR1 = "on";
    [10-03-24 01:33:19.7607] Plugins::iTunesUpdate::Settings::handler (71) set_artwork:$VAR1 = undef;
    [10-03-24 01:33:19.7610] Plugins::iTunesUpdate::Settings::handler (71) ignore_filetype:$VAR1 = undef;
    [10-03-24 01:33:19.7612] Plugins::iTunesUpdate::Settings::handler (71) halfstar:$VAR1 = undef;
    [10-03-24 01:33:19.7614] Plugins::iTunesUpdate::Settings::handler (71) bookmarks:$VAR1 = undef;

    [10-03-24 01:35:04.5923] Slim::Control::Request::notify (2108) Error: Failed notify: Mac::AppleScript returned error (-1753)
    [10-03-24 01:35:04.8290] Slim::Control::Request::notify (2108) Error: Failed notify: Can't call method "playcount" on an undefined value at /Users/thomas/Library/Caches/Squeezebox/InstalledPlugins/Plugins/TrackStat/Plugin.pm line 2259.
    [10-03-24 01:35:04.8360] Slim::Control::Request::notify (2108) Error: Failed notify: Can't call method "url" on an undefined value at Plugins/iTunesUpdate/Plugin.pm line 1575.

    [10-03-24 01:37:36.9203] Slim::Control::Request::notify (2108) Error: Failed notify: Can't call method "url" on an undefined value at Plugins/iTunesUpdate/Plugin.pm line 1575.
    [10-03-24 01:37:36.9841] Slim::Utils::Misc::msg (1165) Warning: [01:37:36.9838] DBIx::Class::ResultSet::single(): Query returned more than one row. SQL that returns multiple rows is DEPRECATED for ->find and ->single at /Library/PreferencePanes/Squeezebox.prefPane/Contents/server/Slim/Schema/Track.pm line 159
    [10-03-24 01:37:37.0070] Slim::Control::Request::notify (2108) Error: Failed notify: Can't call method "url" on an undefined value at Plugins/iTunesUpdate/Plugin.pm line 1575.

    Any clues?
    Thanks for your help, Thomas

  4. #4
    Member
    Join Date
    Mar 2009
    Location
    Germany
    Posts
    81
    >[10-03-24 01:35:04.5923] Slim::Control::Request::notify (2108) Error: Failed notify: Mac::AppleScript returned error (-1753)

    I have the same Error (-1753).
    From one day to another.
    Glue was installed properly. And suddenly only that error. even reinstalls or many reboot did not fix that problem.

  5. #5
    Senior Member
    Join Date
    Apr 2005
    Location
    London
    Posts
    647

    iTunes Update not working correctlyunderOSX

    I think the 1753 error has come up a few times before.
    You can try searching the forums for it but not sure there's ever been a definite answer as to what it is and how to fix it!

    James


    --------------------------------------------------------------------------
    NOTICE: If received in error, please destroy, and notify sender. Sender does not intend to waive confidentiality or privilege. Use of this email is prohibited when received in error. We may monitor and store emails to the extent permitted by applicable law.

  6. #6
    Junior Member
    Join Date
    Mar 2010
    Posts
    17
    Looks like I have to give up on the idea of syncing ratings and play counts.
    Any idea whom to contact about this issue? Logitech? THe SB Server developers?
    Thanks for trying to help!

  7. #7
    Member
    Join Date
    Mar 2009
    Location
    Germany
    Posts
    81
    I just wanted to leave the information that even an update to 10.6.3 did not solve the problem. There's still a -1753 in the logs

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •