Home of the Squeezebox™ & Transporter® network music players.
Results 1 to 5 of 5
  1. #1
    Junior Member
    Join Date
    Feb 2010
    Posts
    3

    QNAP 119 have problem transcoding FLAC to MP3?

    Hi

    I use a Boom and Squeezebox 3 via wirelsess running off Squeezebox Server 7.5 (just upgraded from 7.4.1) on a QNAP 119. All my music is exclusively FLAC and this has worked flawlessly for many years (bar the odd Wifi outage).

    I have recently been looking at streaming music via the internet to my iphone and need to stream this as MP3 due to the narrower bandwidth available. However, I have been unable to get this to work.

    Thinking it might be due to firewall issues, I then tried to set the bitrate limit levels in the player audio settings to stream this to my Boom and Squeezebox on the internal network. The server states that LAME is installed and I have tried all levels of compression and both Direct and Proxied settings, but the MP3 stream will not play. The player moves onto the next track when I FF to clear the buffer, but there is no music and the VU meters do not show any activity, even though the server does show the track is playing.

    I have checked the CPU utilisation on the QNAP and it rarely rises above 10% when transcoding (from about 3% when playing FLAC natively), and the settings under the file formatting settings are set to use LAME when streaming MP3 from FLAC.

    I'm stumped - anyone have any suggestions?

    Alex

  2. #2
    Member
    Join Date
    Jan 2010
    Location
    London
    Posts
    32
    I have never managed to do this on my QNAP but I have the 109 and it seems to be caused by the cpu maxing out at 100%.

    You say you are using lame to encode flac to mp3. Would have though you need 2 programs involved 1 to convert flac to wav and then lame to convert wav to mp3.
    Transporter > Naim Nait 5i2 > PMC GB1i
    SB Touch & SB3 / QNAP TS109II
    Last FM

  3. #3
    Senior Member
    Join Date
    Dec 2009
    Location
    Germany
    Posts
    359
    the qnap 119 is based on the marvel sheeva CPU. This CPU lacks floating point support. Encoding MP3 with lame will most likely overload the CPU.

  4. #4
    Senior Member
    Join Date
    Mar 2008
    Location
    Netherlands
    Posts
    752
    Quote Originally Posted by fragfutter View Post
    the qnap 119 is based on the marvel sheeva CPU. This CPU lacks floating point support. Encoding MP3 with lame will most likely overload the CPU.
    it can do the encoding, but not in real time, so you get continuous rebuffering.
    Setup: 1 Touch, 4 Booms and 1 Radio.
    Server: LMS 7.8 (DebianVM in Proxmox), Tonido for webbased playback

  5. #5
    Junior Member
    Join Date
    Feb 2010
    Posts
    3
    Thanks for the responses.

    I feared this was the case but was surprised that my CPU didn't appear to be maxing out.

    Anyone know of an alternative way to support coding to MP3 in real time without floating point support?

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •