Originally I had version 5.1.5 of the slimserver. I never actually checked what the previous firmware was, but with the 5.1.5, it was within the 2.x family. I just tried the nightly build with the 31 firmware, but it made no difference.