Home of the Squeezebox™ & Transporter® network music players.
Results 1 to 4 of 4
  1. #1
    Junior Member
    Join Date
    Oct 2009
    Posts
    2

    Drives mounting after squeezebox server

    I store my music on a network drive which I mount at boot up using the /etc/fstab file, however I think that the drive is mounted after the squeezebox server starts. When I browse to the server there is no music listed, if I manually restart the service it's all fine, I also get the same behaviour if I unmount the drive and restart the service.

    Is it possible to control the order that services start, so they start after the drive is mounted?

    Sorry if this is a basic question, but I'm very new to ubuntu.

  2. #2
    Senior Member aubuti's Avatar
    Join Date
    Oct 2005
    Posts
    8,839
    Yes, it is possible to control the order of services. I think the easiest way to do it on Ubuntu is through the Boot-Up Manager (bum). Install bum via Synaptic Package Manager or apt-get and then use bum's graphic interface to put the start up sequence for your services in order. In bum, go to the 'Services' tab, select the service, and right click to edit the start/stop priority.

  3. #3
    Senior Member
    Join Date
    Apr 2008
    Location
    France
    Posts
    2,272

    What it your linux flavor ?

    The name of the linux distribution you're using will change the response.
    For exemple in ubuntu, you have to look at the files in /etc/rc2.d/
    Files named S01foo will be launched first, files S99bar and S99baz launched last, in this order, when your start.
    Files named K-something are here to shutdown services that were active before and not needed in the configuration of services composed by the directory.
    Have a look at the documentation on boot / init for your machine, this will be spelled. I found this brief introduction: http://en.wikipedia.org/wiki/Init

    Back to the ubuntu case, if you simply rename a file from S12 to S99, you push it back to the end of initialization.
    EDIT: Well, use the "bum" thing, that is probably a better advice.

    However, reading fstab and executing the mounts is done very early in the boot process. So I doubt this is the problem, really.

    You could verify that your fstab lines pertaining the elusive drive do not contain the option noauto. Noauto blocks automatic execution. Remove noauto, or change it to auto.

    Another possibility I see is wrong ordering of your mounts in fstab:
    Line 1 - /dev/sda /
    Line 2 - /dev/sdb /foo/bar
    Line 3 - /dev/sdc /foo
    Will leave you with sdc mounted over sdb over sda (or sdb not mounted at all). You would not see the contents of dir "bar" as expected. Reissuing the mount afterwards would succeed.
    But this would work every time, as the mount order is correct:
    Line 1 - /dev/sda /
    Line 2 - /dev/sdc /foo
    Line 3 - /dev/sdb /foo/bar

    HTH

  4. #4
    Junior Member
    Join Date
    Oct 2009
    Posts
    2

    Fixed

    Thanks both for your help, moving the service down the list solved the issue.

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •