Home of the Squeezebox™ & Transporter® network music players.
Page 90 of 113 FirstFirst ... 40808889909192100 ... LastLast
Results 891 to 900 of 1126
  1. #891
    Babelfish's Best Boy mherger's Avatar
    Join Date
    Apr 2005
    Location
    Switzerland
    Posts
    20,430

    SSODS 4 released

    > Unfortunately nobody. Flipflip stopped supporting it around 3 years ago
    > and a couple of enthusiasts have patched it up to keep it going since.


    If patching is possible, then there's obviously need for another patch
    :-). Who's been doing such patches?

    --

    Michael

  2. #892
    Senior Member TheLastMan's Avatar
    Join Date
    Mar 2008
    Location
    Richmond (Surrey not VA)
    Posts
    1,005
    Quote Originally Posted by mherger View Post
    > Unfortunately nobody. Flipflip stopped supporting it around 3 years ago
    > and a couple of enthusiasts have patched it up to keep it going since.


    If patching is possible, then there's obviously need for another patch
    :-). Who's been doing such patches?

    --

    Michael
    j-r
    See further up this thread for a link to his latest versions here
    And on another thread started by him here
    Matt
    SqueezeBoxes: 3 x piCorePlayers with two Duets, one no longer in active service.
    Server: Synology DS214 (2TB) NAS running LMS 7.9.1
    Network: TP-Link Archer VR200 router, 3 x Netgear Orbi WiFi mesh access points (amazing!).
    Livingroom: Duet, Linn LP12, Naim 72/Hi-cap/110/Headline amp, B&W CM2 speakers
    Kitchen: piCorePlayer, Tibo powered speakers.
    Dining: piCorePlayer, second hand Cambridge amp and speakers.
    Portable: piCorePlayer with LMS and copy music library.

  3. #893
    Senior Member pinkdot's Avatar
    Join Date
    Nov 2009
    Location
    The Netherlands
    Posts
    1,215
    Quote Originally Posted by mherger View Post
    > Unfortunately nobody. Flipflip stopped supporting it around 3 years ago
    > and a couple of enthusiasts have patched it up to keep it going since.


    If patching is possible, then there's obviously need for another patch
    :-). Who's been doing such patches?

    --

    Michael
    Fixed it! I'm not into coding but thanx to you Michael! I Looked for the hard coded lines. Found just one and changed it according to the Github change: CPAN/Compress/Raw/Zlib.pm → CPAN/arch/5.10/Compress/Raw/Zlib.pm

    In the folder SSODS4/share/sbs/ look for the file 'shipped-binairies. Change line 68 to:

    Code:
    CPAN/arch/*/Compress/Raw/Zlib.pm
    Done!
    Plugins are updating fine now.

  4. #894
    Babelfish's Best Boy mherger's Avatar
    Join Date
    Apr 2005
    Location
    Switzerland
    Posts
    20,430

    SSODS 4 released

    > Fixed it!

    excellent! Please provide the modified file to j-r so he could use it
    for new builds.


    --

    Michael

  5. #895
    Senior Member
    Join Date
    Dec 2008
    Posts
    276
    Quote Originally Posted by pinkdot View Post
    Done!
    Plugins are updating fine now.
    I can confirm, thanks.

    May need to start/stop ssods for it to pick up the changes.

    Quote Originally Posted by obee View Post
    Hi,
    Can you share with us how to install LMS 7.9? Thanks
    For Unraid or SSODS?

  6. #896
    Member patatorz's Avatar
    Join Date
    Oct 2007
    Location
    France - Grenoble
    Posts
    99
    Quote Originally Posted by obee View Post
    Hi,
    I am uisng x86 NAS, is there support of LMS ver 7.9 on x86 Synology NAS? Because I want to have support of DSD playback.
    Thanks in advance.
    I'm in the same case. Any feedback ?

    Thanks for your support

  7. #897
    Member
    Join Date
    Jul 2008
    Location
    Aarhus, Denmark
    Posts
    67
    I'm running 7.9 on a Synology x86 NAS without any problems in SSODS.

    Only thing that needs to be done is updating one of the files in SSODS to look for 7.9 files.
    Can't remember which but should be somewhere within this thread.

  8. #898
    Senior Member pinkdot's Avatar
    Join Date
    Nov 2009
    Location
    The Netherlands
    Posts
    1,215
    You proberbly need to do two things:

    First change line 133 in the etc/ssods.conf:
    The old line looks something like this:
    Code:
    # pattern for tar balls
    SSTARBALLPATTERN="{[sS]lim[sS]erver,[sS]queeze[cC]enter,[sS]queezebox[sS]erver}*.{tar.gz,tar.bz2,tgz,tbz}"
    Change it to (this will ssods recognize the tarball):
    Code:
    # pattern for tar balls
    SSTARBALLPATTERN="{[sS]lim[sS]erver,[sS]queeze[cC]enter,[sS]queezebox[sS]erver,[lL]ogitech[mM]edia[sS]erver}*.{tar.gz,tar.bz2,tgz,tbz}"
    The other one is a change in the libexec/routines.sh:
    Change line 69 into (this will validate the version number):
    Code:
    ssversion=`sed -n 's/^[^#]*\$VERSION[ \t]*=[ \t]*'"'"'\([0123456789\.]*\)'"'"'[ \t]*;/\1/p' ${SSBIN} 2>/dev/null`
    I don't have a x86 nas but these changes could be valid for the ssods for x86 as well (they are for Arm).
    Even this change might be applicable:
    In the folder SSODS4/share/sbs/ look for the file 'shipped-binairies. Change line 68 to:

    Code:
    CPAN/arch/*/Compress/Raw/Zlib.pm
    Hope this helps.

  9. #899
    Member
    Join Date
    Jul 2008
    Location
    Aarhus, Denmark
    Posts
    67
    I remeber only adding the 9 to the version validation, but the other suggestions are probably valid as well.

  10. #900
    Member patatorz's Avatar
    Join Date
    Oct 2007
    Location
    France - Grenoble
    Posts
    99
    Quote Originally Posted by pinkdot View Post
    You proberbly need to do two things:

    First change line 133 in the etc/ssods.conf:
    The old line looks something like this:
    Code:
    # pattern for tar balls
    SSTARBALLPATTERN="{[sS]lim[sS]erver,[sS]queeze[cC]enter,[sS]queezebox[sS]erver}*.{tar.gz,tar.bz2,tgz,tbz}"
    Change it to (this will ssods recognize the tarball):
    Code:
    # pattern for tar balls
    SSTARBALLPATTERN="{[sS]lim[sS]erver,[sS]queeze[cC]enter,[sS]queezebox[sS]erver,[lL]ogitech[mM]edia[sS]erver}*.{tar.gz,tar.bz2,tgz,tbz}"
    The other one is a change in the libexec/routines.sh:
    Change line 69 into (this will validate the version number):
    Code:
    ssversion=`sed -n 's/^[^#]*\$VERSION[ \t]*=[ \t]*'"'"'\([0123456789\.]*\)'"'"'[ \t]*;/\1/p' ${SSBIN} 2>/dev/null`
    I don't have a x86 nas but these changes could be valid for the ssods for x86 as well (they are for Arm).
    Even this change might be applicable:
    In the folder SSODS4/share/sbs/ look for the file 'shipped-binairies. Change line 68 to:

    Code:
    CPAN/arch/*/Compress/Raw/Zlib.pm
    Hope this helps.
    Hello, making that allowed to find "SqueezeboxServer 7.9.0-1403985527" and I installed it. But it does not start and I'm wonderinf it it does not come from the last line to change (CPAN...). I use SSODS 4.14
    Here is the code of the error :
    Code:
    0593: [14-07-05 19:14:54     ] ssctrl failed to start SqueezeboxServer.
    0592: 
    0591: 3. Run the .tar.gz version of Logitech Media Server which includes all required CPAN modules.
    0590: 2. Update the module's package using apt-get, yum, etc.
    0589: 1. Install the latest version of the module(s) using CPAN: sudo cpan Some::Module
    0588: To fix this problem you have several options:
    0587: 
    0586:   XML::Parser (loaded 2.36, need 2.41)
    0585:   Sub::Name (loaded 0.04, need 0.05)
    0584:   Image::Scale (loaded 0.06, need 0.08)
    0583:   HTML::Parser (loaded 3.62, need 3.68)
    0582:   HTML::Entities (loaded 3.60, need 3.68)
    0581:   Audio::Scan (loaded , need 0.93)
    0580: The following CPAN modules were found but cannot work with Logitech Media Server:
    0579: Bareword found in conditional at /volume1/SSODS4/var/home/SqueezeboxServer/CPAN/AnyEvent/constants.pl line 37.
    0578: [14-07-05 19:14:53     ] ssctrl Command line = /opt/ssods4/var/home/SqueezeboxServer/slimserver.pl  --daemon --pidfile /opt/ssods4/var/home/SqueezeboxServer/Cache/squeezecenter.pid --cachedir /opt/ssods4/var/home/SqueezeboxServer/Cache --logdir /opt/ssods4/var/home/SqueezeboxServer/Logs --prefsdir /opt/ssods4/var/home/SqueezeboxServer/Prefs --noupnp --priority 0 --user admin --group users 
    0577: [14-07-05 19:14:53     ] ssctrl Disabled /opt/ssods4/var/home/SqueezeboxServer/CPAN/arch/5.8/x86_64-linux-thread-multi/auto/Image/Scale/Scale.so
    0576: [14-07-05 19:14:53     ] ssctrl Disabled /opt/ssods4/var/home/SqueezeboxServer/CPAN/arch/5.8/sparc-linux/auto/Image/Scale/Scale.so
    0575: [14-07-05 19:14:53     ] ssctrl Disabled /opt/ssods4/var/home/SqueezeboxServer/CPAN/arch/5.8/powerpc-linux-thread-multi/auto/Image/Scale/Scale.so
    0574: [14-07-05 19:14:53     ] ssctrl Disabled /opt/ssods4/var/home/SqueezeboxServer/CPAN/arch/5.8/i386-linux-thread-multi/auto/Image/Scale/Scale.so
    0573: [14-07-05 19:14:53     ] ssctrl Disabled /opt/ssods4/var/home/SqueezeboxServer/CPAN/arch/5.8/arm-linux-gnueabi-thread-multi/auto/Image/Scale/Scale.so
    0572: [14-07-05 19:14:53     ] ssctrl Disabled /opt/ssods4/var/home/SqueezeboxServer/CPAN/arch/5.18/x86_64-linux-thread-multi/auto/Image/Scale/Scale.so
    0571: [14-07-05 19:14:53     ] ssctrl Disabled /opt/ssods4/var/home/SqueezeboxServer/CPAN/arch/5.18/i386-linux-thread-multi-64int/auto/Image/Scale/Scale.so
    0570: [14-07-05 19:14:53     ] ssctrl Disabled /opt/ssods4/var/home/SqueezeboxServer/CPAN/arch/5.16/x86_64-linux-thread-multi/auto/Image/Scale/Scale.so
    0569: [14-07-05 19:14:53     ] ssctrl Disabled /opt/ssods4/var/home/SqueezeboxServer/CPAN/arch/5.16/i386-linux-thread-multi/auto/Image/Scale/Scale.so
    0568: [14-07-05 19:14:53     ] ssctrl Disabled /opt/ssods4/var/home/SqueezeboxServer/CPAN/arch/5.14/x86_64-linux-thread-multi/auto/Image/Scale/Scale.so
    0567: [14-07-05 19:14:53     ] ssctrl Disabled /opt/ssods4/var/home/SqueezeboxServer/CPAN/arch/5.14/powerpc-linux-thread-multi-64int/auto/Image/Scale/Scale.so
    0566: [14-07-05 19:14:53     ] ssctrl Disabled /opt/ssods4/var/home/SqueezeboxServer/CPAN/arch/5.14/i386-linux-thread-multi/auto/Image/Scale/Scale.so
    0565: [14-07-05 19:14:53     ] ssctrl Disabled /opt/ssods4/var/home/SqueezeboxServer/CPAN/arch/5.14/i386-linux-thread-multi-64int/auto/Image/Scale/Scale.so
    0564: [14-07-05 19:14:53     ] ssctrl Disabled /opt/ssods4/var/home/SqueezeboxServer/CPAN/arch/5.14/arm-linux-gnueabi-thread-multi-64int/auto/Image/Scale/Scale.so
    0563: [14-07-05 19:14:53     ] ssctrl Disabled /opt/ssods4/var/home/SqueezeboxServer/CPAN/arch/5.14/arm-linux-gnueabihf-thread-multi-64int/auto/Image/Scale/Scale.so
    0562: [14-07-05 19:14:53     ] ssctrl Disabled /opt/ssods4/var/home/SqueezeboxServer/CPAN/arch/5.12/x86_64-linux-thread-multi/auto/Image/Scale/Scale.so
    0561: [14-07-05 19:14:53     ] ssctrl Disabled /opt/ssods4/var/home/SqueezeboxServer/CPAN/arch/5.12/powerpc-linux-thread-multi-64int/auto/Image/Scale/Scale.so
    0560: [14-07-05 19:14:53     ] ssctrl Disabled /opt/ssods4/var/home/SqueezeboxServer/CPAN/arch/5.12/i386-linux-thread-multi/auto/Image/Scale/Scale.so
    0559: [14-07-05 19:14:53     ] ssctrl Disabled /opt/ssods4/var/home/SqueezeboxServer/CPAN/arch/5.12/i386-linux-thread-multi-64int/auto/Image/Scale/Scale.so
    0558: [14-07-05 19:14:53     ] ssctrl Disabled /opt/ssods4/var/home/SqueezeboxServer/CPAN/arch/5.12/arm-linux-gnueabi-thread-multi-64int/auto/Image/Scale/Scale.so
    0557: [14-07-05 19:14:53     ] ssctrl Disabled /opt/ssods4/var/home/SqueezeboxServer/CPAN/arch/5.10/x86_64-linux-thread-multi/auto/Image/Scale/Scale.so
    0556: [14-07-05 19:14:53     ] ssctrl Disabled /opt/ssods4/var/home/SqueezeboxServer/CPAN/arch/5.10/powerpc-linux-thread-multi/auto/Image/Scale/Scale.so
    0555: [14-07-05 19:14:53     ] ssctrl Disabled /opt/ssods4/var/home/SqueezeboxServer/CPAN/arch/5.10/i386-linux-thread-multi/auto/Image/Scale/Scale.so
    0554: [14-07-05 19:14:53     ] ssctrl Disabled /opt/ssods4/var/home/SqueezeboxServer/CPAN/arch/5.10/arm-linux-gnueabi-thread-multi/auto/Image/Scale/Scale.so
    0553: [14-07-05 19:14:53     ] ssctrl Disabled /opt/ssods4/var/home/SqueezeboxServer/CPAN/Image/Scale.pm
    0552: [14-07-05 19:14:53     ] ssctrl Disabled /opt/ssods4/var/home/SqueezeboxServer/CPAN/Linux/Inotify2.pm
    0551: [14-07-05 19:14:53   
    0004: [14-07-05 19:14:50     ] ssctrl Cannot determine path to SS binaries.
    0003: [14-07-05 19:14:50     ] ssctrl Warning: system errmsg.sys () and/or errmsg.txt () not found. Trying to start anyway.
    0002: [14-07-05 19:14:50     ] ssctrl Using system mysqld: /usr/syno/mysql/libexec/mysqld
    0001: [14-07-05 19:14:49     ] ssctrl Starting SqueezeboxServer 7.9.0-1403985527.
    Thanks for your support
    Last edited by patatorz; 2014-07-05 at 10:23.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •