Home of the Squeezebox™ & Transporter® network music players.
Results 1 to 8 of 8

Thread: SSH into Radio

  1. #1
    Senior Member
    Join Date
    Sep 2009
    Posts
    177

    SSH into Radio

    I set the remote login into my radio to allow SSH. Then I attempted to use putty using the radio's ip address. I kept getting connection refused. Is port 22 the correct port to go into?

    Thanks!

  2. #2
    Junior Member
    Join Date
    Mar 2008
    Location
    Surbiton, Surrey, UK
    Posts
    29
    Quote Originally Posted by vw195 View Post
    I set the remote login into my radio to allow SSH. Then I attempted to use putty using the radio's ip address. I kept getting connection refused. Is port 22 the correct port to go into?

    Thanks!
    Port 22 is right. I enabled it and had a hunt around the filesystem myself

  3. #3
    Senior Member iPhone's Avatar
    Join Date
    Oct 2007
    Location
    Atlanta
    Posts
    3,295
    Quote Originally Posted by vw195 View Post
    I set the remote login into my radio to allow SSH. Then I attempted to use putty using the radio's ip address. I kept getting connection refused. Is port 22 the correct port to go into?

    Thanks!
    Are you currently Ethernet or wireless?

    Yes that is correct. I just logged into my Radio so that should work. Quick question: In Putty you do have SSH bulleted? And when you attempt login it doesn't ask, Login as: ?

    Try this: Goto Settings> Advance> Remote Login and click the enable box. Now leave the Radio at that point without making any other changes. Now use Putty to attempt a login. I know this shouldn't matter, but when I have trouble logging in, this always works for me.
    iPhone
    Media Room:
    ModWright Platinum Signature Transporter, VTL TL-6.5 Signature Pre-Amp, Ayre MX-R Mono's, VeraStarr 6.4SE 6-channel Amp, Vandersteen Speakers: Quatro Wood Mains, VCC-5 Reference Center, four VSM-1 Signatures, Video: Runco RS 900 CineWide AutoScope 2.35:1, Vandersteen V2W Subwoofer

    Living Room:
    Transporter, ADCOM GTP-870HD, Cinepro 3K6SE III Gold, Vandersteen Model 3A Signature, Two 2Wq subs, VCC-2, Two VSM-1

    Office: Touch with Vandersteen VSM-1s
    Kitchen: Touch in-wall mount w/ Thiel Powerpoint 1.2s
    Bedroom: Squeezebox BOOM
    Bathroom: Squeezebox Radio
    Around the House: SliMP3, SB1, SB2, SB3
    Ford Thunderbird: SB Touch, USB drive
    Ford Expedition: SB Touch, USB drive

  4. #4
    Senior Member
    Join Date
    Oct 2007
    Location
    Redwood City, Ca
    Posts
    448
    Quote Originally Posted by vw195 View Post
    I set the remote login into my radio to allow SSH. Then I attempted to use putty using the radio's ip address. I kept getting connection refused. Is port 22 the correct port to go into?

    Thanks!
    Did the screen pop up with a "SSH is now enabled, here's your user and password" screen? (paraphrased) If not, SSH didnt enable properly -- in that case, try rebooting and re-enabling.

  5. #5
    Senior Member
    Join Date
    Sep 2009
    Posts
    177
    Quote Originally Posted by iPhone View Post
    Are you currently Ethernet or wireless?

    Yes that is correct. I just logged into my Radio so that should work. Quick question: In Putty you do have SSH bulleted? And when you attempt login it doesn't ask, Login as: ?
    Currently I am wireless, and SSH is bulleted. It never does ask me for a login. It simply says Connection refused.

    Quote Originally Posted by iPhone View Post
    Try this: Goto Settings> Advance> Remote Login and click the enable box. Now leave the Radio at that point without making any other changes. Now use Putty to attempt a login. I know this shouldn't matter, but when I have trouble logging in, this always works for me.
    I will try it when I get home tonight. I just VNCed in and tried it again, but alas still does not work.

    Quote Originally Posted by Matt Wise View Post
    Did the screen pop up with a "SSH is now enabled, here's your user and password" screen? (paraphrased) If not, SSH didnt enable properly -- in that case, try rebooting and re-enabling.
    It did pop up with that, but for whatever reason its not letting me in. Perhaps it knows that I have no reason to be let in I would chalk it up to user error, but I can ssh into my ipod touch as well as a chumby that I sold
    Last edited by vw195; 2009-10-12 at 07:27.

  6. #6
    Member
    Join Date
    Oct 2009
    Location
    Austria
    Posts
    88
    I had similar problems to another server some time ago - then I realized that there are different versions of ssh available and my old putty-version just supported version 1
    don't know what the SB-radio supports and if this is really your problem but it might be a hint :-)

  7. #7
    Senior Member bluegaspode's Avatar
    Join Date
    Jul 2009
    Location
    Berlin, Germany
    Posts
    3,229
    Quote Originally Posted by Matt Wise View Post
    Did the screen pop up with a "SSH is now enabled, here's your user and password" screen? (paraphrased) If not, SSH didnt enable properly -- in that case, try rebooting and re-enabling.
    I had this problem as well some time ago (no popup - no connection).
    Rebooting helped as described.
    Did you know: SqueezePlayer will stream all your music to your Android device. Take your music everywhere!
    Remote Control + Streaming to your iPad? Squeezebox + iPad = SqueezePad
    Want to see a Weather Forecast on your Radio/Touch/Controller ? => why not try my Weather Forecast Applet
    Want to use the Headphones with your Controller ? => why not try my Headphone Switcher Applet

  8. #8
    Senior Member
    Join Date
    Sep 2009
    Posts
    177
    Quote Originally Posted by bluegaspode View Post
    I had this problem as well some time ago (no popup - no connection).
    Rebooting helped as described.
    I had to reboot to get it to work but successfully got in the second time. Thanks all!

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •