Home of the Squeezebox™ & Transporter® network music players.
Results 1 to 10 of 12

Hybrid View

  1. #1
    Senior Member
    Join Date
    Nov 2005
    Posts
    274

    Problems with Ubuntu 5.10 "Breezy Badger"

    I decided today to update my outdated Slimserver to SqueezeboxCenter 7.4 on my little MP3 server which runs Ubuntu 5.10 "Breezy Badger", but unfortunately, this venture failed completely (Server restarts over and over again).

    So I decided to install SqueezeCenter 7.3 instead, which kinda works, but I can't configure the server since the web interface doesn't load when I try to access it from my desktop PC. There is no error message and it displays something like "SqueezeCenter is loading", but nothing happens after this.

    I can't find any hint in the logfiles and the server itself is running. Indeed for some reason the scanner found all of my MP3s and playlists, so I'm like 90% there, but still I'd like to configure some thing in the web interface.

    Maxbe related: I can't get the "ShutdownServer" script to run by simply copying it the Plugins folder (and setting user rights) as it worked for SlimServer. It is not shown at all under "Extras".

    BTW: where is the configuration stored? For SlimServer it was /etc/slimserver/slimserver.pref, but I can't find any file like this for the SqueezeCenter.

  2. #2
    Senior Member pablolie's Avatar
    Join Date
    Feb 2006
    Location
    bay area, california.
    Posts
    1,138
    configuration files re now in var/lib...

    why do you want to stay with such an old Ubuntu version?
    ...pablo
    Server: Virtual Machine (on VMware Workstation 14 Pro) running Ubuntu 18.04 + LMS 7.9.1
    System: SB Touch -optical-> Benchmark DAC2HGC -AnalysisPlus Oval Copper XLR-> NAD M22 Power Amp -AnalysisPlus Black Mesh Oval-> KEF Reference 1
    Other Rooms: 2x SB Boom; 1x SB Radio; 1x SB Classic-> NAD D7050 -> Totem DreamCatcher + Velodyne Minivee Sub
    Computer audio: workstation -USB-> audioengine D1 -> Grado RS1/Shure 1540

  3. #3
    Senior Member
    Join Date
    Nov 2005
    Posts
    274
    Ok, never mind. I'm updating to Ubuntu 9.04 right now and hope that 7.4 will run there.

  4. #4
    Senior Member pfarrell's Avatar
    Join Date
    Apr 2005
    Location
    Wayne, PA
    Posts
    4,251

    Problems with Ubuntu 5.10 "Breezy Badger"

    0xdeadbeef wrote:
    > Ok, never mind. I'm updating to Ubuntu 9.04 right now and hope that 7.4
    > will run there.


    It should, especially since you are willing to nuke your old installation.

    The transition from 7.3 to 7.4 on Debian/Ubuntu was a bit rough in the
    beta days, but I would expect a clean install to work directly.

    Make sure to verify that your music directories are accessible by the
    user/group that the SBS runs as.


    --
    Pat Farrell
    http://www.pfarrell.com/


  5. #5
    Senior Member
    Join Date
    Nov 2005
    Posts
    274
    It kinda worked flawlessly apart from the very first scan which kinda failed for some reason and reported only 10% of my albums. An update scan fixed this, but still most of the covers were missing.
    The third scan (delete db, complete rebuild) now seems to have worked correctly.

    Guess this will be the last time that I install Linux though. It's cool that it's free and all, but it completely sucks that you can't simply update an application without risking to destroy or being forced to update the whole system just for one application. It's also unbelievable that the repositories are deleted so soon.

  6. #6
    Senior Member pfarrell's Avatar
    Join Date
    Apr 2005
    Location
    Wayne, PA
    Posts
    4,251

    Problems with Ubuntu 5.10 "Breezy Badger"

    0xdeadbeef wrote:
    > Guess this will be the last time that I install Linux though. It's cool
    > that it's free and all, but it completely sucks that you can't simply
    > update an application without risking to destroy or being forced to
    > update the whole system just for one application. It's also unbelievable
    > that the repositories are deleted so soon.


    Which repositories do you mean, the Ubuntu ones? or the Logitech ones
    for your ancient Ubuntu 5.10?

    In either case, I'm not sure I agree with your complaint. If you want
    long term support, you should be running Debian, not Ubuntu. For 99% of
    the time, they are the same, but Debian is all about stability and long
    term support, whereas Ubuntu is about a new version every six months and
    supporting the latest and greatest stuff.

    Your 5.10 is ancient, specifically four and a half years old.

    When I was doing serious Windows development, I would schedule time to
    do a format c: and reinstall from the CD every six months or so.

    The SqueezeBoxServer 7.4 was one of the more difficult ones, I've been
    running it (under various names) for five or so years. Usually only the
    integer number changes are this painful.

    wasn't there a bad PGP key with the values 0xdeadbeef a decade or so ago?


    --
    Pat Farrell
    http://www.pfarrell.com/


  7. #7
    Senior Member
    Join Date
    Nov 2005
    Posts
    274
    Quote Originally Posted by pfarrell View Post
    0xdeadbeef wrote:[color=blue]
    Which repositories do you mean, the Ubuntu ones? or the Logitech ones
    for your ancient Ubuntu 5.10?
    The Ubuntu ones.

    Quote Originally Posted by pfarrell View Post
    In either case, I'm not sure I agree with your complaint. If you want
    long term support, you should be running Debian, not Ubuntu. For 99% of
    the time, they are the same, but Debian is all about stability and long
    term support, whereas Ubuntu is about a new version every six months and
    supporting the latest and greatest stuff.
    It wouldn't have changed anything, would it? Still the new binary package would not run on an "ancient" Debian.

    Quote Originally Posted by pfarrell View Post
    Your 5.10 is ancient, specifically four and a half years old.
    Well, "ancient" is a relative term. If I would have decided to install XP when I setup my MP3 server, I wouldn't have been forced to reinstall a new OS to update an application.

    Quote Originally Posted by pfarrell View Post
    When I was doing serious Windows development, I would schedule time to
    do a format c: and reinstall from the CD every six months or so.
    I only reinstalled XP twice since I bought it several years ago and both times it was because of a complete hardware change.

    Quote Originally Posted by pfarrell View Post
    wasn't there a bad PGP key with the values 0xdeadbeef a decade or so ago?
    There aren't to much words could can create with a 32bit hex number and that still make sense.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •