Home of the Squeezebox™ & Transporter® network music players.
Results 1 to 4 of 4
  1. #1
    Senior Member
    Join Date
    Aug 2005
    Posts
    619

    Can't connect to database

    I am running Slim on OpenSuse 10.3. Or whatever it is called now.
    7.4 is a disaster so far.
    1) The signatures for the packages are not published to the usual key servers (e.g., pgp.mit.edu), so my package manager (smart) refused to install it.
    2) I tried to download it manually in Linus with firefox 3.5 and Konqueror. Both failed to work. The radio buttons for the linux flavor did not work in Konqueror. Firefox go9t me to the signup page, but the download never started.
    3) I downloaded the rpms successfully on my Mac.
    4) I uninstalled squeezecenter, and installed squeexeboxserver.
    5) When I start it, I get the following:
    Your locale was detected as C, you may have problems with non-Latin filenames. Consider changing your LANG variable to the correct locale, i.e. en_US.utf8
    Use of uninitialized value in subroutine entry at /usr/share/squeezeboxserver/CPAN/YAML/Syck.pm line 75.
    [09-09-29 16:32:10.0868] main::init (320) Starting Squeezebox Server (v7.4.0, r28672, Mon Sep 28 17:49:55 PDT 2009) perl 5.008008

    6) BUT, the log gives me a fatal error:
    [09-09-29 16:32:10.0870] main::init (320) Starting Squeezebox Server (v7.4.0, r28672, Mon Sep 28 17:49:55 PDT 2009) perl 5.008008
    [09-09-29 16:32:42.5163] Slim::Utils::MySQLHelper::createSystemTables (500) FATAL: Couldn't connect to database: [Can't connect to local MySQL server through socket '/var/lib/squeezeboxserver/cache/squeezebox-mysql.sock' (2)]

    So how do I fix this?
    I presume I still go to localhost:9000 to con figure this, but it does not answer.

  2. #2
    Senior Member
    Join Date
    Sep 2006
    Location
    Boston
    Posts
    135

    Similar error here as well.

    My squeezecenter must have upgraded itself over night (actually, my script did that). After realizing the service name changed from "squeezecenter" to "squeezeboxserver," I checked the logs and found the following:

    This is Fedora 9, 32bit - wondering if this is caused by an old version of PERL (v5.8.8)?

    [09-09-29 05:02:47.5635] main::init (320) Starting Squeezebox Server (v7.4.0, r28672, Mon Sep 28 17:49:55 PDT 2009) perl 5.008008
    [09-09-29 05:03:23.0142] Slim::Utils::MySQLHelper::createSystemTables (500) FATAL: Couldn't connect to database: [Can't connect to local MySQL server through socket '/var/lib/squeezeboxserver/cache/squeezebox-mysql.sock' (2)]
    [09-09-29 17:21:44.4468] main::init (320) Starting Squeezebox Server (v7.4.0, r28672, Mon Sep 28 17:49:55 PDT 2009) perl 5.008008
    [09-09-29 17:22:17.8501] Slim::Utils::MySQLHelper::createSystemTables (500) FATAL: Couldn't connect to database: [Can't connect to local MySQL server through socket '/var/lib/squeezeboxserver/cache/squeezebox-mysql.sock' (2)]
    [09-09-29 17:45:21.3725] main::init (320) Starting Squeezebox Server (v7.4.0, r28672, Mon Sep 28 17:49:55 PDT 2009) perl 5.008008
    [09-09-29 17:45:53.5032] Slim::Utils::MySQLHelper::createSystemTables (500) FATAL: Couldn't connect to database: [Can't connect to local MySQL server through socket '/var/lib/squeezeboxserver/cache/squeezebox-mysql.sock' (2)]

  3. #3
    Senior Member
    Join Date
    Aug 2005
    Posts
    619

    local vs installed?

    I am wondering...

    I recall that in the last version, I had done something on one of the setup pages to elect to use the mysql installed on my machine rather than the mysql lite that was included with Slimserver. Could this be screwing us up?

  4. #4
    Senior Member
    Join Date
    Aug 2005
    Posts
    619

    Fixed it!

    Try rebooting. The old server is using the ports.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •