Home of the Squeezebox™ & Transporter® network music players.
Results 1 to 7 of 7
  1. #1
    Junior Member
    Join Date
    Apr 2007
    Posts
    16

    Enabling WOL across multiple reboots

    Hi
    Hope someone can help me out here,I have Vortexbox(Fedora)and I am trying to get WOL up and running,I can enable it and it works but after the next reboot it turns itself off again.
    From what I understand(hmmm very little as I have just started playing with linux)is that I need to install a script in /etc/rc.d directory.Question is what script should I add,found one example:

    #!/bin/sh
    # file: /sbin/wolifconfig
    eth0 upethtool -s eth0 wol g


    would this work if yes then please explain to me how I
    can install it in the mentioned directory,remembering
    that you are explaining this to someone with virtualy
    no linux knowage.
    Cheers

    ps.also have posted this in the Vortexbox forums
    Last edited by Delennyk; 2009-09-22 at 09:55.

  2. #2
    Senior Member agillis's Avatar
    Join Date
    Nov 2008
    Posts
    859
    Many computers (such as the VortexBox appliance) have WOL enabled by default in the BIOS. You may be able to go into your BIOS and enable WOL. Try hitting F2 or Delete on boot up.

    If that doesn't work this command will add it to the startup file.

    echo "eth0 upethtool -s eth0 wol g" >> /etc/rc.local
    rip, tag, get cover artů All you do is insert the CD!
    http://vortexbox.org

    agillis
    Lead Developer VortexBox

  3. #3
    Junior Member
    Join Date
    Apr 2007
    Posts
    16
    Hi Andrew thanks for the reply

    I feel as though I am bashing my head up against a brickwall sometimes!!!Confused

    Yep wol is supported as i can in ethtool change from a d to a g so that it is enabled and it works on the next reboot but then reverts back to a d again!!!

    Started up putty loged in as root then put your command in but nothing has changed,in ethtool it still shows up as d.

    Presume this command has to be installed somewhere elseů.but where!! and can I just copy and paste your command into putty ?

    sorry about this as it seems pretty simpleů.but not!

  4. #4
    Senior Member
    Join Date
    Feb 2008
    Location
    Nij Beets, The Netherlands
    Posts
    480
    I'm also new to Linux and I have struggled with this some time. I think there's a bug in Fedora 11 that makes the extra line in rc.local necessary.

    If I understand it well, agilles' line is supposed to add a line to rc.local. I've added it to the end of rc.local by hand with nano:

    nano /etc/rc.local
    add at the end the line:
    ethtool -s eth0 wol g
    save the file and restart.

    I also noticed that you have to wait a bit till the command is processed after restarting. Here ethtool eth0 states that wol is d when I do this immediately after restarting. After waiting a few seconds, it says g.

    Hope this helps.

    Teus
    Last edited by Teus de Jong; 2009-09-23 at 02:42.

  5. #5
    Senior Member bernt's Avatar
    Join Date
    Aug 2005
    Location
    Sweden, Kalmar
    Posts
    795
    I upgraded Ubuntu 8.04 LTS to 8.10 and then to 9.04. Somewhere I lost WoL.

    After some googling I found various solutions but the only one that worked for me was to change the NETDOWN value in /etc/init.d/halt from yes to no.

    /etc/init.d/halt
    NETDOWN=no

    Kind Regards
    /Bernt
    SB Touch optical to Hegel H90, Speakers Larsen 4.2
    Spare SB3
    AirPlay Bridge to Audio Pro A10
    Squeezelite-x connected to home LMS with Neorouter.
    SB Radio
    ReadyNAS 202
    iPeng

  6. #6
    Junior Member
    Join Date
    Apr 2007
    Posts
    16
    Teus de Jong Thank you your instructions did the trick,rebooted a number of times and it works.
    Cheers

  7. #7
    Senior Member gharris999's Avatar
    Join Date
    Apr 2005
    Location
    Santa Fe, NM
    Posts
    3,509
    Another approach to this in Fedora:

    If you want to have your server's eth0 configured to a static ip address, then it's preferable to get rid of the 'NetworkManager' service and use 'network' instead:

    # chkconfig NetworkManager off

    # chkconfig network on

    Then look at your /etc/sysconfig/networking/devices/ifcfg-eth0 file. Mine looks like this:

    Code:
    # Intel Corporation 82541GI Gigabit Ethernet Controller
    DEVICE=eth0
    BOOTPROTO=none
    BROADCAST=192.168.0.255
    DNS1=208.67.222.222
    DNS2=208.67.220.220
    DNS3=192.168.0.1
    GATEWAY=192.168.0.1
    HWADDR=aa:bb:cc:dd:ee:ff
    IPADDR=192.168.0.198
    NETMASK=255.255.255.0
    ONBOOT=yes
    TYPE=Ethernet
    USERCTL=yes
    IPV6INIT=no
    NM_CONTROLLED=no
    PEERDNS=yes
    ETHTOOL_OPTS="wol g"
    That last entry (ETHTOOL_OPTS="wol g") seems to do the trick in terms of seeing to it that WOL is always enabled. If you need to build a ifcfg-eth0 file from scratch, you can get your nic's HWADDR from either # ifconfig or from # cat /etc/udev/rules.d/70-persistent-net.rules.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •