Home of the Squeezebox™ & Transporter® network music players.
Results 1 to 2 of 2

Hybrid View

  1. #1
    Eric Gauthier
    Guest

    crash when wiping cache

    Kevin,

    Thanks, that fixed the crash in the player settings.

    Still getting the following crash in clientGet when attempting to Wipe the
    cache:

    Can't call method "id" without a package or object reference at
    /usr/local/slimserver.nightly/Slim/Utils/Prefs.pm line 460.

    -Eric

    >-----Original Message-----
    >From: discuss-bounces (AT) lists (DOT) slimdevices.com
    >[mailto:discuss-bounces (AT) lists (DOT) slimdevices.com] On Behalf Of kdf
    >Sent: Sunday, May 16, 2004 4:50 PM
    >To: Slim Devices Discussion
    >Subject: [slim] crash when wiping cache
    >
    >
    >Quoting Eric Gauthier <EGauthier (AT) comcast (DOT) net>:
    >
    >> Kdf,
    >>
    >> Thanks for the quick response. However, the client is connected.
    >> Just to make sure, I powered the Squeezebox on via the web

    >interface.
    >> Then "wipe cache" and same crash.
    >>
    >> A Rescan does work without a problem. I have also tried to disable
    >> caching, delete the cache file, and re-enable it, but no effect.
    >>
    >> I have now also noticed something else strange when trying to debug
    >> this. I just added a slimp3 via a wireless bridge to my network
    >> (other 2 players are squeezebox and softsqueeze). When I try and go
    >> to the Player settings of the SliMP3 (settings for other

    >players work
    >> fine) I get a different crash with the following in the error log:
    >>
    >> Can't call method "HASH(0x9077d80)" on unblessed reference at
    >> /usr/local/slimserver/Slim/Web/Setup.pm line 135.

    >
    >I see what is causing this one. My fault, I pasted badly
    >I'm committing a fix in a few minutes. I don't yet see how
    >this relates to your other crash but we'll see. If you arent'
    >using the cvs update method, and don't want to wait for the
    >next nightly, here is the fix:
    >
    >Slim/Web/Setup.pm lines 135, change to:
    >$pageref->{'Prefs'}{'maxBitrate'}{'options'}{'0'} =
    >string('SETUP_MP3BITRATE_DESC');
    >
    >instead of:
    >$pageref->$pageref->{'Prefs'}{'maxBitrate'}{'options'}{'0'} =
    >string('SETUP_MP3BITRATE_DESC');
    >
    >ignore the line breaks here because it should be all in one line.
    >
    >-kdf
    >
    >
    >
    >> I have "forgotten" this player via

    >home.html?player=MAC&forget=MAC but
    >> when it is rediscovered, the same crash.
    >>
    >> Any ideas?
    >>
    >> -Eric
    >>
    >> >-----Original Message-----
    >> >From: discuss-bounces (AT) lists (DOT) slimdevices.com
    >> >[mailto:discuss-bounces (AT) lists (DOT) slimdevices.com] On Behalf Of kdf
    >> >Sent: Sunday, May 16, 2004 8:29 AM
    >> >To: Slim Devices Discussion
    >> >Subject: [slim] crash when wiping cache
    >> >
    >> >
    >> >wipe cache calls the command to wipe the cache memory and
    >> >start a rescan.
    >> >execution of a command contains a client tag, so you must have
    >> >a client connected in order for this to work. no client, no
    >> >id...and boom.
    >> >
    >> >Give it time after startup for your client to be detected,
    >> >then it should work fine. This is a known bug:
    >> >
    >> >http://bugs.slimdevices.com/show_bug.cgi?id=300
    >> >
    >> >kdf
    >> >
    >> >Quoting Eric Gauthier <EGauthier (AT) comcast (DOT) net>:
    >> >
    >> >> I upgraded from 5.1.5 to the nightlies on 14-May to get rid of the
    >> >> memory leak issue on Linux. I don't know if this problem

    >existed in
    >> >> 5.1.5 or not.
    >> >>
    >> >> After starting the server, go to the web page Server
    >> >> Settings->Advanced Server Settings->Performance and select "Wipe
    >> >> Cache" and the server crashes.
    >> >>
    >> >>
    >> >> Error in log file is:
    >> >>
    >> >> Can't call method "id" without a package or object reference at
    >> >> /usr/local/slimserver/Slim/Utils/Prefs.pm line 460.
    >> >>
    >> >> I just upgraded to the latest nightly and it still happens.
    >> >>
    >> >> -Eric
    >> >>
    >> >
    >> >
    >> >
    >> >

  2. #2
    NOT a Slim Devices Employee kdf's Avatar
    Join Date
    Apr 2005
    Posts
    9,493

    crash when wiping cache

    I'm at a loss on that one. I can't reproduce it with my setup. the only way I
    have ever seen that message is when trying a command after startup when the
    clients haven't been properly discovered and acknowleged by the server.

    debug swtiches you could try, maybe d_slimproto (if this is squeezebox) and
    d_command.

    as an aside, I'm really not sure why the $client object is needed for calling a
    wipe of the cache.

    -kdf

    Quoting Eric Gauthier <EGauthier (AT) comcast (DOT) net>:

    > Kevin,
    >
    > Thanks, that fixed the crash in the player settings.
    >
    > Still getting the following crash in clientGet when attempting to Wipe the
    > cache:
    >
    > Can't call method "id" without a package or object reference at
    > /usr/local/slimserver.nightly/Slim/Utils/Prefs.pm line 460.
    >
    > -Eric
    >
    > >-----Original Message-----
    > >From: discuss-bounces (AT) lists (DOT) slimdevices.com
    > >[mailto:discuss-bounces (AT) lists (DOT) slimdevices.com] On Behalf Of kdf
    > >Sent: Sunday, May 16, 2004 4:50 PM
    > >To: Slim Devices Discussion
    > >Subject: [slim] crash when wiping cache
    > >
    > >
    > >Quoting Eric Gauthier <EGauthier (AT) comcast (DOT) net>:
    > >
    > >> Kdf,
    > >>
    > >> Thanks for the quick response. However, the client is connected.
    > >> Just to make sure, I powered the Squeezebox on via the web

    > >interface.
    > >> Then "wipe cache" and same crash.
    > >>
    > >> A Rescan does work without a problem. I have also tried to disable
    > >> caching, delete the cache file, and re-enable it, but no effect.
    > >>
    > >> I have now also noticed something else strange when trying to debug
    > >> this. I just added a slimp3 via a wireless bridge to my network
    > >> (other 2 players are squeezebox and softsqueeze). When I try and go
    > >> to the Player settings of the SliMP3 (settings for other

    > >players work
    > >> fine) I get a different crash with the following in the error log:
    > >>
    > >> Can't call method "HASH(0x9077d80)" on unblessed reference at
    > >> /usr/local/slimserver/Slim/Web/Setup.pm line 135.

    > >
    > >I see what is causing this one. My fault, I pasted badly
    > >I'm committing a fix in a few minutes. I don't yet see how
    > >this relates to your other crash but we'll see. If you arent'
    > >using the cvs update method, and don't want to wait for the
    > >next nightly, here is the fix:
    > >
    > >Slim/Web/Setup.pm lines 135, change to:
    > >$pageref->{'Prefs'}{'maxBitrate'}{'options'}{'0'} =
    > >string('SETUP_MP3BITRATE_DESC');
    > >
    > >instead of:
    > >$pageref->$pageref->{'Prefs'}{'maxBitrate'}{'options'}{'0'} =
    > >string('SETUP_MP3BITRATE_DESC');
    > >
    > >ignore the line breaks here because it should be all in one line.
    > >
    > >-kdf
    > >
    > >
    > >
    > >> I have "forgotten" this player via

    > >home.html?player=MAC&forget=MAC but
    > >> when it is rediscovered, the same crash.
    > >>
    > >> Any ideas?
    > >>
    > >> -Eric
    > >>
    > >> >-----Original Message-----
    > >> >From: discuss-bounces (AT) lists (DOT) slimdevices.com
    > >> >[mailto:discuss-bounces (AT) lists (DOT) slimdevices.com] On Behalf Of kdf
    > >> >Sent: Sunday, May 16, 2004 8:29 AM
    > >> >To: Slim Devices Discussion
    > >> >Subject: [slim] crash when wiping cache
    > >> >
    > >> >
    > >> >wipe cache calls the command to wipe the cache memory and
    > >> >start a rescan.
    > >> >execution of a command contains a client tag, so you must have
    > >> >a client connected in order for this to work. no client, no
    > >> >id...and boom.
    > >> >
    > >> >Give it time after startup for your client to be detected,
    > >> >then it should work fine. This is a known bug:
    > >> >
    > >> >http://bugs.slimdevices.com/show_bug.cgi?id=300
    > >> >
    > >> >kdf
    > >> >
    > >> >Quoting Eric Gauthier <EGauthier (AT) comcast (DOT) net>:
    > >> >
    > >> >> I upgraded from 5.1.5 to the nightlies on 14-May to get rid of the
    > >> >> memory leak issue on Linux. I don't know if this problem

    > >existed in
    > >> >> 5.1.5 or not.
    > >> >>
    > >> >> After starting the server, go to the web page Server
    > >> >> Settings->Advanced Server Settings->Performance and select "Wipe
    > >> >> Cache" and the server crashes.
    > >> >>
    > >> >>
    > >> >> Error in log file is:
    > >> >>
    > >> >> Can't call method "id" without a package or object reference at
    > >> >> /usr/local/slimserver/Slim/Utils/Prefs.pm line 460.
    > >> >>
    > >> >> I just upgraded to the latest nightly and it still happens.
    > >> >>
    > >> >> -Eric
    > >> >>
    > >> >
    > >> >
    > >> >
    > >> >

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •