Home of the Squeezebox™ & Transporter® network music players.
Page 77 of 83 FirstFirst ... 27677576777879 ... LastLast
Results 761 to 770 of 821
  1. #761
    Senior Member
    Join Date
    Oct 2014
    Location
    Pittsburgh PA
    Posts
    323
    Quote Originally Posted by Giunti View Post
    However, on testing a bit more closely I noticed the following:
    When I click "Dynamic Equalizer" in the DenonAvpAvrControl settings in Squeezer there's a kind of app crash and for a second it says the connection has been cut. I've repeated this several times, each time with the same result.
    I can't recreate the Squeezer crash and the log doesn't show anything unusual. I have worked closely with the Squeezer developers and they are very responsive regarding bug reports. In fact, they fixed a couple of crash problems that I reported recently. The first thing I would do is check which version of Squeezer you are running by selecting "About" from the main menu (upper right corner). If it is not 2.2.8-beta-3, go to the Google Play Store, sign up for their beta program and install the latest beta version (which should be 2.2.8-beta-3). There are at least two fixes in the beta release regarding crashes in menu processing. If the problem persists after that, I will give you guidance on reporting it on Squeezer's Github page.
    Sam

  2. #762
    Junior Member Giunti's Avatar
    Join Date
    Oct 2011
    Location
    Austria
    Posts
    27
    Quote Originally Posted by SamY View Post
    I can't recreate the Squeezer crash and the log doesn't show anything unusual. I have worked closely with the Squeezer developers and they are very responsive regarding bug reports. In fact, they fixed a couple of crash problems that I reported recently. The first thing I would do is check which version of Squeezer you are running by selecting "About" from the main menu (upper right corner). If it is not 2.2.8-beta-3, go to the Google Play Store, sign up for their beta program and install the latest beta version (which should be 2.2.8-beta-3). There are at least two fixes in the beta release regarding crashes in menu processing. If the problem persists after that, I will give you guidance on reporting it on Squeezer's Github page.
    OK, I'm now part of the beta program and running 2.2.8-beta-3. BTW, it wasn't the entire app that crashed but it seemed to lose its connection to the AVR when I clicked on "Dynamic Equalizer" within the DenonAvpAvrControl menu. For a split second it displayed the "connection lost" window in Squeezer but kept on working. Access to the equalizer, however, was not possible. This seems to be an erratic error: When I tried out some changes in the Denon UI settings the "Dynamic Equalizer" was miraculously available again. I'll just wait and see how things develop with new versions of the software involved coming out sooner or later.

  3. #763
    Senior Member
    Join Date
    Oct 2014
    Location
    Pittsburgh PA
    Posts
    323

    Version 4.4 is now available

    Version 4.4 is now published, with the following changes (from the wiki pages).

    1. Add the ability in the client Quick Select menu to save the current AVR audio settings to the Quick Select command defined for the active player.

    2. Add support for a syntax change in the PSRSTR command introduced in the newer (X-series) AVR's.

    3. Prevent the player from setting the absolute volume to 100% when running with volume fixed at 100% as a workaround for a bug in some implementations of the player firmware/software.


    For those of you who helped test the new Quick Select update function (#1), you will notice the addition of a popup message confirming that the audio settings have been saved. Enjoy!
    Sam

  4. #764
    Senior Member Aesculus's Avatar
    Join Date
    Jan 2008
    Posts
    443
    I want to personally thank Sam for all he did on this release. This was all his and I really like the new Quick Select save feature. My only input was commenting it needed some sort of app indicator to confirm the action, although you could see it on the Denon if you were watching. He got on it and found a solution that is really cool.

    One word of caution for the one other person in the world besides me that is using a iPad with iPeng and the plugin: You won't see the message on that unique combination and we could not find a work around. It does work fine with iPhones though.
    Chris

  5. #765
    Junior Member
    Join Date
    Apr 2021
    Location
    Béthune, France
    Posts
    16
    Quote Originally Posted by SamY View Post
    I'd like to get an idea of how many users of this plugin there are out there. I know that, in my case, I was using it for more than a year before discovering this forum so it won't be accurate. But, if you're seeing this post, just reply and provide a short description of your setup if you can. Here's a template to use based on my system:

    • AVR(s): Denon AVR-3311ci
    • LMS Platform: RPi B+
    • OS: Debian Jessie
    • Client(s) in use: Squeezer, Squeeze Ctrl
    • Number of players using the plugin: 2


    Any additional info is welcomed, along with comments and questions.

    Thanks.
    Hello to all.

    First I want to thanks authors and contributors of this plugin.

    My setup:
    [*]AVR(s): Denon AVR-2311, with Rpi and ser2net to bridge the serial port to the network.
    [*]LMS Platform: PC
    [*]OS: Windows Server 2012
    [*]Client(s) in use: Squeezer, Material Skin
    [*]Number of players using the plugin: 1 (Pcp)


    I confirm Peterw setting as ser2net has to be configured with raw protocol instead of telnet. I had to make some change in the code in order to use a different port to reach my ser2net Rpi. (It would be great for users like me with old AVR, letting us chossing the port in conf page..) . Player is based on a Rpi with PiCorePlayer and is connected to AVR with RCA. My set up works fine, but as I said, I have 2 Rpis (1 player on Pcp and another with raspbian/ser2net to talk to the AVR) and my nexty goal is to use ser2net on the Pcp Rpi.
    For this I build thje extension and added it. Extension is loaded correctly, ser2net is OK (conf file loaded).. But nothing works. Logs of the plugin:

    init is ok :
    Code:
    [22-01-16 14:46:16.9052] Plugins::DenonAvpControl::Plugin::clearCallback (334) *** DenonAvpControl:Clearing command callback
    [22-01-16 14:46:18.7405] Plugins::DenonAvpControl::Plugin::newPlayerCheck (214) *** DenonAvpControl: PcpX-TEST is: Slim::Player::SqueezePlay=ARRAY(0xa96f244)
    [22-01-16 14:46:18.7413] Plugins::DenonAvpControl::Plugin::newPlayerCheck (240) *** DenonAvpControl: Plugin Enabled: 
    [22-01-16 14:46:18.7420] Plugins::DenonAvpControl::Plugin::newPlayerCheck (241) *** DenonAvpControl: Quick Select: 1
    [22-01-16 14:46:18.7426] Plugins::DenonAvpControl::Plugin::newPlayerCheck (242) *** DenonAvpControl: zone: 0
    [22-01-16 14:46:18.7432] Plugins::DenonAvpControl::Plugin::newPlayerCheck (243) *** DenonAvpControl: speakers: 0
    [22-01-16 14:46:18.7438] Plugins::DenonAvpControl::Plugin::newPlayerCheck (244) *** DenonAvpControl: IP Address: HTTP://192.168.1.76:11111
    [22-01-16 14:46:18.7445] Plugins::DenonAvpControl::Plugin::newPlayerCheck (249) *** DenonAvpControl: Player output level is: Fixed
    [22-01-16 14:46:18.7454] Plugins::DenonAvpControl::Plugin::newPlayerCheck (250) *** DenonAvpControl: Player model is: SqueezeLite
    But:

    Code:
    [22-01-16 14:46:18.8644] Plugins::DenonAvpControl::Plugin::clearCallback (334) *** DenonAvpControl:Clearing command callback
    [22-01-16 14:46:46.9680] Plugins::DenonAvpControl::Plugin::commandCallback (1655) *** DenonAvpControl: commandCallback() p0: power
    [22-01-16 14:46:46.9688] Plugins::DenonAvpControl::Plugin::commandCallback (1656) *** DenonAvpControl: commandCallback() p1: 
    [22-01-16 14:46:46.9696] Plugins::DenonAvpControl::Plugin::commandCallback (1677) *** DenonAvpControl: commandCallback() Player: PcpX-TEST
    [22-01-16 14:46:46.9704] Plugins::DenonAvpControl::Plugin::commandCallback (1685) *** DenonAvpControl: power request1: Slim::Control::Request=HASH(0xd33424c) 
    [22-01-16 14:46:46.9711] Plugins::DenonAvpControl::Plugin::commandCallback (1691) *** DenonAvpControl: commandCallback() Power: 0 
    [22-01-16 14:46:46.9780] Plugins::DenonAvpControl::Plugin::prefSetCallback (1609) *** DenonAvpControl: prefSetCallback() Player PcpX-TEST is powered off 
    [22-01-16 14:46:48.9727] Plugins::DenonAvpControl::Plugin::handlePowerOff (2041) *** DenonAvpControl: handling Power OFF 
    [22-01-16 14:46:48.9735] Plugins::DenonAvpControl::DenonAvpComms::SendNetAvpStandBy (535) Calling writemsg for Standby command
    [22-01-16 14:46:48.9767] Plugins::DenonAvpControl::DenonAvpComms::writemsg (616) Sent AVP command request: ZMOFF
    
    [22-01-16 14:46:48.9786] Plugins::DenonAvpControl::DenonAvpComms::_read (737) read routine called
    [22-01-16 14:46:49.1044] Plugins::DenonAvpControl::DenonAvpComms::_error (627) error routine called
    [22-01-16 14:46:49.1051] Plugins::DenonAvpControl::DenonAvpComms::_error (637) error connecting to AVR: error=End of file, request=ZMOFF
    
    [22-01-16 14:47:04.5466] Plugins::DenonAvpControl::Plugin::commandCallback (1655) *** DenonAvpControl: commandCallback() p0: power
    [22-01-16 14:47:04.5472] Plugins::DenonAvpControl::Plugin::commandCallback (1656) *** DenonAvpControl: commandCallback() p1: 
    [22-01-16 14:47:04.5478] Plugins::DenonAvpControl::Plugin::commandCallback (1677) *** DenonAvpControl: commandCallback() Player: PcpX-TEST
    [22-01-16 14:47:04.5484] Plugins::DenonAvpControl::Plugin::commandCallback (1685) *** DenonAvpControl: power request1: Slim::Control::Request=HASH(0xad23044) 
    [22-01-16 14:47:04.5490] Plugins::DenonAvpControl::Plugin::commandCallback (1691) *** DenonAvpControl: commandCallback() Power: 1 
    [22-01-16 14:47:04.5496] Plugins::DenonAvpControl::Plugin::commandCallback (1719) *** DenonAvpControl: commandCallback() Player output level is: Fixed 
    [22-01-16 14:47:06.5504] Plugins::DenonAvpControl::Plugin::handlePowerStatus (1992) *** DenonAvpControl: handling Power ON Status 
    [22-01-16 14:47:06.5511] Plugins::DenonAvpControl::DenonAvpComms::SendNetAvpPowerStatus (493) Calling query for zone state
    [22-01-16 14:47:06.5541] Plugins::DenonAvpControl::DenonAvpComms::writemsg (616) Sent AVP command request: ZM?
    
    [22-01-16 14:47:06.5558] Plugins::DenonAvpControl::DenonAvpComms::_read (737) read routine called
    [22-01-16 14:47:06.6816] Plugins::DenonAvpControl::DenonAvpComms::_error (627) error routine called
    [22-01-16 14:47:06.6822] Plugins::DenonAvpControl::DenonAvpComms::_error (637) error connecting to AVR: error=End of file, request=ZM?
    So, I don't think the plugin is in fault. I think issues are in the PiCorePlayer side, based on TinyCore linux. Does anyone has already use a Pcp with ser2net ?
    Last edited by oliverbg1; 2022-01-25 at 04:41.

  6. #766
    Senior Member
    Join Date
    Oct 2014
    Location
    Pittsburgh PA
    Posts
    323
    Quote Originally Posted by oliverbg1 View Post
    Hello to all.

    First I want to thanks authors and contributors of this plugin.

    My setup:
    [*]AVR(s): Denon AVR-2311, with Rpi and ser2net to bridge the serial port to the network.
    [*]LMS Platform: PC
    [*]OS: Windows Server 2012
    [*]Client(s) in use: Squeezer, Material Skin
    [*]Number of players using the plugin: 1 (Pcp)


    I confirm Peterw setting as ser2net has to be configured with raw protocol instead of telnet. I had to make some change in the code in order to use a different port to reach my ser2net Rpi. (It would be great for users like me with old AVR, letting us chossing the port in conf page..) . Player is based on a Rpi with PiCorePlayer and is connected to AVR with RCA. My set up works fine, but as I said, I have 2 Rpis (1 player on Pcp and another with raspbian/ser2net to talk to the AVR) and my nexty goal is to use ser2net on the Pcp Rpi.
    For this I build thje extension and added it. Extension is loaded correctly, ser2net is OK (conf file loaded).. But nothing works.

    So, I don't think the plugin is in fault. I think issues are in the PiCorePlayer side, based on TinyCore linux. Does anyone has already use a Pcp with ser2net ?
    Hello, Oliver. I like the idea of being able to override the default tcp port number of 23 for special situations like yours. I have coded a change to support specifying the port number as part of the IP Address in the plugin setup menu, e.g. "192.168.1.78:1234". If no port is supplied, it will default to 23, as it does now. This change will make it easier for you to keep up with the latest plugin version without having to retrofit your customizations. I will attach the new "Plugin.pm" to my next post but first want to make sure that you upgrade the plugin to the latest version, which is 4.4. After you have done that, you will just replace Plugin.pm in the plugin directory and restart LMS. Let me know when you are ready to test.
    Sam

  7. #767
    Junior Member
    Join Date
    Apr 2021
    Location
    Béthune, France
    Posts
    16
    Hi Sam.

    Yes plugin is already updated to the latest version.. and I'm ready to test your modifications
    Last edited by oliverbg1; 2022-01-26 at 05:03.

  8. #768
    Senior Member
    Join Date
    Oct 2014
    Location
    Pittsburgh PA
    Posts
    323
    Quote Originally Posted by oliverbg1 View Post
    Hi Sam.

    Yes plugin is already updated to the latest version.. and I'm ready to test your modifications
    Okay. Here it is. Let me know if you have any problems, and good luck!
    Attached Files Attached Files
    Sam

  9. #769
    Junior Member
    Join Date
    Apr 2021
    Location
    Béthune, France
    Posts
    16
    Quote Originally Posted by SamY View Post
    Okay. Here it is. Let me know if you have any problems, and good luck!
    It's OK for me! power up & Down Ok. same behavior for volume. Great job. Thanks for all people like me with old AVR.

    For my other problem I am in discussion with menbers of piCore forum, to let me know why I cant use ser2net inside the piCorePlayer. This will help me using 1 Rpi instead of 2 (1 for player with pcp and another with raspbian and ser2net connected to my AVR).
    I will give news here.
    Last edited by oliverbg1; 2022-01-26 at 10:04.

  10. #770
    Senior Member
    Join Date
    Oct 2014
    Location
    Pittsburgh PA
    Posts
    323
    Quote Originally Posted by oliverbg1 View Post
    It's OK for me! power up & Down Ok. same behavior for volume. Great job. Thanks for all people like me with old AVR.

    For my other problem I am in discussion with menbers of piCore forum, to let me know why I cant use ser2net inside the piCorePlayer. This will help me using 1 Rpi instead of 2 (1 for player with pcp and another with raspbian and ser2net connected to my AVR).
    I will give news here.
    Glad it works for you. The change will be in the next release. Yes, please do keep us posted on your progress with ser2net and piCorePlayer.
    Sam

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •