Home of the Squeezebox™ & Transporter® network music players.
Page 39 of 41 FirstFirst ... 293738394041 LastLast
Results 381 to 390 of 403
  1. #381
    Senior Member
    Join Date
    Oct 2005
    Location
    Ireland
    Posts
    17,990
    I think keep this thread to the use of Net::UDAP - otherwise this digression will fill it.

  2. #382
    Senior Member Julf's Avatar
    Join Date
    Dec 2010
    Posts
    2,510
    Quote Originally Posted by bpa View Post
    I think keep this thread to the use of Net::UDAP - otherwise this digression will fill it.
    Indeed. There is an "audiophile" subforum for discussing imagined improvements in sound quality.
    "To try to judge the real from the false will always be hard. In this fast-growing art of 'high fidelity' the quackery will bear a solid gilt edge that will fool many people" - Paul W Klipsch, 1953

  3. #383
    Junior Member
    Join Date
    Aug 2017
    Posts
    1
    Hi, I am on windows 10 and have troubles getting the udap_shell.pl running , so I used the udap_shell_1_0_0 exe that was posted earlier in this thread.

    My squeezebox duet receiver works with wpa2 and plays the music, but when the server is turned off, the receiver also stops (the light indicator is off) and when the server is turned back on, the receiver stays off.
    My Squeezebox boom does not have this problem, but the duet receiver does not seem to see that the server is running again.

    So when I wake up and turn on the squeezebox server, I open the udap_shell exe on my laptop and tell the receiver to reset and then it works.
    Does anybody know what I can do to make sure that I don't have to reset the receiver every time the server is turned on?

    Thank you very much!

  4. #384
    Senior Member dolodobendan's Avatar
    Join Date
    Dec 2017
    Location
    Braunschweig, Germany
    Posts
    850
    Quote Originally Posted by Julf View Post
    Indeed. There is an "audiophile" subforum for discussing imagined improvements in sound quality.
    Great, there I can tell the world about how my newly acquired iridium plated remote control improved the sound of my USB headphones!

    And back to Net::UDAP.

    Code:
    UDAP> discover
    info: *** Broadcasting adv_discovery message to MAC address 00:00:00:00:00:00 on 255.255.255.255
    Use of uninitialized value in length at /PerlApp/Net/UDAP/Util.pm line 57, <FIN> line 1.
    Use of uninitialized value in length at /PerlApp/Net/UDAP/Util.pm line 67, <FIN> line 1.
    Supplied string has length0(expected length: 6) at /PerlApp/Net/UDAP.pm line 296
    Use of uninitialized value in concatenation (.) or string at /PerlApp/Net/UDAP.pm line 297, <FIN> line 1.
    info:   adv_discovery response received from
    Use of uninitialized value in length at /PerlApp/Net/UDAP/Util.pm line 57, <FIN> line 1.
    Use of uninitialized value in length at /PerlApp/Net/UDAP/Util.pm line 67, <FIN> line 1.
    Supplied string has length0(expected length: 6) at /PerlApp/Net/UDAP.pm line 358
    mac not found in msg at /PerlApp/Net/UDAP/Shell.pm line 156
    Anyone else got this with udap_shell_1_0_0.exe? (And maybe even has a solution?)

    Edit:

    My bad, this has been asked before and a solution was posted

    (http://forums.slimdevices.com/showth...l=1#post501429)

    I got it to work using this:

    https://github.com/robinbowes/net-udap/tree/1.0.x

    And a direct connection between my PC (first ethernet port) and the receiver.
    Last edited by dolodobendan; 2018-01-02 at 10:25.
    QLMS 7.9.3@2.04 x64 (digimaster) with perl 5.28 dedicated to me. :D / QNAP 469L QTS 4.3.4

  5. #385
    Senior Member dolodobendan's Avatar
    Join Date
    Dec 2017
    Location
    Braunschweig, Germany
    Posts
    850
    Quote Originally Posted by Thomas8675309 View Post
    Then I followed the general instructions here:

    http://www.practicalreason.net/item/...out-controller
    Whoever wrote this mixed up local and receiver's IP, but since he was consistent in his misuse, it should work (if it is works at all), despite stuff like:

    Open a command window and get the IP address of the Squeezebox Receiver using the following DOS command:

    Code:
    ipconfig /all
    Here you should find a section Autoconfiguration IPv4 Address which will list the IP address assigned to the device connected on the ethernet port. See the highlighted line above for an example - you can see how the IP address of the Receiver is 192.168.1.4.

    To get the Net::UDAP application to connect to the Squeezebox Receiver you need to run its udap_shell.pl script and specify the IP address of the Receiver you determined in the previous section.
    QLMS 7.9.3@2.04 x64 (digimaster) with perl 5.28 dedicated to me. :D / QNAP 469L QTS 4.3.4

  6. #386
    Junior Member
    Join Date
    Oct 2018
    Posts
    4

    So confused. Am I beating a dead horse?

    Quote Originally Posted by dolodobendan View Post
    Great, there I can tell the world about how my newly acquired iridium plated remote control improved the sound of my USB headphones!

    And back to Net::UDAP.

    Code:
    UDAP> discover
    info: *** Broadcasting adv_discovery message to MAC address 00:00:00:00:00:00 on 255.255.255.255
    Use of uninitialized value in length at /PerlApp/Net/UDAP/Util.pm line 57, <FIN> line 1.
    Use of uninitialized value in length at /PerlApp/Net/UDAP/Util.pm line 67, <FIN> line 1.
    Supplied string has length0(expected length: 6) at /PerlApp/Net/UDAP.pm line 296
    Use of uninitialized value in concatenation (.) or string at /PerlApp/Net/UDAP.pm line 297, <FIN> line 1.
    info:   adv_discovery response received from
    Use of uninitialized value in length at /PerlApp/Net/UDAP/Util.pm line 57, <FIN> line 1.
    Use of uninitialized value in length at /PerlApp/Net/UDAP/Util.pm line 67, <FIN> line 1.
    Supplied string has length0(expected length: 6) at /PerlApp/Net/UDAP.pm line 358
    mac not found in msg at /PerlApp/Net/UDAP/Shell.pm line 156
    Anyone else got this with udap_shell_1_0_0.exe? (And maybe even has a solution?)

    Edit:

    My bad, this has been asked before and a solution was posted

    forums.slimdevices.com/showthread.php?57861-Net-UDAP-SqueezeBox-Receiver-configuration-tool&p=501429&viewfull=1#post501429

    I got it to work using this:

    github.com/robinbowes/net-udap/tree/1.0.

    And a direct connection between my PC (first ethernet port) and the receiver.
    I've tried everything I can think of to get this to work. I was getting all the errors listed above also. Then I finally see this link to a solution. But the link takes me to a page that seems to no longer exists.
    I really have no experience in open source or messing with all this IP kinda stuff. I've spent around 30 hours so far on this. Is this even worth it?

  7. #387
    Senior Member
    Join Date
    Jan 2010
    Location
    Hertfordshire
    Posts
    3,467
    Quote Originally Posted by wownflutter View Post
    I've tried everything I can think of to get this to work. I was getting all the errors listed above also. Then I finally see this link to a solution. But the link takes me to a page that seems to no longer exists.
    I really have no experience in open source or messing with all this IP kinda stuff. I've spent around 30 hours so far on this. Is this even worth it?
    Which link did you try? I just tried the link in the first post which opened a page contained another link to Github which also opens.

    Sent from my SM-G900F using Tapatalk

  8. #388
    Junior Member
    Join Date
    Oct 2018
    Posts
    4
    Quote Originally Posted by slartibartfast View Post
    Which link did you try? I just tried the link in the first post which opened a page contained another link to Github which also opens.

    Sent from my SM-G900F using Tapatalk
    Do you mean the link in the very first page of this thread, or the first link I referenced in this post?


    I started all over and am trying to use the step by step from the beginning instead of using that UDAP shortcut.
    I can't even get past getting the udap_shell.pl to work.
    The instructions are definitely written for expert users. I just can't get anywhere.

  9. #389
    Senior Member
    Join Date
    Jan 2010
    Location
    Hertfordshire
    Posts
    3,467
    Quote Originally Posted by wownflutter View Post
    Do you mean the link in the very first page of this thread, or the first link I referenced in this post?


    I started all over and am trying to use the step by step from the beginning instead of using that UDAP shortcut.
    I can't even get past getting the udap_shell.pl to work.
    The instructions are definitely written for expert users. I just can't get anywhere.
    I was referring to the link in the first page of the thread. I have not needed to use this myself but can imagine it is not straightforward unless you are familiar with it.

    Sent from my SM-G900F using Tapatalk

  10. #390
    Senior Member
    Join Date
    Oct 2005
    Location
    Ireland
    Posts
    17,990
    Quote Originally Posted by slartibartfast View Post
    I was referring to the link in the first page of the thread. I have not needed to use this myself but can imagine it is not straightforward unless you are familiar with it.

    Sent from my SM-G900F using Tapatalk
    Project has been moved to github soU uRL
    https://github.com/robinbowes/net-udap

    It still works although I think it needs to be patched for some OSs and OS versions. I moved from Ubuntu 16.04 to 18.04 and UDAP needed a mod due to a change in output format of "ipconfig " command used by the script.


    UDAP parses output from a similar command in windows to get interface IP address - so perhaps similar problem.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •