Most of the time (but not always) I have not been able to SWITCH BACK FROM digital inputs to the music from SC. My display indicates that I've switched, but the sound is still from the digital input. I have to turn off and on on the Transporter remote to be able to hear the music.

Yesterday I upgraded (from SC 7.2) to SC 7.3.1. First I thougt that the problem finaly was solved - but actually it is now worse, at least it was last night. I had big troubles SWITCHING TO the digital inputs. I tried everything (turning off/on, selecting digital input from the built-in firmware menu, Xilinx reset and factory reset). Nothing helped. I just could not get any sound from the digital inputs. Gave up, did listen to some music, and then after perhaps 30 minutes I tried the digital inputs again - and now it worked. Is there any explanation for this behavior?

This morning I played a littele more with this issue. Now (at least this morning ;-) it seems that I can SWITCH TO the digital inputs all the times. It also seems that if I select to play an album I can switch FROM digital input to the music. But if I select a single track it continues to play the digital input sound. After trying to play a single track, it will NOT play an entire album, unless I go back and select the digital input again (although it is allready playing). After that I can select the album.

Switching to and from the digital inputs seems very unstable. Is this a firmware problem? A hardware problem? Or is it just me doing things in a wrong way?

BTW: Is it possible to rename the digital inputs? It will definately bee more family-freindly to be able to select "DVD" and "CD" compared to "RCA, coaksial, S/PDIF" and "Optical S/PDIF (TOSLINK)".