Home of the Squeezebox™ & Transporter® network music players.
Page 2 of 2 FirstFirst 12
Results 11 to 18 of 18
  1. #11
    Junior Member
    Join Date
    Dec 2008
    Tried all kinds of things tonight:

    1. First, I brought my Duet over to my friend's apartment, who already has a SB Classic on his network. Upon first try, my Duet recognized his SqueezeCenter and I was able to select it through the controller. Sadly, I was unable to get further than the selection because my Duet entered into the software update mode and my controller didn't have enough battery power to make it through that stage (apparently it didn't charge on the dock last night...). Nonetheless, it seemed like a good sign that there probably is nothing wrong with my Duet -- it's likely just some configuration issue with my network / PC.

    2. My friend and I hypothesized that, since my Duet connects to my network and my Windows firewall is set up as it should be, the likely culprit may be some program or service running on my PC. Accordingly, I stopped all .exe's and services related to Symantec AntiVirus and my Checkpoint VPN. I also stopped all other .exe's that were unnecessary. None of that made a difference.

    3. After reading the thread about WPA-TKIP that DoomWolf supplied, I tried switching to that encryption as well as WPA-AES and the other WPA2's. None of that made a difference either.

    4. Slimpy, by "SqueezePlay" I'm assuming you're referring to SoftSqueeze. No, my controller does not list SoftSqueeze once it has "found" my music sources. SoftSqueeze does, however, show up in SqueezeCenter.

    5. Hildebrandt, how would I check the connection to the controller/receiver in the router? When I look at the router's admin pages, I can see that there are two DHCP clients (the controller and receiver I would suspect since I don't have any other devices on my network). However, the IP of my PC (ending in .100) does not show up in this list, which does seem strange.

    6. My friend mentioned running netstat, which I did, but I can't say that I understand how to interpret the results that well. I've pasted them below in case any of you can find anything of use. Again, I don't really know what I'm talking about here, but it does seem suspicious to me that my PC is showing up under Foreign Address, both as 'localhost' and of course as 'revengeoftheant'. Is that normal?

    Active Connections

    Proto Local Address Foreign Address State
    TCP revengeoftheant:epmap revengeoftheant:0 LISTENING
    TCP revengeoftheant:microsoft-ds revengeoftheant:0 LISTENING
    TCP revengeoftheant:3483 revengeoftheant:0 LISTENING
    TCP revengeoftheant:9000 revengeoftheant:0 LISTENING
    TCP revengeoftheant:9090 revengeoftheant:0 LISTENING
    TCP revengeoftheant:31038 revengeoftheant:0 LISTENING
    TCP revengeoftheant:1052 revengeoftheant:0 LISTENING
    TCP revengeoftheant:4751 localhost:9000 ESTABLISHED
    TCP revengeoftheant:4752 localhost:9092 ESTABLISHED
    TCP revengeoftheant:4753 localhost:9000 CLOSE_WAIT
    TCP revengeoftheant:4754 localhost:9000 ESTABLISHED
    TCP revengeoftheant:4755 localhost:9000 ESTABLISHED
    TCP revengeoftheant:4756 localhost:9000 ESTABLISHED
    TCP revengeoftheant:4757 localhost:9000 ESTABLISHED
    TCP revengeoftheant:5152 revengeoftheant:0 LISTENING
    TCP revengeoftheant:5152 localhost:4846 CLOSE_WAIT
    TCP revengeoftheant:9000 localhost:4751 ESTABLISHED
    TCP revengeoftheant:9000 localhost:4753 FIN_WAIT_2
    TCP revengeoftheant:9000 localhost:4754 ESTABLISHED
    TCP revengeoftheant:9000 localhost:4755 ESTABLISHED
    TCP revengeoftheant:9000 localhost:4756 ESTABLISHED
    TCP revengeoftheant:9000 localhost:4757 ESTABLISHED
    TCP revengeoftheant:9092 revengeoftheant:0 LISTENING
    TCP revengeoftheant:9092 localhost:4752 ESTABLISHED
    TCP revengeoftheant:netbios-ssn revengeoftheant:0 LISTENING
    TCP revengeoftheant:4876 wwwtk2test2.microsoft.com:http ESTABLISHED
    TCP revengeoftheant:4877 ESTABLISHED
    TCP revengeoftheant:4878 ESTABLISHED
    TCP revengeoftheant:4879 ESTABLISHED
    TCP revengeoftheant:4880 ESTABLISHED
    TCP revengeoftheant:4881 ESTABLISHED
    TCP revengeoftheant:4882 ESTABLISHED
    TCP revengeoftheant:4883 ESTABLISHED
    TCP revengeoftheant:4884 ESTABLISHED
    TCP revengeoftheant:4885 ESTABLISHED
    TCP revengeoftheant:4888 ESTABLISHED
    TCP revengeoftheant:4892 ESTABLISHED
    TCP revengeoftheant:4893 ESTABLISHED
    TCP revengeoftheant:4894 iw-in-f147.google.com:https ESTABLISHED
    UDP revengeoftheant:microsoft-ds *:*
    UDP revengeoftheant:isakmp *:*
    UDP revengeoftheant:3483 *:*
    UDP revengeoftheant:4500 *:*
    UDP revengeoftheant:ntp *:*
    UDP revengeoftheant:1410 *:*
    UDP revengeoftheant:1900 *:*
    UDP revengeoftheant:4762 *:*
    UDP revengeoftheant:ntp *:*
    UDP revengeoftheant:netbios-ns *:*
    UDP revengeoftheant:netbios-dgm *:*
    UDP revengeoftheant:1900 *:*
    Last edited by revengeoftheants; 2008-12-18 at 01:20.

  2. #12
    Junior Member
    Join Date
    Nov 2008
    I'm not overly familiar with the WRT54GL so unless it has a separate screen for DHCP clients over wireless and wired, your computer should be listed there. Double check that it is grabbing the IP from the router and hasn't been set statically so it is definitely in the same subnet.

    I would also consider trying to set up the SBR by not using the wireless (turn it off in the router config) and plugging it directly into the router with a network cable. You would then connect to the SBR with the controller through bridging mode. If it still doesn't work then, you know it isn't a wireless issue.

    Lastly when I was speaking to support yesterday they did ask if I had any VPN clients installed so maybe there is an issue with these? Other more knowledgable people will probably have more info about this.

    I'd also think about calling Logitech Support as they do have a lot of expertise.
    Last edited by Rimmer100; 2008-12-18 at 02:38.

  3. #13
    Senior Member Millwood's Avatar
    Join Date
    Jan 2006
    I have a wrt54g. the dhcp client page is not reliable - it often has missing entries.

    Could you post the result of

    ipconfig /all

    on your pc just to see the network setup.

    Also, make sure you entered the correct netmask (same as seen in ipconfig /all or in your router setup) when you configured your controller.
    2 SB3, 1 Duet
    Debian Jessie server LMS 7.9.1
    Netgear WNDR3400V3 wireless network.

  4. #14
    Sounds like you're a fairly technical user so hopefully you'll be comfortable with some of the suggestions below.

    Since you have a WRT54GL you might want to consider ditching the Linksys firmware and jumping to DD-WRT.

    I'm running DD-WRT with WPA-AES encryption on my old Buffalo router and haven't had a single issue with any of my six devices (one SBR, an SBC, a Boom, two SB3's, and an SB2) - however, I also don't run any firewalls or AV on my XPSP3 squeezecenter.

    Probably not the root of your problem, but you will have much power power and control with your GL - and you will likely gain a good amount of stability from it.

    At one point you mentioned you were running zone alarm and windows firewall - any reason for that? Later you mentioned the only firewall was the windows firewall -- did you uninstall zonealarm or disable it?

    This really seems like a firewall problem - with the firewalls, AV, etc running on this PC, no telling what's still hiding out & blocking incoming packets. Probably the next step is to fire up some network tools so we have more visibility about what's going on.

    Step one at this point is probalby to get a port scanner and run it from another computer hooked to your network - scan the squeezecenter PC to see if the ports are indeed open.

    There are many free port scanners available out there. Before you attempt a port scan, be sure you can ping your squeezecenter PC.

    Once you've verified the proper ports are open, the next step may be to fire up a packet analyzer like wireshark on your squeezecenter computer and look for incoming packets from the receiver. I don't know off hand what a person should be seeing as I've never had to do this for my setup, but I'm sure there are folks on here that do know what packets to look for.

    Before you try to analyze the data from wireshark, be sure you know your SBR's IP address - that way you can disregard any packets from any other devices on your network & make life easier on yourself.

    If you get to the point of running wireshark & have captured packets from the SBR, you can save that capture to a file and post for others to analyze.

    The beauty of wireshark is that it will let you really know what's going on in your network instead having to try to guess. It should lead to a very quick isolation of the problem & hopefully, resolution.
    Last edited by 86atc250r; 2008-12-18 at 12:20.

  5. #15
    Senior Member
    Join Date
    Dec 2007
    To the OP. It sounds very much like the router and the wireless is working properly though there is a possibility that there could still be a configuration issue with the wireless but I don't think that is the case here as you mention that you can ping all the devices. I assume that you are doing this from the PC. If not it would be worth trying to ping the controller and receiver from the PC. It should work. If not then look into the router configuration to see if it has a setting that stops wireless devices getting to LAN devices, some wireless routers have that security feature.

    Assuming the ping is OK then in principle the controller and receiver can talk to the PC at a network level. The question then becomes what stops it seeing SqueezeCentre. You mention having tries SoftSqueeze which I assume is on the same PC as SqueezeCentre and I infer from this that you have tried accessing SqueezeCentre from a browser on the same PC. It would help here if you had another PC from which you could try to access SC. I suspect it may fail.

    Looking at your netstat output you seem to have a number of connections to port 9000. That port is used by SC to stream the music and provide the main information feed in and out. As you can't get the controller and receiver connected those shouldn't exist. This suggest to me that you have another application which is using that port and thus blocking the Duet. If you use netstat -b it will give you the exe filename associated with each port and 9000 should be squeezecentre.exe if not that is your culprit.

    Assuming that is the case then the simplest solution is to move SC out of the way (since your unlikely to be able to do it with the other app). Luckily you can access the SC interface from the web browser so go to settings and the advanced tab. Select Network from the drop down on on that page change the "Web Server port number". Make it something which isn't in use say 9001 and apply the changes. Then stop and restart SC and try it out.

    The firewall may need adjusting to the new port number but I suggest you try it with it disabled first and then enable it afterwards if it works.

    (I also vaguely recall that some VPN software uses port 9000 and since you have one installed it seems like a candidate.) And in case anyone is wondering why it would work from a browser/Softsqueeze on the PC and not on the network. On the PC by default SoftSqueeze and the browser connect to not the LAN IP address. Most likely interfering software only establishes a port on the LAN IP address not the loopback address so SC can successfully establish and use a port there.

  6. #16
    Junior Member
    Join Date
    Dec 2008
    Thanks to everyone who has posted. I'm happy to report that the problem has been solved.

    I ran netstat -b to see if there was anything else using port 9000 and didn't see anything, so I finely broke down and called Logitech support. To be honest, I didn't find the representative to be all that helpful. He only asked the very basic questions that are asked in the user guide and in numerous posts in these forums. When I foresaw that the phone conversation was going to last a long time, I offered up the fact that my PC also had VPN software installed. I had turned it off, but I asked him if he thought uninstalling it would be a better option. He said to give it a try, so I did and now everything works smashingly.

    I actually uninstalled two pieces of software, Authenex authentication and Checkpoint SecurClient. I didn't take the time to see which one was the ultimate culprit, but I would suggest to anybody who has issues getting the receiver and SqueezeCenter server to see each to make sure that any VPN related software is uninstalled.

    Thanks again for taking the time to help me with this issue.

  7. #17
    Senior Member
    Join Date
    Jan 2006
    Hmm, by any chance did you try to reinstall the VPN software after getting the Duet up and running?

  8. #18
    Senior Member
    Join Date
    May 2008
    If I remember rightly Checkpoint SecurClient includes an agressive firewall, which was probably the source of your problems.
    Yes, it will. Yes, all of them. Yes, SoftSqueeze as well. What ?

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts