Home of the Squeezebox™ & Transporter® network music players.
Page 2 of 2 FirstFirst 12
Results 11 to 19 of 19
  1. #11
    Member
    Join Date
    Jun 2005
    Location
    Belgium
    Posts
    35
    I've managed to apply the patch and compile slimp3slave. I had to change 'curses' into 'ncurses' in slimp3slave.c and the Makefile.

    It plays the music fine but 2 problems remain:
    - as root, the music plays fine but it still comes up and says "Playmode: 3" every time I change the song.
    - otherwise it says "Ignoring sigpipe" and no music plays. The Playmode message also appears in between.

    It's on Suse 9.3 (and I know next to nothing about linux). Any tips?

  2. #12
    Member
    Join Date
    Sep 2005
    Location
    Past the Black Stump
    Posts
    46

    Re: slimp3slave startup on debian

    On 25/10/05 09:55:05, Roger the Shrubber wrote:
    >
    > I've managed to apply the patch and compile slimp3slave. I had to
    > change
    > 'curses' into 'ncurses' in slimp3slave.c and the Makefile.
    >
    > It plays the music fine but 2 problems remain:
    > - as root, the music plays fine but it still comes up and says
    > "Playmode: 3" every time I change the song.
    > - otherwise it says "Ignoring sigpipe" and no music plays. The
    > Playmode message also appears in between.
    >
    > It's on Suse 9.3 (and I know next to nothing about linux). Any tips?
    >
    >


    Did you run it with the -b option?
    --
    'ooroo

    stinga...(-)
    ---------------------------------------------------
    Email: stinga (AT) wolf-rock (DOT) com o
    You need only two tools. o /////
    A hammer and duct tape. If it /@ `\ /) ~
    doesn't move and it should, > (O) X< ~ Fish!!
    use the hammer. If it moves and `\___/' \) ~
    shouldn't, use the tape. \\\
    ---------------------------------------------------


  3. #13
    Member
    Join Date
    Jun 2005
    Location
    Belgium
    Posts
    35
    Yes, with -b.
    The patch seems to be applied properly because the .c file has 'while((opt = getopt(argc, argv, "+vlbhs:c:")) != -1)' in it.

    Is it supposed to return to the prompt because I also don't get back when I start?

  4. #14
    Member
    Join Date
    Sep 2005
    Location
    Past the Black Stump
    Posts
    46

    Re: slimp3slave startup on debian

    On 25/10/05 12:25:46, Roger the Shrubber wrote:
    >
    > Yes, with -b.
    > The patch seems to be applied properly because the .c file has
    > 'while((opt = getopt(argc, argv, "+vlbhs:c:")) != -1)' in it.
    >
    > Is it supposed to return to the prompt because I also don't get back
    > when I start?
    >
    >


    Nope it just supposed to sit there making noise... :-)

    If you want ti actually background it, thaen use of the & is required!
    Maybe 'background' was not such a good description.

    --
    'ooroo

    stinga...(-)
    ---------------------------------------------------
    Email: stinga (AT) wolf-rock (DOT) com o
    You need only two tools. o /////
    A hammer and duct tape. If it /@ `\ /) ~
    doesn't move and it should, > (O) X< ~ Fish!!
    use the hammer. If it moves and `\___/' \) ~
    shouldn't, use the tape. \\\
    ---------------------------------------------------

  5. #15
    Member
    Join Date
    Jun 2005
    Location
    Belgium
    Posts
    35
    I don't know what & does (or how to use it), but I can get it to run and show a prompt again with:
    startproc -u slimserver /usr/local/slimserver/slimp3slave/slimp3slave -b -s localhost

    but then I still get "Ignoring sigpipe" (as slimserver) and "Playmode: 3" (as root and as slimserver).

  6. #16
    Member
    Join Date
    Sep 2005
    Location
    Past the Black Stump
    Posts
    46

    Re: slimp3slave startup on debian

    On 25/10/05 16:55:18, Roger the Shrubber wrote:
    >
    > I don't know what & does (or how to use it), but I can get it to run
    > and
    > show a prompt again with:
    > startproc -u slimserver /usr/local/slimserver/slimp3slave/slimp3slave
    > -b -s localhost
    >
    > but then I still get "Ignoring sigpipe" (as slimserver) and
    > "Playmode:
    > 3" (as root and as slimserver).
    >



    I just do
    slimp3slave -b&
    and it works, never tried the -s option since I have slimp3slave and
    slimserver on the same box.

    Try that.
    I might have commented out the Playmode comment in the c code since I
    wasn't interested.
    I am sure the sigpipe error is when it is trying to accept input when
    you have run it daemon mode, which would sort of say the -s is screwing
    up the -b option.

    --
    'ooroo

    stinga...(-)
    ---------------------------------------------------
    Email: stinga (AT) wolf-rock (DOT) com o
    You need only two tools. o /////
    A hammer and duct tape. If it /@ `\ /) ~
    doesn't move and it should, > (O) X< ~ Fish!!
    use the hammer. If it moves and `\___/' \) ~
    shouldn't, use the tape. \\\
    ---------------------------------------------------

  7. #17
    Member
    Join Date
    Jun 2005
    Location
    Belgium
    Posts
    35
    the result of
    startproc /usr/local/slimserver/slimp3slave/slimp3slave -b

    and
    slimp3slave -b&

    is the same except that in the latter case it returns the PID. "Playmode: 3" is still showing up. I'll try to remove it from the source.

    The "Ignoring sigpipe" is probably related to permissions, I guess. I just checked and madplay won't work as slimserver either. I did add slimserver to the 'audio' group in YAST, but no effect. Any suggestions on that?
    Thanks!

  8. #18
    Member
    Join Date
    Jun 2005
    Location
    Belgium
    Posts
    35
    chmod 666 /dev/dsp seems to have fixed it.
    Thanks for your help!

  9. #19
    Member
    Join Date
    Sep 2005
    Location
    Past the Black Stump
    Posts
    46

    Re: slimp3slave startup on debian

    On 25/10/05 21:46:20, Roger the Shrubber wrote:
    >
    > the result of
    > startproc /usr/local/slimserver/slimp3slave/slimp3slave -b
    >
    > and
    > slimp3slave -b&
    >
    > is the same except that in the latter case it returns the PID.
    > "Playmode: 3" is still showing up. I'll try to remove it from the
    > source.
    >
    > The "Ignoring sigpipe" is probably related to permissions, I guess. I
    > just checked and madplay won't work as slimserver either. I did add
    > slimserver to the 'audio' group in YAST, but no effect. Any
    > suggestions
    > on that?
    > Thanks!
    >


    ??!!???
    Lets go back to basics...

    Log on as root.
    run slimp3slave
    does it work?

    run slimp3slave -b&
    does it work?

    run madplay
    does it work?

    Maybe it is a madplay issue?

    Post any output, if you get any...

    --
    'ooroo

    stinga...(-)
    ---------------------------------------------------
    Email: stinga (AT) wolf-rock (DOT) com o
    You need only two tools. o /////
    A hammer and duct tape. If it /@ `\ /) ~
    doesn't move and it should, > (O) X< ~ Fish!!
    use the hammer. If it moves and `\___/' \) ~
    shouldn't, use the tape. \\\
    ---------------------------------------------------

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •