Home of the Squeezebox™ & Transporter® network music players.
Page 1 of 4 123 ... LastLast
Results 1 to 10 of 32
  1. #1

    Exclamation Boom first impressions. Problems!

    When I first powered up my Boom I selected the SqueezeNetwork as the source and it did 2 updates to Firmware 32. I then switched to my own SqueezeCenter running Ubuntu 'Server' 8.04.1 (Hardy) with Perl 5.8.8 and SqueezeCenter 7.2 - 22900 from APT deb http://debian.slimdevices.com stable main. I have AlienBBC and AAC Plus installed.

    Once connected to my SC, I played some music everything was working fine. I hit the power button and did a little work. After a short while I loaded up the SqueezeCenter Web Interface on my laptop, turned on my Boom and pressed 'Play'. There was silence. The progress bar on the SCWI page was moving along, but the Boom was sitting there with Now Playing showing the correct track, but no progress. I could pause and play, but no sound and the 'remaining time' counter wouldn't decrement.

    I quit the SCWI, pressed the controller on the Boom, browsed the music and attempted to play something else. Same problem. I tried some Internet Radio, but this was the same - it would connect to the stream and then sit there not doing anything. I held down the power button, the Boom rebooted and then everything was working again.

    I played a bit more music and was playing around with the unit, loaded up a different album, queued up some more, played another album... and then it 'locked up' again. No sound, no track progress. Reboot.

    One way of recreating this problem on my Boom is attempting to play any of the 'Natural Sounds' or 'Sound Effects' in the Extras menu item. This then just stops working and no sound or track progress until the Boom is rebooted again.

    I thought maybe I was fiddling with it too much? I don't know, it was late. I set the alarm from the Boom for 4:30am with the 'Random Mix' option and played some Kings of Convenience to put me to sleep. I woke up on my own at 4:40, and noticed that the alarm icon was flashing and the time/date display was different. It appeared to be playing on Alarm, but no sound and no track progress. Good thing I have a good body clock.

    I unplugged the Boom, rebooted the Netgear DG834G router, rebooted the fileserver running SC and plugged the Boom back in again. I'll post back when I get home if it happens again.

    My SqueezeCenter logfile is attached.
    Last edited by hussein; 2008-09-10 at 05:02.

  2. #2
    Logitech Squeezebox Employee
    Join Date
    Jun 2008
    Posts
    468

    Boom first impressions. Problems!

    This is very strange behavior. When the track doesn't progress as you say,
    it's usually a xilinx not programmed problem (which can be solved easily).
    However, since it works sometimes and doesn't work other times, it seems
    like a network issue. Maybe. What is your network setup? Can you
    reproduce again and post exact steps you took?'
    Thanks so much. We've gone through a ton of alpha and beta testing, but odd
    problems can still slip through.

    Does anybody else recognize what this problem could be?


  3. #3
    Thanks for your reply Caleb.

    I just got home. First thing I did was reset the Boom by holding down '+' while rebooting (holding down the power button). Re-entered my WPA2 key (much less painful the second time), and it seemed good to go. My fileserver and router were reset this morning when the Boom failed to wake me and I haven't touched them since.

    Everything works as you would expect. Playing some music no problem. I scrolled to 'Extras', 'Sounds & Effects' - attempting to play anything here makes the Boom go crazy. Squeezecenter log file reports:
    Code:
    [08-09-09 22:49:02.3273] Slim::Schema::updateOrCreate (1065) Error: { TITLE => "Sound Effects" }
    [08-09-09 22:50:25.6828] Slim::Schema::updateOrCreate (1064) Error: No URL specified! Returning undef.
    Are these files/sounds supposed to be included with SqueezeCenter? Do they work for anyone else? Anyway, once it has failed to play these files it then fails to play anything else until a reboot.

    That is reproducible here - but please note I have seen this problem happen a couple of times randomly without the help of the 'Sounds & Effects' menu.

    My network setup is a Netgear DG834G v4 Wireless ADSL Modem Router with the latest firmware. Its configured for 802.11g with WPA2-PSK. The SqueezeCenter is plugged into the router with a short run wired 100Mb connection which works well. I can provide any info on services etc if you think they are relevant.

    As for network performance, the Boom says it has a signal strength of ~'80' and the network test shows it can do 5000kbps without any packet drop. Compatibility-wise, the router is based on a Broadcom BCM4318 wireless chip and works fine (quite reliably) with: Macbook, iBook G4, Lenovo Thinkpad (Intel 3945ABG), Nintendo Wii and HTC TyTN II phone all running a multitude of operating systems. It does not work with any Intel 2200BG chipset based computer/device.

    -----

    ...while typing this post I was listening to some Michael Jackson on my Boom. At the end of track 4 its just stopped working, not advancing to the next track and again not playing anything else. The UI works perfectly (and always does when this happens). I just had to prod the power button again.

    Damn.

  4. #4
    Senior Member
    Join Date
    Apr 2005
    Location
    UK
    Posts
    357
    The Sounds & Effects all play fine on my Boom.

    I'm using SqueezeCenter Version: 7.2 - 22900 @ Tue Aug 26 11:27:23 PDT 2008 - Windows XP - EN - cp1252, on Win XP SP3

    Richard

  5. #5
    Thanks Richard.

    I think I have found something. I have left the Boom playing and it has been behaving itself. I revisited the point in the playlist where it stopped working last time, and it died again this time. I had two tracks in an album with the same track number in the ID3 tag - this killed my Boom.

    Now that I've fixed that and rebuilt the database I'm keeping an eye out to see if it happens again.

    Edit: To be clear, in one album the Boom went into 'silent mode' and stopped after Track 4 because Track 5 and Track 6 both were labelled as Track 6 in their ID3 tags.
    Last edited by hussein; 2008-09-10 at 14:14.

  6. #6
    My Last.FM recommendations just made the Boom go quiet. It was working before.

  7. #7
    Senior Member
    Join Date
    Apr 2007
    Location
    St. Paul, MN USA
    Posts
    884
    Are you streaming flac to the boom or converting to mp3 (bitrate limiting)?

    I'm trying to think of anything similar but all I'm coming up with was some of the early "new streaming" stuff - which you shouldn't have.

  8. #8
    Although I do have 30-40% of my music in FLAC, SqueezeCenter only has the path to MP3s. These vary: tracks transcoded from FLAC are Lame encoded VBR, and all the rest can be anything. They all have ID3v2 tags. They all play fine on my Empeg, in iTunes (via mt-daapd) and in XBMC on my Xbox.

    AlienBBC also kills the Boom. It works fine in SoftSqueeze.

    This is bad news. Can I re-flash the current firmware onto my Boom? Is there some kind of hardware diagnostic? Memory test?

  9. #9
    I just fed it a FLAC file. It didn't like it.

  10. #10
    Senior Member
    Join Date
    Apr 2007
    Location
    St. Paul, MN USA
    Posts
    884
    Really unusual. About all I play is flac.
    I'm out of ideas except for randomly resetting and reinstalling things (xilinix, firmware, sc 7.2, etc.). Support?

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •