Home of the Squeezebox™ & Transporter® network music players.
Page 1 of 6 123 ... LastLast
Results 1 to 10 of 56
  1. #1
    Member BlueWombat's Avatar
    Join Date
    Jun 2006
    Location
    SF, CA
    Posts
    67

    Help: HP MSS, AlienBBC and AAC files

    Hi - I've successfully installed Squeezecenter on my Mediasmart Server and gotten it running, even added in the AlienBBC plug-in, but when I go to change the file conversion settings so that mplayer converts my AAC files for streaming I don't see Mplayer as a choice...I made this change successfully in the past on my old PC. Any thoughts on what I'm missing to get mplayer listed and selected on the File Settings page??

    P.S. I was able to run AlienBBC's test batch and it looked like a stream was running on the server, but of course I couldn't tell since the MSS has no audio output :-)

  2. #2
    Senior Member
    Join Date
    Oct 2005
    Location
    Ireland
    Posts
    17,859
    Some more Info always help.

    I presume MSS is some sort of WHS based NAS and not a Linux based NAS. I also presume you are running SC 7.x

    IS your problem that both AlienBBC and AAC don't play or just AAC ?

    It looks like either
    * mplayer is installed in the wrong directory
    * ownership or permissions is preventing SC from finding mplayer
    * mplayer is marked as not executable by SC.

    How did you install AlienBBC - zip or exe ?
    What is the full path name of SC installation ?
    What is the full path name of the directory where mplayer is installed ?

    Why do you need to change AAC definitions ?
    Did you have problems with Quicktime ?

    On small systems, mov123 (with Quicktime) or faad would be lighter solutions for AAC rather than mplayer.

  3. #3
    Member BlueWombat's Avatar
    Join Date
    Jun 2006
    Location
    SF, CA
    Posts
    67
    As I noted in the body of the note, the HP MSS is HP's MediaSmart Server - I know there are several people on this forum that have sucesssfully installed on this WHS server, so I was hoping for some advice from those users.

    The issue is this - I have a large number of files that are AAC files in addition to my other music. When I was running Squeezecenter on my PC before adding the Windows Home Server, I had problems with AAc stuttering on playback, so thought the best method was to install Mplayer via AlienBBC since I'd have to install either that or Quicktime onthe server anyways.

    As I stated, Squeezecenter was successfully instralled using the WHS desktop. I then installed AlienBBC using the EXE file. The files seem to be set up similarly to the setup on my old PC, in the same Squeezesever sub directory, etc. As I stated, I was also able to run AlienBBCs test that is a DOS Bath - it shows that a stream is playing from one of the BBC stations. HOWEVER, when I go in to associate conversion of AAC files, Mplayer doesn't show on the dropdown like it does on my old PC setup, meaning I can't choose that as my streaming/conversion program.

    Your suggested possible causes are where I was going too

    Quote Originally Posted by bpa View Post
    * ownership or permissions is preventing SC from finding mplayer
    * mplayer is marked as not executable by SC.
    But I don't know how to resolve these types of issues or where to start.

    Basically, if I have gotten Windows Home Server to install the programs, is there anything else I need to do to make sure squeezecenter can use them??


    P.S. I was previously using a setup with a linkstation for storage and my PC as the slimserver, but found it really caused issues, such as slowing the PC for other uses, meaning the PC had to be awake to play music, etc. The HP Media Server came from a neighbor who works for MS and got it for me CHEAP, so I thought I'd try a dedicated server.

  4. #4
    Senior Member
    Join Date
    Oct 2005
    Location
    Ireland
    Posts
    17,859
    Does AlienBBC work - can you play a BBC stream from SC ? If so then mplayer is in the right place and permissions is not the issue. The batch file will always work even if mplayer is in the wrong place or has wrong permissions - the batch test just proves mplayer is OK when run by a user and there is a network path from PC to network.


    Please clarify the following - Under Settings/Advanced/Filetypes Apple AAC - is the drop down box grey and doesn't work at all or it does work but mplayer is not shown as an option. If the latter, what is shown as the option besides "disabled".

    If the FileTYpes box is grey - please attach a copy of your conf filer that has the edited mplayer entry - either a modified convert.conf, a custom-convert.conf or a slimserver-convert.conf.

    Did you use Notepad or Wordpad to edit the conf file ?

  5. #5
    Senior Member bonze's Avatar
    Join Date
    Jun 2006
    Location
    Bucks. UK
    Posts
    1,499
    Sorry to butt in, but I'm slightly confused by this thread.

    Looking at my Settings /Advanced /File Types page....

    I have AACplus which decodes with 'mplayer'
    and Apple AAC which decodes with 'mov123'

    Should the Apple AAC also have an option for mplayer ? or have I got the wrong end of the wossname ?
    Also, if I remember correctly, the AACplus options only appeared after installing the extras from:
    http://forums.slimdevices.com/showpo...4&postcount=19
    LMS Version: 7.9
    TranquilPC T2-WHS-A3 - WHS 2011
    2x Touch, 3x SB3

  6. #6
    Senior Member
    Join Date
    Oct 2005
    Location
    Ireland
    Posts
    17,859
    AACplus is NOT AAC. AACplus is nearly always used in streams.

    mplayer can be used to decode AAC and AACplus.

    The official supported Squeezecenter decoder for AAC is mov123 which uses QuickTime libraries. Some user have had problems with the mov123/QuickTime solution and so have changed the standard setting to use mplayer.

    If you do not have problems playing AAC - then stick with the official decoder.

  7. #7
    Member BlueWombat's Avatar
    Join Date
    Jun 2006
    Location
    SF, CA
    Posts
    67
    OK - I can get a stream from AlienBBC and, just to clarify, MP3s play fine.

    When I try to play an AAC file, I noticed the time counter will click off the first few seconds of the song, then jump back to 0:00, then start again - a loop - but even during those first few seconds no sound comes out.

    Just to make sure It wasn't an issue of mis-typing, I copied the convert.conf file from my working version of the PC based Squeezecenter with no change.

    On the File Types menu I have the following:

    Apple AAC or Movie File:
    AIFF = Mov123 (other choice is "Disabled")
    FLAC = mplayer/FLAC (other choice is "Disabled")
    MP3 = Disabled (Greyed out)
    WAV = mplayer (other choice is "Disabled")

  8. #8
    Senior Member
    Join Date
    Oct 2005
    Location
    Ireland
    Posts
    17,859
    MP3 playing proves nothing as there is no transcoding at work.

    Playing BBC streams through AlienBBC (i.e. not Staff picks BBC streams) proves mplayer is OK, permissions are OK and socketwrapper is not blocked.

    Since mplayer is not greyed out for AAC - it means SC has found mplayer and can execute it.

    Selecting a file and playing it - clock ticks and then stops. This is normal if either mplayer, flac or socketwrapper could not run or access the file. SC find the error by timeout.

    Can you do a log of playing an AAC file with logging of player.source set to DEBUG.

    Post the log.

  9. #9
    Member BlueWombat's Avatar
    Join Date
    Jun 2006
    Location
    SF, CA
    Posts
    67
    OK, my next steps have been:

    1. reset config to play AAC via mov123 and it worked BUT I have the issue of static that I had before on my old system.
    2.set config to use mplayer again, added Logging per request. Song didn't play - same skipping back to start as before in a loop
    3.Here is the log:




    A couple of things look weird, but as this is beyond my capabilities, I hope BPA can decipher.

  10. #10
    Senior Member
    Join Date
    Oct 2005
    Location
    Ireland
    Posts
    17,859
    The log shows everything looking OK setting up socketwrapper, mplayer and flac with reasonable command lines.

    It looks like either socketwrapper, mplayer or flac has a problem with either either a command line value or is being prevented from running or passing data (e.g. security s/w). The only way to find out what is happening is to get more detailed log output by running SC in a DOS box.

    Post a log following the instructions for "More complete Logging" from the AlienBBC wiki entry.
    http://wiki.slimdevices.com/index.ph...mplete_Logging

    Detailed logging will enable output from mplayer and socketwrapper to be saved as they cannot write their debug output to SC log file.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •