Home of the Squeezebox™ & Transporter® network music players.
Page 54 of 55 FirstFirst ... 44452535455 LastLast
Results 531 to 540 of 547
  1. #531
    Junior Member
    Join Date
    Jul 2020
    Posts
    5
    Quote Originally Posted by bpa View Post
    IIRC Those messages do not appear unless log level plugin.extensions has been changed from ERROR and set to be retained after LMS restarts - so that sounds like it is historical - a change made a good time ago.
    No I had turned on debug for the plugin.extensions and restarted LMS in order to get the debug output for WaveInput after reading the previous post #508 about the same issue following update to 8.1

    Quote Originally Posted by bpa View Post
    The "uninstall" and "install" shows you probably haven't been restarting LMS after requesting a plugin to be installed/uninstalled.
    Please see above, I had restarted when turning on debug. The uninstall and install appeared when I installed the update to BBC Sounds and restarted.

    Quote Originally Posted by bpa View Post
    When uninstalled, it is in 3rd Party plugins. Did you manually add a repository ?
    Yes it is. No.


    Quote Originally Posted by bpa View Post
    Unless you describe what "ODD happening" is - I can't help.
    Well I updated from 7.9.3~1591161343 to 8.1.0 and WavInput remained in the active plugins list but with no tick in the box and its description was 'Plugin is incompatible with this version of Logitech Media Server. Please update.' I enabled debug and got the messages in the log as I posted. I also ticked the box next to WaveInput in the active plugins, applied and restarted: this made no difference. Later I noticed there was an update available to BBC Sounds so I applied that and restarted and at that point I got the uninstall message for WaveInput in the log. WaveInput then appeared in the 3rd party plugins list and I was able to select it, apply and restart, at which point the plugin works. That whole sequence does not seem like the 'normal' one to me and I therefore surmise it to be 'odd'. Short of sending you the complete server.log, which you are most welcome to, I'm not sure what else I can tell you, the plugin is fine now and I'm very grateful to you for the effort you've made to create it in the first place and to help idiots like me when things go wrong!

  2. #532
    Senior Member
    Join Date
    Oct 2005
    Location
    Ireland
    Posts
    20,768
    Quote Originally Posted by yas1 View Post
    Well I updated from 7.9.3~1591161343 to 8.1.0 and WavInput remained in the active plugins list but with no tick in the box and its description was 'Plugin is incompatible with this version of Logitech Media Server. Please update.'
    The WaveInput was only valid for 7.9.* before 8.0 was released. When 8.0 was released for a few months and I had time to check out the plugin with 8.0 - I then updated WaveInput plugin so that it would compatible with 8.*

    I think you are saying you had WaveInput already installed with 7.9.3 (and maybe earlier) - this wasn't clear from earlier post.
    So the version of the plugin already installed in 7.9 had validity marked for 7.9.* in install.xml from the pre-existing installed version of WaveInput - whereas the repository version of WaveInput has an updated install.xml for 8.* compatibility.
    After upgrade to 8.1 - the plugin version did not change so no plugin update, but the compatibility as indicated in install.xml still show only 7.9.* compatibility.
    To get an updated install.xml which had 8.* compatibility - plugin had to be uninstalled and reinstalled.

    This "install.xml" issue is true for many plugins which did not have a version update as there is no code change.

  3. #533
    Junior Member
    Join Date
    Jul 2020
    Posts
    5
    Quote Originally Posted by bpa View Post
    The WaveInput was only valid for 7.9.* before 8.0 was released. When 8.0 was released for a few months and I had time to check out the plugin with 8.0 - I then updated WaveInput plugin so that it would compatible with 8.*

    I think you are saying you had WaveInput already installed with 7.9.3 (and maybe earlier) - this wasn't clear from earlier post.
    So the version of the plugin already installed in 7.9 had validity marked for 7.9.* in install.xml from the pre-existing installed version of WaveInput - whereas the repository version of WaveInput has an updated install.xml for 8.* compatibility.
    After upgrade to 8.1 - the plugin version did not change so no plugin update, but the compatibility as indicated in install.xml still show only 7.9.* compatibility.
    To get an updated install.xml which had 8.* compatibility - plugin had to be uninstalled and reinstalled.

    This "install.xml" issue is true for many plugins which did not have a version update as there is no code change.
    That makes sense bpa thank you.
    But I don't see any maxVersion defined in the install.xml, only a minVersion, what am I missing here?

    root@xxxxx:/var/lib/squeezeboxserver/cache/InstalledPlugins/Plugins/WaveInput# ls -l
    total 32
    drwxr-xr-x 3 squeezeboxserver nogroup 60 Jan 8 19:20 HTML
    -rw-r--r-- 1 squeezeboxserver nogroup 1671 Oct 9 2009 Plugin.pm
    -rw-r--r-- 1 squeezeboxserver nogroup 2031 Oct 9 2009 Settings.pm
    -rw-r--r-- 1 squeezeboxserver nogroup 2293 Oct 9 2009 WAVIN.pm
    -rw-r--r-- 1 squeezeboxserver nogroup 355 Oct 12 2009 custom-convert.conf
    -rw-r--r-- 1 squeezeboxserver nogroup 478 Dec 17 2008 custom-convert.conf.eca
    -rw-r--r-- 1 squeezeboxserver nogroup 301 Jul 5 2008 custom-types.conf
    -rwxr--r-- 1 squeezeboxserver nogroup 652 Feb 27 2020 install.xml
    -rwxr--r-- 1 squeezeboxserver nogroup 538 Jul 18 2008 strings.txt
    root@xxxxx:/var/lib/squeezeboxserver/cache/InstalledPlugins/Plugins/WaveInput# cat install.xml
    <?xml version="1.0"?>

    <extension>
    <name>PLUGIN_WAVEINPUT</name>
    <module>Plugins::WaveInput::Plugin</module>
    <playerMenu>RADIO</playerMenu>
    <version>1.04</version>
    <description>PLUGIN_WAVEINPUT_DESC</description>
    <creator>bpa</creator>
    <defaultState>enabled</defaultState>
    <homepageURL></homepageURL>
    <optionsURL>plugins/WaveInput/settings/basic.html</optionsURL>
    <icon>plugins/WaveInput/html/images/waveinput.png</icon>
    <type>2</type><!-- type=extension -->
    <targetApplication>
    <id>Squeezecenter</id>
    <minVersion>7.3</minVersion>
    <maxVersion>*</maxVersion>
    </targetApplication>
    <targetPlatform>Linux</targetPlatform>

    </extension>

  4. #534
    Senior Member
    Join Date
    Oct 2005
    Location
    Ireland
    Posts
    20,768
    Quote Originally Posted by yas1 View Post
    But I don't see any maxVersion defined in the install.xml, only a minVersion, what am I missing here?
    <targetApplication>
    <id>Squeezecenter</id>
    <minVersion>7.3</minVersion>
    <maxVersion>*</maxVersion>
    IIRC The maxVersion used to be set to 7.* - I changed it to * which means no limit - if set to 8.* then when 9.0 came along same problem would arise.

    The original intent of the plugin update procedure (i.e. leave code installed that was not compatible) was to allow a user edit the install.xml manually to override the compatibility constraint. However in practice - some users had difficulties editing the file.

  5. #535
    Member
    Join Date
    Jan 2012
    Location
    Lyon
    Posts
    65
    Hi,

    In order to remove the use of line-in on my squeezebox boom, I undertook to install squeezelite with the wavinput plugin on my Ubuntu 20.04 workstation (i'm sorry but I haven't read all 53 pages of the forum).

    The plugin is installed and activated, I restarted my 8.0.0 server.

    I have bookmarked wavin:default on my squeezelite but it doesn't seem to work.

    Here are my server logs

    Code:
    21-03-14 21:37:22.6186] Slim::Player::Song::open (413) Error: Couldn't create command line for wavin playback for [wavin:default]
    What more can I do? Thank you for everything!
    8 SqueezeBox : 1 Touch, 1 Boom, 4 Radios, 1 PiCorePlayer on rPiA and 1 Max2Play with Jivelite on Odroid C1 with TouchScreen - LMS Server on Synology 116+ -

  6. #536
    Senior Member
    Join Date
    Oct 2005
    Location
    Ireland
    Posts
    20,768
    Quote Originally Posted by Bristow View Post
    What more can I do? Thank you for everything!
    Is the plugin successfully installed ?
    What version of the plugin is installed according to the WebUI Settings/Plugins page ?
    Do you have a File Format called WaveInput under WebUI Settings/Advanced/Filetypes and if so - what are the settings for FLAC, MP3 and PCM ?
    What is the output of "arecord -l" ? Is there a "default" device listed ?

  7. #537
    Member
    Join Date
    Jan 2012
    Location
    Lyon
    Posts
    65
    Quote Originally Posted by bpa View Post
    Is the plugin successfully installed ?
    What version of the plugin is installed according to the WebUI Settings/Plugins page ?
    I have 1.04

    Quote Originally Posted by bpa View Post
    Do you have a File Format called WaveInput under WebUI Settings/Advanced/Filetypes and if so - what are the settings for FLAC, MP3 and PCM ?
    Yes i have FLAC, MP3 and PCM but this is disabled and i can't change it

    Quote Originally Posted by bpa View Post
    What is the output of "arecord -l" ? Is there a "default" device listed ?
    I don't think so...

    Code:
    bristow@Desktop:~$ arecord -l
    **** Liste des Périphériques Matériels CAPTURE ****
    carte 0: PCH [HDA Intel PCH], périphérique 0: ALC898 Analog [ALC898 Analog]
      Sous-périphériques: 1/1
      Sous-périphérique #0: subdevice #0
    carte 0: PCH [HDA Intel PCH], périphérique 2: ALC898 Alt Analog [ALC898 Alt Analog]
      Sous-périphériques: 2/2
      Sous-périphérique #0: subdevice #0
      Sous-périphérique #1: subdevice #1
    Thanks for your help !
    8 SqueezeBox : 1 Touch, 1 Boom, 4 Radios, 1 PiCorePlayer on rPiA and 1 Max2Play with Jivelite on Odroid C1 with TouchScreen - LMS Server on Synology 116+ -

  8. #538
    Senior Member
    Join Date
    Oct 2005
    Location
    Ireland
    Posts
    20,768
    Quote Originally Posted by Bristow View Post
    Yes i have FLAC, MP3 and PCM but this is disabled and i can't change it
    Cant change because there is no executables that LMS can use.

    The entries should be
    Flac - arecord/flac
    MP3 - arecord/lame Thius will be disabled if you do not have "lame" installed
    PCM - arecord

    Since you have shown that "arecord" works on your system - then the problem is the permissions - the user id which is running LMS cannot find/execute the application arecord. This is strange. I have Ubuntu 20.04 and it is ok for me.

    Permission may also include groups. For example on some system the userid which is running LMS needs to be a member of the audio group so that it can access audio hardware although this depends on your audio hardware - which looks to be ordinary PC except for an odd additional subdevice.

  9. #539
    Member
    Join Date
    Jan 2012
    Location
    Lyon
    Posts
    65
    Thank you for this answer.

    I may have made a mistake.

    My LMS is on my Synology NAS and I ran `arecord -l` on my Ubuntu 20.04 workstation (squeezelite) and I want to send the sound to my Squeezebox Boom.

    If I run arecord -l on the nas, I get this:
    Code:
    root@Nas:~# arecord -l
    -ash: arecord: command not found
    8 SqueezeBox : 1 Touch, 1 Boom, 4 Radios, 1 PiCorePlayer on rPiA and 1 Max2Play with Jivelite on Odroid C1 with TouchScreen - LMS Server on Synology 116+ -

  10. #540
    Senior Member
    Join Date
    Apr 2005
    Location
    UK/London
    Posts
    4,556
    Ah ... for the plugin to work I think it has to be on the same system as LMS.

    However, I expect there is a way to achieve the same outcome.

    bpa might have a quick answer while I go away to think again.
    Paul Webster
    http://dabdig.blogspot.com
    Author of "Now Playing" plugins covering Radio France (FIP etc), PlanetRadio (Bauer - Kiss, Absolute, Scala, JazzFM etc), KCRW, Supla Finland, ABC Australia, CBC/Radio-Canada and RTE Ireland

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •