Home of the Squeezebox™ & Transporter® network music players.
Page 195 of 199 FirstFirst ... 95145185193194195196197 ... LastLast
Results 1,941 to 1,950 of 1988
  1. #1941
    Senior Member erland's Avatar
    Join Date
    Dec 2005
    Location
    Sweden
    Posts
    11,285
    Quote Originally Posted by SlimChances View Post
    This is a bit over my head Erland but I ran a Free Form Query and get this result, does that tell us anything?
    Yes, it says that you have two libraries with id 5 and 6, would be interesting to see if the ids changes if you run it again after you upgrade LMS or does something that trigger the playlist library parameter to be reset.
    Erland Isaksson (My homepage)
    Developer of many plugins/applets
    Starting with LMS 8.0 I no longer support my plugins/applets (see here for more information )

  2. #1942
    Senior Member
    Join Date
    Nov 2010
    Location
    Hertfordshire, UK
    Posts
    3,244
    Quote Originally Posted by erland View Post
    Yes, it says that you have two libraries with id 5 and 6, would be interesting to see if the ids changes if you run it again after you upgrade LMS or does something that trigger the playlist library parameter to be reset.
    I have, on very rare occasions (I think only when completely resetting LMS), seen the id numbers increase, and rather than rescanning I have changed the ids back to where they were (1 and 2 on my system).
    LMS 8.1 on PC, Xubuntu 20.04, FLACs 16->24 bit, 44.1->192kbps. 2 Touches & EDO.
    LMS plugin UPnP/DLNA Bridge to MF M1 CLiC (A308CR amp & ESLs) & Marantz CR603 UPnP renderers.
    Also Minimserver & Upplay to same & to upmpdcli/mpd PC renderers.
    Squeezelite to Meridian USB Explorer DAC to PC speakers/headphones.
    Wireless Xubuntu 20.04 laptop firefox/upplay or Android mobile with Squeeze-Ctrl/BubbleUPnP controls LMS/Minimserver.

  3. #1943
    Senior Member SlimChances's Avatar
    Join Date
    Apr 2005
    Posts
    1,761
    Quote Originally Posted by PasTim View Post
    I have, on very rare occasions (I think only when completely resetting LMS), seen the id numbers increase, and rather than rescanning I have changed the ids back to where they were (1 and 2 on my system).
    Thanks, changing those ids might be easier for me, do I find them somewhere in prefs folder. I looked at server.prefs and multilibrary.prefs but not sure where to make any changes if that is possible


    EDIT: In multilibrary.prefs I see references to activelibraryno: 1 and 2, 3,4,5
    Attached Images Attached Images  
    Last edited by SlimChances; 2021-03-03 at 06:14.
    Logitech Media Server Version: 8.2.0 - 1614639334 @ Tue Mar 2 00:11:57 CET 2021
    Operating system: Debian - EN - utf8
    Platform Architecture: x86_64-linux
    Perl Version: 5.30.0 - x86_64-linux-gnu-thread-multi
    IO::Socket::SSL: 2.067
    Database Version: DBD::SQLite 1.58 (sqlite 3.22.0)

    One SB Touch connected by Ethernet - Denon AVR -1912 Receiver, Paradigm 4.1 speakers
    SB Touch connected by Optical to Sabaj A4
    amp and Energy bookshelf speakers
    Two SB Radios wireless

  4. #1944
    Senior Member SpiderJon's Avatar
    Join Date
    Dec 2008
    Location
    Cardiff, Wales, UK
    Posts
    202

    CustomScan - possible problems?

    In my server log, I routinely get the following entries relating to CustomScan:

    [21-03-03 14:47:46.8312] Plugins::CustomScan::Scanner::initDatabase (114) CustomScan: Creating database tables
    [21-03-03 14:47:46.8336] Plugins::CustomScan::Scanner::initDatabase (119) CustomScan: Upgrading database adding table column valuesort, please wait...
    [21-03-03 14:47:46.8342] Plugins::CustomScan::Scanner::executeSQLFile (522) Couldn't open: /var/lib/squeezeboxserver/cache/InstalledPlugins/Plugins/CustomScan/SQL/SQLite/dbupgrade_valuesort.sql : No such file or directory
    [21-03-03 14:47:46.8347] Plugins::CustomScan::Scanner::initDatabase (125) CustomScan: Upgrading database adding table column extravalue, please wait...
    [21-03-03 14:47:46.8352] Plugins::CustomScan::Scanner::executeSQLFile (522) Couldn't open: /var/lib/squeezeboxserver/cache/InstalledPlugins/Plugins/CustomScan/SQL/SQLite/dbupgrade_extravalue.sql : No such file or directory
    [21-03-03 14:47:46.8357] Plugins::CustomScan::Scanner::initDatabase (131) CustomScan: Upgrading database adding table column valuetype, please wait...
    [21-03-03 14:47:46.8361] Plugins::CustomScan::Scanner::executeSQLFile (522) Couldn't open: /var/lib/squeezeboxserver/cache/InstalledPlugins/Plugins/CustomScan/SQL/SQLite/dbupgrade_valuetype.sql : No such file or directory

    Two questions:

    1. Are they something I should worry/do something about?

    2. If they are, what should I do? :-)
    Duet x 3, via various hi-fi. LMS on Raspberry Pi OS (Debian 10) on a Pi4.

  5. #1945
    Senior Member
    Join Date
    Nov 2010
    Location
    Hertfordshire, UK
    Posts
    3,244
    Quote Originally Posted by SlimChances View Post
    Thanks, changing those ids might be easier for me, do I find them somewhere in prefs folder. I looked at server.prefs and multilibrary.prefs but not sure where to make any changes if that is possible


    EDIT: In multilibrary.prefs I see references to activelibraryno: 1 and 2, 3,4,5
    I'm afraid not. To change the ids you have to change data in the database, not in the prefs. If you are not familiar with SQL that might take a bit of learning to do. I shut LMS down and use an SQLite tool to change the values in table multilibrary_libraries, but there are several possible pitfalls in that approach, not least other related tables. Erland might have some ideas.
    LMS 8.1 on PC, Xubuntu 20.04, FLACs 16->24 bit, 44.1->192kbps. 2 Touches & EDO.
    LMS plugin UPnP/DLNA Bridge to MF M1 CLiC (A308CR amp & ESLs) & Marantz CR603 UPnP renderers.
    Also Minimserver & Upplay to same & to upmpdcli/mpd PC renderers.
    Squeezelite to Meridian USB Explorer DAC to PC speakers/headphones.
    Wireless Xubuntu 20.04 laptop firefox/upplay or Android mobile with Squeeze-Ctrl/BubbleUPnP controls LMS/Minimserver.

  6. #1946
    Senior Member SlimChances's Avatar
    Join Date
    Apr 2005
    Posts
    1,761
    Quote Originally Posted by PasTim View Post
    I'm afraid not. To change the ids you have to change data in the database, not in the prefs. If you are not familiar with SQL that might take a bit of learning to do. I shut LMS down and use an SQLite tool to change the values in table multilibrary_libraries, but there are several possible pitfalls in that approach, not least other related tables. Erland might have some ideas.
    Hmm...It is getting a bit past my skill set so I will just reset the library values as I have in the past
    Logitech Media Server Version: 8.2.0 - 1614639334 @ Tue Mar 2 00:11:57 CET 2021
    Operating system: Debian - EN - utf8
    Platform Architecture: x86_64-linux
    Perl Version: 5.30.0 - x86_64-linux-gnu-thread-multi
    IO::Socket::SSL: 2.067
    Database Version: DBD::SQLite 1.58 (sqlite 3.22.0)

    One SB Touch connected by Ethernet - Denon AVR -1912 Receiver, Paradigm 4.1 speakers
    SB Touch connected by Optical to Sabaj A4
    amp and Energy bookshelf speakers
    Two SB Radios wireless

  7. #1947
    Senior Member
    Join Date
    Nov 2010
    Location
    Hertfordshire, UK
    Posts
    3,244
    Quote Originally Posted by SlimChances View Post
    Hmm...It is getting a bit past my skill set so I will just reset the library values as I have in the past
    It is still a mystery why this happens for you. When you do LMS updates do you just install the deb, and do nothing else (not even a rescan)? That's what I've done for years, and hardly ever had a problem.
    LMS 8.1 on PC, Xubuntu 20.04, FLACs 16->24 bit, 44.1->192kbps. 2 Touches & EDO.
    LMS plugin UPnP/DLNA Bridge to MF M1 CLiC (A308CR amp & ESLs) & Marantz CR603 UPnP renderers.
    Also Minimserver & Upplay to same & to upmpdcli/mpd PC renderers.
    Squeezelite to Meridian USB Explorer DAC to PC speakers/headphones.
    Wireless Xubuntu 20.04 laptop firefox/upplay or Android mobile with Squeeze-Ctrl/BubbleUPnP controls LMS/Minimserver.

  8. #1948
    Senior Member SlimChances's Avatar
    Join Date
    Apr 2005
    Posts
    1,761
    Quote Originally Posted by PasTim View Post
    It is still a mystery why this happens for you. When you do LMS updates do you just install the deb, and do nothing else (not even a rescan)? That's what I've done for years, and hardly ever had a problem.
    I download the LMS. I stop the server. And then install through gdebi the amd64.deb version. Then restart server. Everything is in order after the upgrade except the multilibrary designations which are often although not always blank on the settings pages. I reset those through SQL Playlist if need be.

    EDIT: I just upgraded to the latest LMS 8.2 to see what would happen. All settings including multilibrary settings were retained so there is no way to show the problem occurring right now
    Last edited by SlimChances; 2021-03-04 at 05:48.
    Logitech Media Server Version: 8.2.0 - 1614639334 @ Tue Mar 2 00:11:57 CET 2021
    Operating system: Debian - EN - utf8
    Platform Architecture: x86_64-linux
    Perl Version: 5.30.0 - x86_64-linux-gnu-thread-multi
    IO::Socket::SSL: 2.067
    Database Version: DBD::SQLite 1.58 (sqlite 3.22.0)

    One SB Touch connected by Ethernet - Denon AVR -1912 Receiver, Paradigm 4.1 speakers
    SB Touch connected by Optical to Sabaj A4
    amp and Energy bookshelf speakers
    Two SB Radios wireless

  9. #1949
    Senior Member
    Join Date
    Nov 2010
    Location
    Hertfordshire, UK
    Posts
    3,244
    Quote Originally Posted by SlimChances View Post
    I download the LMS. I stop the server. And then install through gdebi the amd64.deb version. Then restart server. Everything is in order after the upgrade except the multilibrary designations which are often although not always blank on the settings pages. I reset those through SQL Playlist if need be.

    EDIT: I just upgraded to the latest LMS 8.2 to see what would happen. All settings including multilibrary settings were retained so there is no way to show the problem occurring right now
    I hope the trend continues!
    LMS 8.1 on PC, Xubuntu 20.04, FLACs 16->24 bit, 44.1->192kbps. 2 Touches & EDO.
    LMS plugin UPnP/DLNA Bridge to MF M1 CLiC (A308CR amp & ESLs) & Marantz CR603 UPnP renderers.
    Also Minimserver & Upplay to same & to upmpdcli/mpd PC renderers.
    Squeezelite to Meridian USB Explorer DAC to PC speakers/headphones.
    Wireless Xubuntu 20.04 laptop firefox/upplay or Android mobile with Squeeze-Ctrl/BubbleUPnP controls LMS/Minimserver.

  10. #1950
    Senior Member SlimChances's Avatar
    Join Date
    Apr 2005
    Posts
    1,761
    Indeed
    Logitech Media Server Version: 8.2.0 - 1614639334 @ Tue Mar 2 00:11:57 CET 2021
    Operating system: Debian - EN - utf8
    Platform Architecture: x86_64-linux
    Perl Version: 5.30.0 - x86_64-linux-gnu-thread-multi
    IO::Socket::SSL: 2.067
    Database Version: DBD::SQLite 1.58 (sqlite 3.22.0)

    One SB Touch connected by Ethernet - Denon AVR -1912 Receiver, Paradigm 4.1 speakers
    SB Touch connected by Optical to Sabaj A4
    amp and Energy bookshelf speakers
    Two SB Radios wireless

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •