Home of the Squeezebox™ & Transporter® network music players.
Page 193 of 193 FirstFirst ... 93143183191192193
Results 1,921 to 1,926 of 1926
  1. #1921
    Senior Member
    Join Date
    Mar 2017
    Posts
    2,593
    Quote Originally Posted by jeroen2 View Post
    That seems useful, but then when you select a library on the homescreen what screen would follow? A revised homescreen? Or "my music" for that library?



    Would that selection then remain throughout the whole session/interface?

    In that case it would work like this right?
    1/ Create a Library for topgenre, selecting a number of subgenres.
    2/ Click "pin to homescreen" on genres, with the option to save library ID above.
    3/ Rename "genres" on homescreen to name of topgenre.
    4/ Repeat for all topgenres.

    (I think this might run into trouble though when you get to step 4, because genre (linked with the other library ID) is already pinned, so it would only show the option to remove, not?)
    This belongs in the MaterialSkin thread - I'll answer there.
    Material debug: 1. Launch via http: //SERVER:9000/material/?debug=json (Use http: //SERVER:9000/material/?debug=json,cometd to also see update messages, e.g. play queue) 2. Open browser's developer tools 3. Open console tab in developer tools 4. REQ/RESP messages sent to/from LMS will be logged here.

  2. #1922
    Senior Member
    Join Date
    Nov 2010
    Location
    Hertfordshire, UK
    Posts
    3,222
    Quote Originally Posted by erland View Post
    Michael have now added the Multi Library plugin to the unsupported repository so it can be installed if you use 8.1 and activate unsupported extensions in LMS Settings/Plugins. His responses to this thread keeps ending up in an old thread due to some bug in the forum mail gateway so I thought Iĺd mention it here also. However, as I previously said, Iĺd recommend everyone using Multi Library to try if the built-in virtual library functionality fulfill your needs.
    Thanks for your advice Erland. I'll take a look at the SQL, and try to understand how it works. Currently I don't even seem to be able get it to work in normal menus using the default skin, but I probably haven't tried hard enough. If I need help I'll start a new thread.
    LMS 8.1 on PC, Xubuntu 20.04, FLACs 16->24 bit, 44.1->192kbps. 2 Touches & EDO.
    LMS plugin UPnP/DLNA Bridge to MF M1 CLiC (A308CR amp & ESLs) & Marantz CR603 UPnP renderers.
    Also Minimserver & Upplay to same & to upmpdcli/mpd PC renderers.
    Squeezelite to Meridian USB Explorer DAC to PC speakers/headphones.
    Wireless Xubuntu 20.04 laptop firefox/upplay or Android mobile with Squeeze-Ctrl/BubbleUPnP controls LMS/Minimserver.

  3. #1923
    Senior Member SlimChances's Avatar
    Join Date
    Apr 2005
    Posts
    1,741
    I have been using Custom Browse for several years including installs with LMS 8 and 8.1 sucessfully. I now find that a number (most) of the menus do not return any results. These include album,artist,genre, new artist, new album. menus that do get results are year and playlist. I know that the plugin is not supported as it once was but I was hoping to get a bit more use from it. My last attempt to correct this issue was to upgrade to LMS 8.2 as it has better support for Erland's plugins. Also not working quite right is Trackstat which just returns and empty screen when selected but I still appear to have tracks with ratings. Everything was working a short time ago, not quite sure what has changed.
    Logitech Media Server Version: 8.0.1 - 1606928904 @ Thu Dec 3 01:21:23 CET 2020
    Operating system: Debian - EN - utf8
    Platform Architecture: x86_64-linux
    Perl Version: 5.30.0 - x86_64-linux-gnu-thread-multi
    IO::Socket::SSL: 2.067
    Database Version: DBD::SQLite 1.58 (sqlite 3.22.0)

    One SB Touch connected by Ethernet - Denon AVR -1912 Receiver, Paradigm 4.1 speakers
    SB Touch connected by Optical to Sabaj A4
    amp and Energy bookshelf speakers
    Two SB Radios wireless

  4. #1924
    Senior Member erland's Avatar
    Join Date
    Dec 2005
    Location
    Sweden
    Posts
    11,242
    Quote Originally Posted by SlimChances View Post
    I have been using Custom Browse for several years including installs with LMS 8 and 8.1 sucessfully. I now find that a number (most) of the menus do not return any results. These include album,artist,genre, new artist, new album. menus that do get results are year and playlist. I know that the plugin is not supported as it once was but I was hoping to get a bit more use from it. My last attempt to correct this issue was to upgrade to LMS 8.2 as it has better support for Erland's plugins. Also not working quite right is Trackstat which just returns and empty screen when selected but I still appear to have tracks with ratings. Everything was working a short time ago, not quite sure what has changed.
    Any errors in server.log file ?
    Erland Isaksson (My homepage)
    Developer of many plugins/applets
    Starting with LMS 8.0 I no longer support my plugins/applets (see here for more information )

  5. #1925
    Senior Member SlimChances's Avatar
    Join Date
    Apr 2005
    Posts
    1,741
    Code:
    [21-02-07 16:21:53.5357] Slim::Utils::Misc::msg (1283) Warning: [16:21:53.5355] Negative repeat count does nothing at /var/lib/squeezeboxserver/cache/InstalledPlugins/Plugins/TrackStat/Plugin.pm line 5127.[21-02-07 16:21:53.5448] Slim::Utils::Misc::msg (1283) Warning: [16:21:53.5447] Negative repeat count does nothing at /var/lib/squeezeboxserver/cache/InstalledPlugins/Plugins/TrackStat/Plugin.pm line 5127.
    [21-02-07 16:21:53.8889] Slim::Utils::Misc::msg (1283) Warning: [16:21:53.8887] Negative repeat count does nothing at /var/lib/squeezeboxserver/cache/InstalledPlugins/Plugins/TrackStat/Plugin.pm line 5127.
    [21-02-07 16:27:00.7960] main::init (389) Starting Logitech Media Server (v8.2.0, 1612703157, Sun Feb  7 14:44:35 CET 2021) perl 5.030000 - x86_64-linux-gnu-thread-multi
    [21-02-07 16:27:00.9222] Slim::Utils::Misc::msg (1283) Warning: [16:27:00.9220] DBIx::Class::ResultSet::update_or_create(): Query returned more than one row.  SQL that returns multiple rows is DEPRECATED for ->find and ->single at /usr/share/perl5/Slim/Schema.pm line 1905
    [21-02-07 16:27:01.8089] Plugins::CustomScan::Scanner::executeSQLFile (522) Couldn't open: /var/lib/squeezeboxserver/cache/InstalledPlugins/Plugins/CustomScan/SQL/SQLite/dbupgrade_valuesort.sql : No such file or directory
    [21-02-07 16:27:01.8091] Plugins::CustomScan::Scanner::executeSQLFile (522) Couldn't open: /var/lib/squeezeboxserver/cache/InstalledPlugins/Plugins/CustomScan/SQL/SQLite/dbupgrade_extravalue.sql : No such file or directory
    [21-02-07 16:27:01.8093] Plugins::CustomScan::Scanner::executeSQLFile (522) Couldn't open: /var/lib/squeezeboxserver/cache/InstalledPlugins/Plugins/CustomScan/SQL/SQLite/dbupgrade_valuetype.sql : No such file or directory
    [21-02-07 16:27:02.2369] Slim::Utils::Misc::msg (1283) Warning: [16:27:02.2367] write_file '/media/Music/Flac/Artist Pictures/artist.png.missing' - sysopen: No such file or directory at /var/lib/squeezeboxserver/cache/InstalledPlugins/Plugins/MusicArtistInfo/LocalArtwork.pm line 62.
    [21-02-07 16:27:09.6752] Slim::Utils::Misc::msg (1283) Warning: [16:27:09.6748] Negative repeat count does nothing at /var/lib/squeezeboxserver/cache/InstalledPlugins/Plugins/TrackStat/Plugin.pm line 5127.
    I don't think I need Custom Scan , perhaps if I remove that it would help. I think I added that plugin very recently
    .....
    EDIT: removing Custom Scan didn't help(rescanned library after I removved it)
    Last edited by SlimChances; 2021-02-07 at 14:42.
    Logitech Media Server Version: 8.0.1 - 1606928904 @ Thu Dec 3 01:21:23 CET 2020
    Operating system: Debian - EN - utf8
    Platform Architecture: x86_64-linux
    Perl Version: 5.30.0 - x86_64-linux-gnu-thread-multi
    IO::Socket::SSL: 2.067
    Database Version: DBD::SQLite 1.58 (sqlite 3.22.0)

    One SB Touch connected by Ethernet - Denon AVR -1912 Receiver, Paradigm 4.1 speakers
    SB Touch connected by Optical to Sabaj A4
    amp and Energy bookshelf speakers
    Two SB Radios wireless

  6. #1926
    Senior Member SlimChances's Avatar
    Join Date
    Apr 2005
    Posts
    1,741
    Problem solved. I havve had this problem frequenty happening with Dynamic Playlists when I updated LMS to a newer version; the setting for library (I have multi library installed) gets deleted and I have to reset it in SQL Playlists. This time it happened in my Custom Browse menu settings. I went into Custom Browse settings and opened Manage Menus and clicked on the menus to adjust the library setting.
    Attached Images Attached Images  
    Logitech Media Server Version: 8.0.1 - 1606928904 @ Thu Dec 3 01:21:23 CET 2020
    Operating system: Debian - EN - utf8
    Platform Architecture: x86_64-linux
    Perl Version: 5.30.0 - x86_64-linux-gnu-thread-multi
    IO::Socket::SSL: 2.067
    Database Version: DBD::SQLite 1.58 (sqlite 3.22.0)

    One SB Touch connected by Ethernet - Denon AVR -1912 Receiver, Paradigm 4.1 speakers
    SB Touch connected by Optical to Sabaj A4
    amp and Energy bookshelf speakers
    Two SB Radios wireless

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •