Home of the Squeezebox™ & Transporter® network music players.
Page 186 of 200 FirstFirst ... 86136176184185186187188196 ... LastLast
Results 1,851 to 1,860 of 1995
  1. #1851
    Senior Member erland's Avatar
    Join Date
    Dec 2005
    Location
    Sweden
    Posts
    11,293
    Quote Originally Posted by PasTim View Post
    Thanks very much.

    I wonder whether Erland might want to put a consolidated list of plugins that seem OK under LMS 8 (even though not yet verified by him) in the first post of this thread, for everyone's benefit?
    Quote Originally Posted by PasTim View Post
    I think it might be a good idea to ask Michael. I'd be happy with either approach, but I could well understand it if Michael doesn't want relatively untested plugins available as standard.

    The cautious approach would be a separate repo (a beta) which people would have to explicitly include. That might also help you if/as/when you get around to test them yourself and want to try a few fixes.

    As to what to include, I'd be a bit go-for-it and include all except the ones you have been told don't work.
    Please continue to report which of my plugins that works/doesnít work in this thread but letís continue the discussion how to indicate whatís working to the thread I started earlier in the year in the developers section, itís a generic problem and not only related to my plugins:
    https://forums.slimdevices.com/showt...l=1#post998387

    I donít want to manage a list of working plugins myself since I think this is a generic problem for all plugins that arenít actively supported.
    Erland Isaksson (My homepage)
    Developer of many plugins/applets
    Starting with LMS 8.0 I no longer support my plugins/applets (see here for more information )

  2. #1852
    Senior Member
    Join Date
    Nov 2010
    Location
    Hertfordshire, UK
    Posts
    3,255
    Quote Originally Posted by erland View Post
    Where did you find the non working link ?
    A bookmark. I've probably had it for years. No problem.
    LMS 8.1 on PC, Xubuntu 20.04, FLACs 16->24 bit, 44.1->192kbps. 2 Touches & EDO.
    LMS plugin UPnP/DLNA Bridge to MF M1 CLiC (A308CR amp & ESLs) & Marantz CR603 UPnP renderers.
    Also Minimserver & Upplay to same & to upmpdcli/mpd PC renderers.
    Squeezelite to Meridian USB Explorer DAC to PC speakers/headphones.
    Wireless Xubuntu 20.04 laptop firefox/upplay or Android mobile with Squeeze-Ctrl/BubbleUPnP controls LMS/Minimserver.

  3. #1853
    Senior Member
    Join Date
    Feb 2010
    Posts
    358
    Just want to mention a slight upgrade issue that does not have to do with LMS versions. If you are moving from a very old perl to a newer one, the URI::Escape module changed its encoding strategy in 2010, so trackstat backups written from very old versions of perl will not be read correctly by a new version of perl. I ran into this when migrating of ReadyNAS as described in this thread. I am trying to recover my trackstat history by diffing the backups on both versions and editing accordingly.

  4. #1854
    Senior Member
    Join Date
    Nov 2010
    Location
    Hertfordshire, UK
    Posts
    3,255
    I have now made the shift to the 8.0.1. Done a full rescan, and all OK so far, including the latest versions of:

    Custom Browse
    Custom Clock Helper
    Custom Scan
    Dynamic Playlists
    Multi-Library
    SQL Playlist
    Trackstat (I think - I haven't checked many of the options)

    Having also changed to Material Skin, I'm still figuring out the options and menus. I'm not sure Hide Menus works.
    LMS 8.1 on PC, Xubuntu 20.04, FLACs 16->24 bit, 44.1->192kbps. 2 Touches & EDO.
    LMS plugin UPnP/DLNA Bridge to MF M1 CLiC (A308CR amp & ESLs) & Marantz CR603 UPnP renderers.
    Also Minimserver & Upplay to same & to upmpdcli/mpd PC renderers.
    Squeezelite to Meridian USB Explorer DAC to PC speakers/headphones.
    Wireless Xubuntu 20.04 laptop firefox/upplay or Android mobile with Squeeze-Ctrl/BubbleUPnP controls LMS/Minimserver.

  5. #1855
    Senior Member
    Join Date
    Apr 2007
    Posts
    289
    Quote Originally Posted by PasTim View Post
    Custom Browse
    Custom Clock Helper
    Custom Scan
    Dynamic Playlists
    Multi-Library
    SQL Playlist
    Trackstat (I think - I haven't checked many of the options)

    I'm not sure Hide Menus works.
    That is extremely encouraging as I also use all of these plugins from Erland. I donít use any steaming services nor are there any other 8.0 features that I need. Regardless, I like my LMS version to stay relatively current. But if these plugins didnít work in 8.0+, especially TrackStat, I would stay on 7.9.4 forever.

  6. #1856
    Senior Member
    Join Date
    Nov 2010
    Location
    Hertfordshire, UK
    Posts
    3,255
    Quote Originally Posted by prabbit View Post
    That is extremely encouraging as I also use all of these plugins from Erland. I donít use any steaming services nor are there any other 8.0 features that I need. Regardless, I like my LMS version to stay relatively current. But if these plugins didnít work in 8.0+, especially TrackStat, I would stay on 7.9.4 forever.
    The main issue for me would be if there are underlying changes, like SSL or Perl version changes, that might cause problems with other plugins (eg some BBC ones). Since I learned that 7.9.4 is no longer being maintained at all, moving forward might then be the only option. Given nothing much else to do right now in these strange times I decided it was a good time to take the plunge and see what happened.
    LMS 8.1 on PC, Xubuntu 20.04, FLACs 16->24 bit, 44.1->192kbps. 2 Touches & EDO.
    LMS plugin UPnP/DLNA Bridge to MF M1 CLiC (A308CR amp & ESLs) & Marantz CR603 UPnP renderers.
    Also Minimserver & Upplay to same & to upmpdcli/mpd PC renderers.
    Squeezelite to Meridian USB Explorer DAC to PC speakers/headphones.
    Wireless Xubuntu 20.04 laptop firefox/upplay or Android mobile with Squeeze-Ctrl/BubbleUPnP controls LMS/Minimserver.

  7. #1857
    Senior Member
    Join Date
    Oct 2005
    Location
    Ireland
    Posts
    20,562
    Quote Originally Posted by prabbit View Post
    But if these plugins didnít work in 8.0+, especially TrackStat, I would stay on 7.9.4 forever.
    Plugins needs maintenance. The plugins currently work with 8.0.* and at the moment 8.1.*. No guarantees.
    As the plugins have some interaction with a key component - the database, there is a chance that this will break in the future due to revisions.
    I think it would be better to plan your migration from unsupported plugins and not risk getting stuck with no service at some point in the near future.

  8. #1858
    Senior Member erland's Avatar
    Join Date
    Dec 2005
    Location
    Sweden
    Posts
    11,293
    I totally agree with you bpa, even if they work currently it’s just a matter of time until something breaks.

    I wish I had the focus and time to be able to continue maintaining the plugins but to be brutally realistic it’s very unlikely to happen. My family situation is different today with a small kid in the house and my music listening behavior has changed significantly to mostly using streaming services (Spotify) and currently I’ve honestly barely any need for my plugins myself. It’s hard to let all people down who have used my plugins and I’ve had some hope to be able to do some minimal maintenance, but to be realistic this is very unlikely to happen.

    Due to all this I’ve also decided to leave my repository files as they are with maxTarget=7.*.
    If some one wants to maintain a separate repository file with minTarget=8.0.0 pointing at my or your own server feel free to do so, but in this case please put it under your e-mail/name instead of mine so people primarily contact you instead of me if they have problem with LMS 8.0 or later.

    For people relying on my plugins this means that you have the current options:

    - Stay on LMS 7.* forever. In this case you are probably going to loose streaming services over time since they tend to change and will probably stop working on 7.* eventually. Upgrading the OS is obviously very risky since 7.* is eventually going to stop working on latest OS versions. This might be an alternative if you are only using local music and have LMS installed on a computer/device that isn’t used for anything else.

    - If you have development skills or is willing to learn, implement new plugins with similar functionality as mine and support them on LMS 8.0 and later. Based on some discussions in the forum I think there might already be some work going on in this direction related to ratings and browsing by custom tags. Alternatively take over maintenance of my plugins, but I honestly expect this to be harder and more boring. It’s always easier to maintain code you have written yourself. I had zero Perl knowledge when I started to implement TrackStat so don’t look at it as an impossible task just because you haven’t developed in Perl before.

    - Install my plugins manually in 8.0 and enjoy them as long as they work, but as indicated it’s just a matter of time until something breaks so you should probably plan for that so your setup doesn’t become unusable when it happens. In LMS 8.1 (or later) it’s possible to install some of them if unsupported plugins have been activated in LMS Settings/Plugins, but please note that they might not work or it’s just a matter of time until something breaks them.

    For my personal setup I think the most likely scenario is that I’ll continue using 7.8 on short terms and switch to 8.* without most of my plugins installed on longer terms.

    I still plan to continue being a member in this community, so this post doesn’t mean I’ll disappear from the community.

    To everyone using my plugins, sorry to let you down but hopefully most of you will understand. Thanks for all positive feedback you have given me over the years.
    Last edited by erland; 2021-01-02 at 12:10. Reason: Added info about unsupported plugins in 8.1
    Erland Isaksson (My homepage)
    Developer of many plugins/applets
    Starting with LMS 8.0 I no longer support my plugins/applets (see here for more information )

  9. #1859
    Senior Member
    Join Date
    Nov 2010
    Location
    Hertfordshire, UK
    Posts
    3,255
    Quote Originally Posted by erland View Post
    I totally agree with you bpa, even if they work currently itís just a matter of time until something breaks.

    I wish I had the focus and time to be able to continue maintaining the plugins but to be brutally realistic itís very unlikely to happen. My family situation is different today with a small kid in the house and my music listening behavior has changed significantly to mostly using streaming services (Spotify) and currently Iíve honestly barely any need for my plugins myself. Itís hard to let all people down who have used my plugins and Iíve had some hope to be able to do some minimal maintenance, but to be realistic this is very unlikely to happen.

    Due to all this Iíve also decided to leave my repository files as they are with maxTarget=7.*.
    If some one wants to maintain a separate repository file with minTarget=8.0.0 pointing at my or your own server feel free to do so, but in this case please put it under your e-mail/name instead of mine so people primarily contact you instead of me if they have problem with LMS 8.0 or later.

    For people relying on my plugins this means that you have the current options:

    - Stay on LMS 7.* forever. In this case you are probably going to loose streaming services over time since they tend to change and will probably stop working on 7.* eventually. Upgrading the OS is obviously very risky since 7.* is eventually going to stop working on latest OS versions. This might be an alternative if you are only using local music and have LMS installed on a computer/device that isnít used for anything else.

    - If you have development skills or is willing to learn, implement new plugins with similar functionality as mine and support them on LMS 8.0 and later. Based on some discussions in the forum I think there might already be some work going on in this direction related to ratings and browsing by custom tags. Alternatively take over maintenance of my plugins, but I honestly expect this to be harder and more boring. Itís always easier to maintain code you have written yourself. I had zero Perl knowledge when I started to implement TrackStat so donít look at it as an impossible task just because you havenít developed in Perl before.

    - Install my plugins manually in 8.0 and enjoy them as long as they work, but as indicated itís just a matter of time until something breaks so you should probably plan for that so your setup doesnít become unusable when it happens.

    For my personal setup I think the most likely scenario is that Iíll continue using 7.8 on short terms and switch to 8.* without most of my plugins installed on longer terms.

    I still plan to continue being a member in this community, so this post doesnít mean Iíll disappear from the community.

    To everyone using my plugins, sorry to let you down but hopefully most of you will understand. Thanks for all positive feedback you have given me over the years.
    LMS 8.1 on PC, Xubuntu 20.04, FLACs 16->24 bit, 44.1->192kbps. 2 Touches & EDO.
    LMS plugin UPnP/DLNA Bridge to MF M1 CLiC (A308CR amp & ESLs) & Marantz CR603 UPnP renderers.
    Also Minimserver & Upplay to same & to upmpdcli/mpd PC renderers.
    Squeezelite to Meridian USB Explorer DAC to PC speakers/headphones.
    Wireless Xubuntu 20.04 laptop firefox/upplay or Android mobile with Squeeze-Ctrl/BubbleUPnP controls LMS/Minimserver.

  10. #1860
    Senior Member
    Join Date
    Feb 2010
    Posts
    358
    I really appreciate all the plugins you built, Erland, and completely respect your choice to step back. Still, I don't want to see the plugins fade away. I would be willing to "stick a toe in the water" and try maintaining the simple, useful, and relatively stable, DBQuery plugin. If that works out, I'd consider adopting more. If I have to make any changes, I would then create a fork, so I can keep any headaches out of your hair.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •