Home of the Squeezebox™ & Transporter® network music players.
Results 1 to 4 of 4
  1. #1
    Senior Member mr-b's Avatar
    Join Date
    Feb 2007
    Location
    UK
    Posts
    531

    Scan status says "finished" - but is still "Running"

    Hi

    On SC7.0 on Vista, the Status tab shows that the library scan has finished:

    "SqueezeCenter has finished scanning your music collection.06:08:50"

    but the details indicate that the Merge Various Artists part is still running e.g.

    "Merge Various Artists (233 of 1905) Running 05:38:01"

    SC is set to clean and rescan nightly and the Merge VA progress number changes each time with no files added/changed.

    The scanner.log just has a couple of entries (undated):

    frame 1: Slim::Schema::throw_exception (/<C:\PROGRA~1\SQUEEZ~1\server\scanner.exe>DBIx/Class/Schema.pm line 606)
    frame 2: DBIx::Class::Schema::txn_do (scanner.pl line 216)
    frame 3: (eval) (scanner.pl line 216)
    frame 4: main::main (scanner.pl line 345)


    Any ideas what is wrong?

  2. #2
    Senior Member mr-b's Avatar
    Join Date
    Feb 2007
    Location
    UK
    Posts
    531
    I just discovered the root cause of the scanning problem - I disabled the McAfee on-access virus scanner and the scan now completes successfully (including Artwork Scan and DB optimisation).

    Directory Scan (22200 of 22200) Complete 00:26:29
    Playlist Scan (1 of 1) Complete 00:00:00
    Merge Various Artists (1910 of 1910) Complete 00:00:58
    Artwork Scan (2065 of 2065) Complete 00:04:22
    Database Optimize ( of ) Complete 00:00:24
    SqueezeCenter has finished scanning your music collection. Total Time:00:32:13

    The issue now is that I can't seem to exclude my music folder from the scanner. :-(
    Can anyone recommend one that works with SC?

  3. #3
    Senior Member radish's Avatar
    Join Date
    Apr 2005
    Location
    Red Bank, NJ
    Posts
    5,052
    There's a thread just below discussing anti-virus, I (and several others) recommended NOD32.

  4. #4
    Yes, I was experiencing similar behaviour before Ś it was due to McAfee VirusScan preventing SqueezeCenter from writing certain files to disk.

    As you discovered by disabling it, VirusScan is the culprit. To solve this problem, I set my it to scan executables and documents only. Alternatively, you can tell McAffee to ignore MYI file extensions.

    From the VirusScan Console: "All Processes > Detection > Exclusions > Add".

    Type in the file extensions, ie MYI, and you are good to go. Scans should complete no problem.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •