Home of the Squeezebox™ & Transporter® network music players.
Results 1 to 7 of 7
  1. #1
    Junior Member
    Join Date
    Aug 2006
    Posts
    18

    Squeezecenter album art formatting issue

    Anyone else seeing this album art formatting problem with Squeezecenter (see attached screenshot)?

    I'm running the release version of 7.0 and the default skin on a Gentoo Linux machine. If I set the interface to "hide artwork", it still leaves one large artwork placeholder showing. I assume that the right-hand artwork placeholders should be the same size as the ones one the left hand side.

    I wanted to check for any obvious lapse on my part before filing a bug report, so thanks for any help in advance.

  2. #2
    Senior Member
    Join Date
    Feb 2008
    Posts
    144
    I have seen nothing like that.

  3. #3
    Junior Member
    Join Date
    Feb 2008
    Posts
    26

    Not with the Generic icon, but...

    I've seen it a few times when my cover art is a bit wonky and needs re-doing (see below), and after replacing the art with Amazon standard size, etc. and re-scanning the Library, all is well.

    I've not seen it do this with the Generic icon though.

    Odd, that...
    Squeezebox Controller+ iPhone w/iPeng+ iPad w/Squeezepad > Squeezebox 3 > Garden Hose > Sunbeam Model 5 Mixmaster > Free-Range Chicken > Two Soup Cans and a String > Kazoo

  4. #4
    Babelfish's Best Boy mherger's Avatar
    Join Date
    Apr 2005
    Location
    Switzerland
    Posts
    20,396

    Squeezecenter album art formatting issue

    > Anyone else seeing this album art formatting problem with Squeezecenter
    > (see attached screenshot)?


    Please run a full scan with artwork logging set to debug
    (settings->advanced->logging). I wonder whether there's a problem with the
    GD.pm or libgd, or some artwork being corrupted. But as it's the default
    image...

    Michael

  5. #5
    Junior Member
    Join Date
    Aug 2006
    Posts
    18
    Here is the server log:

    [08-03-12 18:51:54.3864] Slim::Web::Graphics:rocessCoverArtRequest (215) missing artwork replaced by placeholder.
    [08-03-12 18:51:54.3889] Slim::Web::Graphics:rocessCoverArtRequest (233) got cover art image image/png of 13643 bytes
    [08-03-12 18:51:54.3900] Slim::Web::Graphics:rocessCoverArtRequest (474) Can't use GD for image/png (music/4503/cover_96x96_p.png)
    [08-03-12 18:51:54.3914] Slim::Web::Graphics:rocessCoverArtRequest (492) caching result key: cover-pad-96-96-0-.png, orig=
    [08-03-12 18:53:00.8658] Slim::Networking::Select::select (245) Error: Select task failed: Can't use an undefined value as a SCALAR reference at /opt/squeezecenter/Slim/Web/HTTP.pm line 1673.
    HTTP/1.1 200 OK
    Server: SqueezeCenter (7.0 - 17793)
    Connection: keep-alive
    Date: Wed, 12 Mar 2008 18:53:07 GMT
    Content-Length: 692
    Content-Type: text/plain

    [08-03-12 18:51:54.3864] Slim::Web::Graphics:rocessCoverArtRequest (215) missing artwork replaced by placeholder.
    [08-03-12 18:51:54.3889] Slim::Web::Graphics:rocessCoverArtRequest (233) got cover art image image/png of 13643 bytes
    [08-03-12 18:51:54.3900] Slim::Web::Graphics:rocessCoverArtRequest (474) Can't use GD for image/png (music/4503/cover_96x96_p.png)
    [08-03-12 18:51:54.3914] Slim::Web::Graphics:rocessCoverArtRequest (492) caching result key: cover-pad-96-96-0-.png, orig=
    [08-03-12 18:53:00.8658] Slim::Networking::Select::select (245) Error: Select task failed: Can't use an undefined value as a SCALAR reference at /opt/squeezecenter/Slim/Web/HTTP.pm line 1673.
    [08-03-12 18:53:08.2158] Slim::Networking::Select::select (245) Error: Select task failed: Can't use an undefined value as a SCALAR reference at /opt/squeezecenter/Slim/Web/HTTP.pm line 1673.

  6. #6
    Babelfish's Best Boy mherger's Avatar
    Join Date
    Apr 2005
    Location
    Switzerland
    Posts
    20,396

    Squeezecenter album art formatting issue

    > (474) Can't use GD for image/png (music/4503/cover_96x96_p.png)
    > [08-03-12 18:51:54.3914] Slim::Web::Graphics:rocessCoverArtRequest


    Is your libgd broken, outdated or something? What version do you have installed on what system?


    --

    Michael

  7. #7
    Junior Member
    Join Date
    Aug 2006
    Posts
    18
    Thanks for your help so far.

    I'm using Gentoo, latest kernel and up to date.

    homeserver ~ $ gdlib-config --all
    GD library 2.0.35
    includedir: /usr/include
    cflags: -I/usr/include
    ldflags: -L/usr/lib
    libs: -ljpeg -lpng12 -lz -lm
    libdir: /usr/lib
    features: GD_JPEG GD_PNG GD_GIF GD_GIFANIM GD_OPENPOLYGON

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •