Home of the Squeezebox™ & Transporter® network music players.
Results 1 to 2 of 2
  1. #1

    Linkstation Pro Freelink - Setting static IP & Maintaining Internet access

    Iím having some problems with setting static ip and maintaining Internet access on my Frelink Linkstation Pro

    If I enable the dhcp Internet access is fine but I want a fixed IP to setup my Squeezebox 3 Alien BBC etc

    When I use the script as below with my network particulars which are all based on a 192.168.10.1 gateway
    I get my required static ip but I loose my internet connection.

    In the old days one could add the
    Nameserver line in /etc/resolv.conf and all would be well
    but with current Debian this seems to be not so.

    I noted the below post from Tired legs written a few months back which still has the vi /etc/resolv.conf
    mentioned . When I try to do this I get some warning that the file will be overwritten.


    QUOTE
    When I FreeLinked my LS Pro, I used this sequence to create the static IP address:

    vi /etc/network/interfaces
    auto lo
    iface lo inet loopback
    auto eth0
    #iface eth0 inet dhcp
    iface eth0 inet static
    address 192.168.10.30
    network 192.168.10.0
    netmask 255.255.255.0
    #broadcast 192.168.10.255
    gateway 192.168.10.1
    #dns-nameservers 192.168.10.1
    [The lines starting with "#" were in the file previously. Adding "#" comments them out, but leaves them readable in case you need to back out the edits.]

    vi /etc/resolv.conf
    nameserver 192.168.10.1
    END QUOTE

    Iím no expert at this but has anyone got a working solution.

    I donít think my network is that unusual. I have a Cisco ADSL modem which acts as my router and is set up as 192.168.10.1
    This connects to an 8 port switch into which my PCís and Linkstation Pro are all hardwired. I also have a Linksys wireless router connected into the switch with ipís in the range 192.1687.1.x on the wireless side. This communicates fine with the SB3 and the SB3 and Linkstation Pro communicate just fine.

    I think I have the dhcp switched off on the Linksys leaving the Cisco doing all the dhcp stuff

    I saw an article somewhere on the net pointing out that one should bring down the network before making changes to /etc/network/interfaces. Clearly if I do this with an Ethernet connected Linkstation Iím not going to get very far as it will drop off my ssh session

    Should I add some nameservers into the above script?. Should I uncomment the broadcast? I think Iíve tried both
    Iím a bit nervous about random changes as some combination left me with a Linkstation I could not talk to without invoking EM mode

    Any ideas?

    Thanks in advance

    Eddie

  2. #2
    Did some more research and came up with this. I guess it could be the problem. I didn't realise I was at the cutting edge. Now to figure out how to upgrade my dh-client to unstable

    eddie



    John wrote:

    >> I add the appropriate lines into resolv.conf but it is overwritten on
    >> each restart.

    Joshua replied:

    >> This smells like the resolvconf package screwing things up. Resolvconf
    >> folks, feel free to reassign this back if you think this isn't your
    >> problem...


    First let me point out that if you have resolvconf installed then
    you should not make manual changes to the resolver configuration
    file because the file is automatically generated. You can indeed
    control what goes into the automatically generated file, but only
    by modifying the sources that are used to generate it. See
    resolvconf(8) for instructions.

    Note, however, that resolvconf never writes to /etc/resolv.conf
    directly. It sets up a symlink from /etc/resolv.conf to
    /etc/resolvconf/run/resolv.conf and then writes to the latter file.
    So if /etc/resolv.conf (itself, not its target) is being overwritten
    then resolvconf is not the culprit. There are lots of packages out
    there that futz with resolv.conf. One of my chief occupations during
    the past year has been hunting down all these packages and getting
    them to disable their trickery when resolvconf is installed. One
    package that slipped through the cracks until recently was
    dhcp-client, as discussed in #248399.

    To summarize #248399: until recently dhcp-client lacked resolvconf
    support. (Support was not added because it was expected that
    dhcp-client would be replaced by what is currently dhcp3-client.
    dhcp3-client has had resolvconf support for a long time. However,
    dhcp3-client never became dhcp-client and the installer is still
    installing dhcp-client.) Prior to the addition of resolvconf
    support, dhclient-script wrote directly to /etc/resolv.conf.

    echo search $new_domain_name >/etc/resolv.conf
    echo nameserver $nameserver >>/etc/resolv.conf

    Resolvconf's postinst sets up

    /etc/resolv.conf -> /etc/resolvconf/run/resolv.conf

    so with resolvconf installed, dhclient-script's information ended
    up in /etc/resolvconf/run/resolv.conf and was promptly overwritten
    by resolvconf.

    The solution to #248399 was to add resolvconf support to
    dhcp-client. This was done in dhcp-client version 2.0pl5-17 which
    was uploaded on 16 May 2004. That version hasn't made it into
    testing yet.

    With resolvconf support added, dhclient-script sends its information
    to resolvconf if it sees that resolvconf is installed and this
    information gets merged into the automatically generated file.

    John: I would appreciate it if you would check to make
    sure that this bug has been fixed. Install the broadband task
    again and upgrade dhcp-client to the latest from unstable. Your
    resolv.conf should be updated automagically.

    I am closing #251066 with this message, but please reopen it if
    it turns out that there is still a bug somewhere.
    --
    Thomas Hood

    So I installed unstable which gave me the dhcp3 version of things and everything is happy in debian land again

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •