Home of the Squeezebox™ & Transporter® network music players.
Page 2 of 2 FirstFirst 12
Results 11 to 12 of 12
  1. #11
    NOT a Slim Devices Employee kdf's Avatar
    Join Date
    Apr 2005
    Posts
    9,493

    "Clear and Rescan" not clearing?

    Quoting kyleki <kyleki.32zh4z1199990702 (AT) no-mx (DOT) forums.slimdevices.com>:

    >
    > kdf;256910 Wrote:
    >> It seems to me that you re asking is for the scan to force musicIP to
    >> refresh its database as part of the clear/rescan, which is exactly what
    >> this bug (and related thread) talks about as part of the scheduler.

    >
    > OK, cool. As long as it gets fixed in the mix I guess. I just figured
    > that a fix for this specific issue would be easier than having all the
    > extra development overhead of adding a scheduler.
    >

    The scheduler is already there. To do anything that refreshes MIP
    before a rescan does need some sort of new scheduler to check when MIP
    is done it's task. If it were simple, I'd have already done it.
    Anything would need some good testing to make sure MIP status info is
    accurate and predictable.

    -kdf


  2. #12
    Senior Member
    Join Date
    Nov 2005
    Location
    Southern California
    Posts
    184
    Quote Originally Posted by kdf View Post
    The scheduler is already there. To do anything that refreshes MIP before a rescan does need some sort of new scheduler to check when MIP is done it's task. If it were simple, I'd have already done it. Anything would need some good testing to make sure MIP status info is accurate and predictable.
    True. I suppose I was over simplifying it in my mind not realizing that the downstream scan stages would depend on when MIP finished its scan. Thanks for the clarification and I'm looking forward to seeing a fix sometime in the future. ;-)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •