Home of the Squeezebox™ & Transporter® network music players.
Page 1 of 2 12 LastLast
Results 1 to 10 of 13
  1. #1
    Junior Member
    Join Date
    May 2007
    Posts
    5

    Songs in same artist & album displayed seperately

    I am using 6.5.4 on Vista. I've noticed (also on earlier versions of SS) that songs by the same artist in the same album (stored in the same Artist\Album\ folder on my PC) are displayed separately. SS lists them in 4 different albums using the very same album name. The display is the same when I browse Albums and Artist.

    I tagged all the songs together so there is no issue with name formats, typos etc. Also, I noticed that on one instance SS added "(Disc 1)" at the end of the album name. Strange, since they all show up under the same (one) album in the PC folder structure AND in my Music Player (Music Match). Would appreciate ideas to fix this strange problem. Thanks in advance.
    Yodi

  2. #2
    Senior Member
    Join Date
    Feb 2007
    Location
    Spalding, Lincs, UK
    Posts
    649
    I would hazard a guess you've got some errant tags somewhere - if it's adding (Disc 1) you may well have discnumber tags you don't need.

    Best bet is to have a look at www.mp3tag.de/en - that's a great free tagger if you don't already have it.

    Open the offending files in mp3tag, look at their Extended Tags and delete all but the basics, ie title, track, year, album, artist, genre (your choices may differ!)

    Then for a belts-and-braces rescan stop SlimServer, delete the Cache folder and start SS again.

    Do you use iTunes with SS?

  3. #3
    Junior Member
    Join Date
    May 2007
    Posts
    5
    Thx for your reply. I've never used the tagger you mentioned. Been doing it manually, for the most part, from within Musicmatch. I will certainly give it a shot.

    I don't use iTunes. I did once but then realized that not only does it volunteer to format all your music folder/subfolder structure but also changes the filenames and does not give you an option to rename them the way you want. At least this was the case several months ago when I installed iTunes. So I stopped and don't plan on going back.

    Btw, most of the albums/artists I am having the tag issues with are direct copies from my CDs - thats why it puzzles me as to why its acting strangely.

  4. #4
    Senior Member
    Join Date
    Feb 2007
    Location
    Spalding, Lincs, UK
    Posts
    649
    Yup, iTunes can do that if you let it! mp3tag is great - I think you'll find it speeds things up for you. Always back everything up first though, if you're planning to do a mass-tagging!

    I found all manner of weird tags on some of my CD rips that I wasn't even aware of. mp3tag will show show you EVERYTHING, not all taggers do.

    Another thing to look for is whether you've got a mix of tags, ie if you've got id3v1 and v2 tags. Generally speaking SS is happier with just v2 tags, and mp3tag can remove all your unneeded v1 tags in one hit.

    Are the folders in question definitely in the format...

    Artist\Album\01-Track name.mp3
    Artist\Album\02-Track name.mp3

    ...etc? Post back if you're still having grief!

  5. #5
    Junior Member
    Join Date
    May 2007
    Posts
    5
    Installed and ran mp3tag last night. Took a couple of test runs and sneak-peeks at the help files to get used to the interface but i agree: the tool is awesome.

    It has already fixed some of the directories I was having issues with; not all, though. There are couple of albums (that I am working with) that still display the album names multiple times (in SS) with 1 or 2 songs under 1 listing and the rest in the other. Will go back re-try tonight. Also, just re-scanning changes doesn't change the SS display; I have to "clear and rescan from scratch" to see the changes gtake effect. This is really time consuming over 12000 songs. Any work-arounds?

    Also, you'd mentioned clearing the cache. How? I found one directory named "Cache" under server-> ... don't remember now. May be you can confirm so I know I am deleting/moving files from the right place.

    Running mp3tag over my whole collection will be intersting (even after I've backed it up). Overall, I think you've given me the solution I needed. Thanks!

  6. #6
    Senior Member SteveEast's Avatar
    Join Date
    Feb 2006
    Location
    Minneapolis, MN
    Posts
    599
    One of the things to try is to select all tracks on an album and do Right Mouse/Extended Tags. Then look at tags marked as <keep> - these are the tags that have different values across the selected tracks. Typically the only ones so marked would be Title and Track, plus possibly Discnumber (for a multi disc set) and some album replay gain stuff.

    Steve.

  7. #7
    Senior Member
    Join Date
    Feb 2007
    Location
    Spalding, Lincs, UK
    Posts
    649
    The cache folder you've found is indeed the one. If you've done loads of small tagging changes SS sometimes misses them, so it's a good habit to periodically stop SS, delete this folder and then restart - that'll build it from scratch

    There's no work round for rescanning, apart from navigating to the newly retagged files on your Squeezebox via the Music Folder browse. I use iTunes, so Music Folder doesn't display for me so can't tell you any more about it! I believe it means you navigating to the physical location of the file which in turn prompts SS to rescan it.

    Are all of the offending files in one folder? If not, move them all into one folder, open that folder with mp3tag and cut everything apart from track, title, album, artist, genre, year and artwork.

    Then delete stop SS, delete cache and restart.

    It **must** be some tagging weirdness, somewhere! Did you cut all bar id3v2 tags out?

  8. #8
    Junior Member
    Join Date
    May 2007
    Posts
    5
    >> Are all of the offending files in one folder?

    Impressive: you seem to have all the answers i.e., I just looked and found the very first file in a seperate folder. Will fix it. I also noticed that SS was picking up some of the displayed folders & files from the "Recycled Bin". This was the cause of some of the redundant displays. As soon as I emptied the Recycled Bin some of the offending folders/files disappeared. Will look into the rest tonight.

    >> Did you cut all bar id3v2 tags out?

    How do I do this? I looked at some of the folders and the tags are displayed like -> ID3V2.3 (ID3V1 ID3V2.3). Does this mean it now has 2 tags and I can get rid of ID3V1? Would appreciate if you tell me how (using mp3tag).

    You've been a great help. Appreciate it.

  9. #9
    Senior Member
    Join Date
    Feb 2007
    Location
    Spalding, Lincs, UK
    Posts
    649
    Ah, good. Thought it might be the folder thing - even if all your tags are exactly the same, if the files are in different physical locations SS doesn't know they're part of the same album, however moving all of these files into one folder tells SS they are in fact supposed to be treated as one!

    If you open options in mp3tag (Ctrol+O) then set the options as per the attached jpegs, that should do it.

    Then, in theory, whenever you select tags and hit Save, all bar id3v2 tags are removed. If they aren't, then the alternative is to right click the files in question in mp3tag and hit "Remove tags" - provided you've set your options as detailed that should leave you with only id3v2 tags. Again, you can do this operation in bulk, but that's a) brave and b) potentially upsetting without... that's right, a backup!

    Of course, thinking about it, if you're not using iTunes you could always set your tags to be id3v2.4 UTF-8 (Tags > MPEG > Write) - that way you'll get more flexible tagging options (not least album and artist sort fields that SS can use, for example youi could display Paul McCartney, but SS would sort that as McCartney, Paul)

    Post back with your results!
    Last edited by moley6knipe; 2007-10-12 at 00:14.

  10. #10
    Junior Member
    Join Date
    May 2007
    Posts
    5
    Sry for the delayed post. I backed up my entire music folder and performed a mass tag conversion, keeping only the essentials and getting rid of the rest. The older tag removal options were selected by default so I didnt change anything there.

    After I rescanned my folder within SS all the duplicates vanished!!! Thanks a bunch (again) - your ideas were right on the money from the very beginning.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •