Home of the Squeezebox™ & Transporter® network music players.
Results 1 to 7 of 7
  1. #1
    Junior Member
    Join Date
    Aug 2007
    Posts
    3

    Question Albums split across duplicate entries…. I tried, and failed to fix it.

    All,

    I’m a fairly recent squeezebox convert. I was so please with the hardware I bought a second SB3 one week after receiving the first. However I’m having a few problems with the server software. I have been battling it on an off for the last month (whenever I get time) Now I have to admit defeat - I just don’t understand why its behaving the way it is.

    The problem is that Slimserver is splitting some albums across several entries in the album list, each of which contains a few tracks. It only does it with a few albums but it does it enough to make browsing very frustrating.

    For example take the Beatles 1967-1970 (Disc 1) which is stored in the following directory structure:

    Audio
    *The Beatles
    **1967-1970 (Disc 1)

    Two tracks: “A Day In The Life” and “Hello, Goodbye” are in the same directory (Audio\The Beatles\1967-1970 (Disc 1)). However the album 1967-1970 (Disc 1) appears several times in the album list and these two tracks are listed separately.

    These were ripped a while back in my ipod days, but I have checked the tags in Mp3tag and they are consistent.

    The properties of these two tracks are:

    Title: A Day In The Life
    Artist: The Beatles
    Album: 1967-1970 (Disc 1)
    Genre: Classic Rock
    Track: 6
    File Format: MP3
    Duration: 5:04
    Year: 1973
    File Length: 3,659,974 Bytes
    Bitrate: 96kbps CBR
    Sample Rate: 44.1 kHz
    ID3 Tag Version: ID3v2.3.0
    Location: D:\Audio\The Beatles\1967-1970 (Disc 1)\The Beatles - 1967-1970 (Disc 1) - 06 - A Day In The Life.mp3 (Download)
    Date Modified: Friday, December 29, 2006, 12:51:57 AM

    and,

    Title: Hello, Goodbye
    Artist: The Beatles
    Album: 1967-1970 (Disc 1)
    Genre: Classic Rock
    Track: 9
    File Format: MP3
    Duration: 3:18
    Year: 1973
    File Length: 2,380,386 Bytes
    Bitrate: 96kbps CBR
    Sample Rate: 44.1 kHz
    ID3 Tag Version: ID3v2.3.0
    Location: D:\Audio\The Beatles\1967-1970 (Disc 1)\The Beatles - 1967-1970 (Disc 1) - 09 - Hello, Goodbye.mp3 (Download)
    Date Modified: Friday, December 29, 2006, 12:51:59 AM

    It’s pretty obvious that they are from the same album, and I know the tags are reasonable because both Windows Media Player and iTunes correctly list both these tracks as one album. Slimserver gets it completely wrong, yet strangely it gets Disc 2 right!?

    I started out with Slimserver version 6.5.2 and have gone back to 6.2.2 but that did not fix it. I have not tried 6.5.3 yet, but this kind of behaviour is not listed in the readme. I also searched the forum, but came up blank. Can anyone give me a clue what I’m doing wrong as I’m completely stumped :-(.

    Thanks in advance……………..



    D

  2. #2
    Senior Member
    Join Date
    Feb 2007
    Location
    Spalding, Lincs, UK
    Posts
    649
    That is a strange one. I can't see anything that would suggest why SS has got those wrong. I'm assuming the info you listed is taken from the SS web interface, yes?

    I can only suggest stopping SS, deleting the cache and restarting. P'raps it just needs a lie down!

  3. #3
    Junior Member
    Join Date
    Aug 2007
    Posts
    3
    Thanks for taking time to reply moley6knipe. Unfortunately I have tried that several times over the last few months. That said, the last thing I did was removed the comments from some of the tags and then I did not do a full rescan (it takes soooo long) so I'll give that a go tonight and report back.

    thanks

    D

  4. #4
    Senior Member Patrick Dixon's Avatar
    Join Date
    Apr 2005
    Location
    UK
    Posts
    1,805
    Have you got any disc number tags set?

  5. #5
    Senior Member adamslim's Avatar
    Join Date
    Sep 2006
    Location
    St Albans, UK
    Posts
    1,217
    You can also have several different tag types set - say ID3v2.3 and 2.4 - which may not contain the same data. You can fix this in MP3Tag by going to options > tags > mpeg, checking all the read and remove checkboxes, setting it to write only those you want, and then selecting your entire library, do Ctrl-X (cut) and then Ctrl-V (paste).

    Or just rerip them - 96kbps, really!

    Adam
    PC, JRiver/Qobuz, Digital XO, Asus Xonar u7, Restek Sextet, JBL L300
    LMS: 3xBoom, 1xRadio, SB3

  6. #6
    Junior Member
    Join Date
    May 2007
    Posts
    6
    I am having the same problem. I had been running an older version of Slim Server (not sure which one, at least 18 months old) until today when I decided to upgrade. Now, about 1/3 of my artists have duplicate entries for a single album.

    Here is an example of what I see:
    http://burningshore.com/pics/misc/slimserver.JPG

    Alice in Chains' "Dirt" has four entries. The entire album was ripped from a CD at the same time, years ago. All tags are marked as ID3v2.3.0. All songs on the album are in the same folder.

    I did not have this problem until I upgraded to 6.5.4 today.

    Any ideas?

  7. #7
    Junior Member
    Join Date
    May 2007
    Posts
    6
    UPDATE - Just before going to bed, I was going to try to revert back to an older version of the Slimserver. I could not find one for download, so instead I tried the nightly build (6.5.5) and re-scanned the entire library. This fixed the issue. I'm not sure if the fix was in the new version or something else, but it seems to be back to normal.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •