Home of the Squeezebox™ & Transporter® network music players.
Results 1 to 3 of 3
  1. #1
    Junior Member
    Join Date
    Jul 2007
    Posts
    2

    Problem playing MP3 from library

    I can't play any of my mp3 from my library, however I can play internet radio without problems.
    I switched on d_source debugging and got this in the log file:
    Matched Format: mp3 Type: mp3 Command: -
    openSong: this is an mp3 file: file:///D:/Musik/MP3/dr%20hook%20-%20Who%20The%20F%20Is%20Alice.mp3
    file type: mp3 format: mp3 inrate: 160 maxRate: 0
    command: -
    openSong: opening file D:\Musik\MP3\dr hook - Who The F Is Alice.mp3
    openSong: seeking in 2087 into D:\Musik\MP3\dr hook - Who The F Is Alice.mp3
    MP3 file was not encoded with LAME, will not play back gapless
    openSong: Streaming with format: mp3
    00:04:20:07:a4:43 New play mode: play
    00:04:20:07:a4:43: Current playmode: play
    Error opening current track, so mark it as already played
    Backtrace:

    frame 0: Slim::Player::Source::errorOpening (/<C:\Programmer\SlimServer\server\slim.exe>Slim/Player/Squeezebox2.pm line 579)
    frame 1: Slim::Player::Squeezebox2::failedDirectStream (/<C:\Programmer\SlimServer\server\slim.exe>Slim/Networking/Slimproto.pm line 527)
    frame 2: Slim::Networking::Slimproto::_disco_handler (/<C:\Programmer\SlimServer\server\slim.exe>Slim/Networking/Slimproto.pm line 387)
    frame 3: Slim::Networking::Slimproto::client_readable (/<C:\Programmer\SlimServer\server\slim.exe>Slim/Networking/Select.pm line 238)
    frame 4: (eval) (/<C:\Programmer\SlimServer\server\slim.exe>Slim/Networking/Select.pm line 238)
    frame 5: Slim::Networking::Select::select (slimserver.pl line 492)
    frame 6: main::idle (slimserver.pl line 35)
    frame 7: PerlSvc::Startup (perlsvc line 850)
    frame 8: PerlSvc::_startup (slimserver.pl line 0)
    frame 9: (eval) (slimserver.pl line 0)

    00:04:20:07:a4:43: Switching to mode stop from play
    00:04:20:07:a4:43 New play mode: stop
    Stopping and clearing out old chunks for client 00:04:20:07:a4:43
    Resetting song queue
    resetSongQueue: Song queue is now 0
    00:04:20:07:a4:43: Current playmode: stop
    .
    Anyone know how to fix this?

    TIA,
    Tommy

  2. #2
    Senior Member Anoop M.'s Avatar
    Join Date
    Dec 2006
    Location
    San Jose, California
    Posts
    302
    Quote Originally Posted by tlarsen View Post
    I can't play any of my mp3 from my library, however I can play internet radio without problems.
    I switched on d_source debugging and got this in the log file:
    Matched Format: mp3 Type: mp3 Command: -
    openSong: this is an mp3 file: file:///D:/Musik/MP3/dr%20hook%20-%20Who%20The%20F%20Is%20Alice.mp3
    file type: mp3 format: mp3 inrate: 160 maxRate: 0
    command: -
    openSong: opening file D:\Musik\MP3\dr hook - Who The F Is Alice.mp3
    openSong: seeking in 2087 into D:\Musik\MP3\dr hook - Who The F Is Alice.mp3
    MP3 file was not encoded with LAME, will not play back gapless
    openSong: Streaming with format: mp3
    00:04:20:07:a4:43 New play mode: play
    00:04:20:07:a4:43: Current playmode: play
    Error opening current track, so mark it as already played
    Backtrace:

    frame 0: Slim::Player::Source::errorOpening (/<C:\Programmer\SlimServer\server\slim.exe>Slim/Player/Squeezebox2.pm line 579)
    frame 1: Slim::Player::Squeezebox2::failedDirectStream (/<C:\Programmer\SlimServer\server\slim.exe>Slim/Networking/Slimproto.pm line 527)
    frame 2: Slim::Networking::Slimproto::_disco_handler (/<C:\Programmer\SlimServer\server\slim.exe>Slim/Networking/Slimproto.pm line 387)
    frame 3: Slim::Networking::Slimproto::client_readable (/<C:\Programmer\SlimServer\server\slim.exe>Slim/Networking/Select.pm line 238)
    frame 4: (eval) (/<C:\Programmer\SlimServer\server\slim.exe>Slim/Networking/Select.pm line 238)
    frame 5: Slim::Networking::Select::select (slimserver.pl line 492)
    frame 6: main::idle (slimserver.pl line 35)
    frame 7: PerlSvc::Startup (perlsvc line 850)
    frame 8: PerlSvc::_startup (slimserver.pl line 0)
    frame 9: (eval) (slimserver.pl line 0)

    00:04:20:07:a4:43: Switching to mode stop from play
    00:04:20:07:a4:43 New play mode: stop
    Stopping and clearing out old chunks for client 00:04:20:07:a4:43
    Resetting song queue
    resetSongQueue: Song queue is now 0
    00:04:20:07:a4:43: Current playmode: stop
    .
    Anyone know how to fix this?

    TIA,
    Tommy
    Is it only mp3's that will not play? Check for antivirus and firewalls as well. If you have them installed try uninstalling them to see if the files will play then.

  3. #3
    Junior Member
    Join Date
    Jul 2007
    Posts
    2
    Disabling my firewall and antivirus software did not resolve the problem.
    From the logfile is says:
    frame 0: Slim::Player::Source::errorOpening (/<C:\Programmer\SlimServer\server\slim.exe>Slim/Player/Squeezebox2.pm line 579)
    but wats the reason for this and how do I fix it?
    thanks,
    Tommy

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •